X
Tryk her for at gå til webstedets mobilversion.

Supportforum

installed new version, now all the fonts show up as boxed ????? how do I fix?

Skrevet

all the copy shows up as boxed question marks

all the copy shows up as boxed question marks
Vedhæftede skærmbilleder
Citér

Yderligere systemdetaljer

Program

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:71.0) Gecko/20100101 Firefox/71.0

Yderligere information

Luk
FredMcD
  • Top 10 Contributor
4308 løsninger 60484 svar

Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1

Type '''about:preferences#content'''<enter> in the address bar. Across from '''fonts and colors,''' press the '''Advanced''' button. On the bottom, turn on '''Allow Web Sites To Choose Their Own.''' Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1
Fandt du dette nyttigt?
Citér
cor-el
  • Top 10 Contributor
  • Moderator
17683 løsninger 159975 svar

This usually happens if you use third-party font managers that store their fonts is a not standard location. Firefox on Mac uses a rather restricted sandbox and blocks access to most of the file system and thus blocks access to the font file if the font isn't in a standard system location. Firefox isn't able to access the requested font and falls back to a 'last resort' font that shows all glyphs as a '?' or an 'A'.

You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.


You can check for sandbox security issues when Firefox has a problem to access fonts installed locally.

You can set this pref to 2 or 1 on the about:config page to reduce the sandbox security level.

  • security.sandbox.content.level = 1
  • close and restart Firefox to make the change effective.

If '1' still doesn't have effect then try '0' to disable the sandbox.

If this didn't work then undo/reverse the change and reset the pref via the right-click context menu to the default value.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

See also:

This usually happens if you use third-party font managers that store their fonts is a not standard location. Firefox on Mac uses a rather restricted sandbox and blocks access to most of the file system and thus blocks access to the font file if the font isn't in a standard system location. Firefox isn't able to access the requested font and falls back to a 'last resort' font that shows all glyphs as a '?' or an 'A'. You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected. *https://developer.mozilla.org/en-US/Tools/Page_Inspector/How_to/Examine_and_edit_HTML You can check in the <b>Rules</b> tab in the right panel in the Inspector what font-family is used for selected text. You can check in the <b>Font</b> tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website. *https://developer.mozilla.org/en-US/Tools/Page_Inspector/How_to/Edit_fonts ---- You can check for sandbox security issues when Firefox has a problem to access fonts installed locally. *https://wiki.mozilla.org/Security/Sandbox You can set this pref to 2 or 1 on the <b>about:config</b> page to reduce the sandbox security level. *security.sandbox.content.level = 1 *close and restart Firefox to make the change effective. If '1' still doesn't have effect then try '0' to disable the sandbox. If this didn't work then undo/reverse the change and reset the pref via the right-click context menu to the default value. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *https://support.mozilla.org/en-US/kb/about-config-editor-firefox See also: *https://wiki.mozilla.org/Security/Sandbox#Content_Levels
Fandt du dette nyttigt?
Citér
Stil et spørgsmål

Du skal logge ind på din konto for at svare på et indlæg. Start et nyt spørgsmål, hvis du ikke har en konto endnu.