X
Tryk her for at gå til webstedets mobilversion.

Supportforum

How to disable user prompt dialog: The proxy moz-proxy://xxxxxxx:8080 is requesting a username and password

Skrevet

I'm using firefox in linux for selenium test automation. Some of my automation tests need a sysproxy (provided by my company) to access internet. These prefs are set in my test

"network.proxy.type": 1, "network.proxy.http": "company.proxy.com", "network.proxy.http_port": 8080

When firefox launches up, a prompt dialog is always shown asking for credentials for the proxy. I've added company .pem in path ~/.mozilla/certificates and these .pem are loaded correctly in firefox.

Is there a way to disable the user prompt dialog?

I'm using firefox in linux for selenium test automation. Some of my automation tests need a sysproxy (provided by my company) to access internet. These prefs are set in my test "network.proxy.type": 1, "network.proxy.http": "company.proxy.com", "network.proxy.http_port": 8080 When firefox launches up, a prompt dialog is always shown asking for credentials for the proxy. I've added company .pem in path ~/.mozilla/certificates and these .pem are loaded correctly in firefox. Is there a way to disable the user prompt dialog?
Citér

Yderligere systemdetaljer

Installerede plugins

None

Program

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/75.0.3770.142 Safari/537.36

Yderligere information

Luk
cor-el
  • Top 10 Contributor
  • Moderator
17681 løsninger 159964 svar

Does setting signon.autologin.proxy = true work ?

See also Proxy:

Does setting signon.autologin.proxy = true work ? See also Proxy: *https://github.com/mozilla/policy-templates/blob/master/README.md
Fandt du dette nyttigt?
Citér

Spørgsmålsstiller

No, signon.autologin.proxy = true doesn't work. All .pems that our company proxy requires are installed via policies.json. I can see them in certificate manager.

No, signon.autologin.proxy = true doesn't work. All .pems that our company proxy requires are installed via policies.json. I can see them in certificate manager.
Fandt du dette nyttigt?
Citér
Stil et spørgsmål

Du skal logge ind på din konto for at svare på et indlæg. Start et nyt spørgsmål, hvis du ikke har en konto endnu.