Search Support

How do I stop Firefox from automatically compressing downloaded files?

  • 5 svar
  • 1 har dette problem
  • 134 visninger
  • Seneste svar af cor-el

more options

I've disabled NTFS compression in windows 10 through the command line, registry changes. Firefox still automatically compresses files I download. No other browser does this (Chrome, Edge).

Valgt løsning

Are you compressing the temp folder (%TMP%, %TEMP%) ?

Læs dette svar i sammenhæng 👍 1

All Replies (5)

more options

A couple other users have reported similar issues in the past, although no one appears to have ever been about to reproduce the problem.

NTFS compression is handled by the Windows operating system, not Firefox. Firefox plays no role in file compression. You will want to make sure that you have disabled NTFS compression in Windows 10.

Other than that, a user on Reddit said that a clean reinstall fixed the issue for them.

Steps for a clean reinstall can be found in the Uninstall Firefox from your computer documentation. If you plan on removing your user data as outlined in the document, you will want to make sure to back up your Firefox data BEFORE doing so.

Hope this helps.

more options

I disabled NTFS compression on Windows 10 before I came to this support site. I attempted a clean reinstall, including deleting all residual firefox folders after uninstalling before reinstalling.

It still automatically compresses files downloaded from the internet. I know this is a problem with the Firefox browser because this issue does not occur with any of the other browsers (Chrome, Edge, etc).

more options

Valgt løsning

Are you compressing the temp folder (%TMP%, %TEMP%) ?

more options

Uncompressing the temp folder fixed the problem, thank you.

more options

Note that this is likely because Firefox starts downloading the file in the background to the temp folder and then later copies the compressed file to the destination folder.