X
Tryk her for at gå til webstedets mobilversion.

Supportforum

The emails open in multiple tabs automatically

Skrevet

Quite recent at least beginning of 2019, I notice my thunderbird opens automatically email in multiple tabs. I did not request for it. Even when I scroll my mail folder, it randomly open the mail and put it in different tab. I hate it and I have to close all of them and if I leave my thunderbird on whole day and scroll for mail, I get more like 15+ tab of mail.

Whenever I close my thunderbird, I make sure I do not leave any mail open on a tab. I close everything.

Never happen in my life since I started using Thunderbird if I am not mistaken, late 90s.

Can I disable this function?

Quite recent at least beginning of 2019, I notice my thunderbird opens automatically email in multiple tabs. I did not request for it. Even when I scroll my mail folder, it randomly open the mail and put it in different tab. I hate it and I have to close all of them and if I leave my thunderbird on whole day and scroll for mail, I get more like 15+ tab of mail. Whenever I close my thunderbird, I make sure I do not leave any mail open on a tab. I close everything. Never happen in my life since I started using Thunderbird if I am not mistaken, late 90s. Can I disable this function?
Citér

Yderligere systemdetaljer

Program

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

Yderligere information

Luk
Toad-Hall
  • Top 10 Contributor
1793 løsninger 12065 svar

If you are only using the Message List scrollbar then you are not selecting any email and nothing will open, but the list will move up or down to reveal messages in the list.

A single left click on an email in a Message List will open the email in the lower 'Message Pane' providing the 'Message Pane' is enabled.

If you use the up and down arrow keys on keyboard to move up and down the Message List, this will also act like you performed a single left click on email and will open the email in the lower 'Message Pane' providing the 'Message Pane' is enabled.

If the 'Message Pane' is not enabled then nothing will open with a single left click or use of arrow keys.


A double left click on an email in the Message List will open an email in a new Tab or Window, depending upon what settings are selected in Options.


Do you have the 'Message Pane' enabled? If no: You can enable the Message Pane by any of the following methods:

  1. Via 'Menu Bar': 'View' > 'Layout' > select 'Message Pane'
  2. Via 'Menu icon': hover over 'Options' > select 'Layout' > select 'Message Pane'
  3. Toggle the view using the 'F8' key on keyboard.

You can choose whether a double click will open emails in a new tab or window: Via 'Menu Bar': 'Tools' > 'Options' OR Via 'Menu icon': click on 'Options'

In Options window select 'Display' and the 'Advanced' tab Open messages in: There are three options. Most people prefer 'A new tab' But you can choose to open in 'A new message window' or 'An exisitng message window' click on 'OK'


If you have the Message Pane enabled and you think you are using a single left click, but it opens in a new tab, then it is possible your mouse may be malfunctioning or mouse settings need adjustment. Your mouse sends the signal to your computer and if computer perceives a double click then the program will perform a double click function, hence opening email in a tab.

In some cases a lengthy left click - holding down a bit too long, may be perceived by the computer as a double click. This may be fixed by altering your mouse settings as they could be too sensitive.

If you are only using the Message List scrollbar then you are not selecting any email and nothing will open, but the list will move up or down to reveal messages in the list. A single left click on an email in a Message List will open the email in the lower 'Message Pane' providing the 'Message Pane' is enabled. If you use the up and down arrow keys on keyboard to move up and down the Message List, this will also act like you performed a single left click on email and will open the email in the lower 'Message Pane' providing the 'Message Pane' is enabled. If the 'Message Pane' is not enabled then nothing will open with a single left click or use of arrow keys. A double left click on an email in the Message List will open an email in a new Tab or Window, depending upon what settings are selected in Options. Do you have the 'Message Pane' enabled? If no: You can enable the Message Pane by any of the following methods: # Via 'Menu Bar': 'View' > 'Layout' > select 'Message Pane' # Via 'Menu icon': hover over 'Options' > select 'Layout' > select 'Message Pane' # Toggle the view using the 'F8' key on keyboard. You can choose whether a double click will open emails in a new tab or window: Via 'Menu Bar': 'Tools' > 'Options' OR Via 'Menu icon': click on 'Options' In Options window select 'Display' and the 'Advanced' tab Open messages in: There are three options. Most people prefer 'A new tab' But you can choose to open in 'A new message window' or 'An exisitng message window' click on 'OK' If you have the Message Pane enabled and you think you are using a single left click, but it opens in a new tab, then it is possible your mouse may be malfunctioning or mouse settings need adjustment. Your mouse sends the signal to your computer and if computer perceives a double click then the program will perform a double click function, hence opening email in a tab. In some cases a lengthy left click - holding down a bit too long, may be perceived by the computer as a double click. This may be fixed by altering your mouse settings as they could be too sensitive.

Ændret af Toad-Hall den

Fandt du dette nyttigt?
Citér
williamjameson 0 løsninger 5 svar

I have message pane enable so that emails open in a separate window. I like to highlight multiple emails to delete from the inbox. Problem is sometimes I get the Pop Up asking if I want to open multiple emails & I choose no, nothing else happens. But sometimes multiple emails open automatically.

My mouse settings are set to the lowest setting so I don't see how this is the problem. I'm using a wireless mouse, I believe its a Logitech. Isn't there a way to deactivate the Pop up Email nuisance ? I noticed the Configuration Editor function. So which function disables that pop up ? I know to go to the Advance Features and choose Options to Config Editor and all I have to do is double click to deactivate or disable.

If it disables all pop ups I can live with that since I've been online since 1993 with WIN 3.0 also known as the days of the 33k modem or slooooow motion. I'm PC literate but this email is taxing my time. Thank you!!

I have message pane enable so that emails open in a separate window. I like to highlight multiple emails to delete from the inbox. Problem is sometimes I get the Pop Up asking if I want to open multiple emails & I choose no, nothing else happens. But sometimes multiple emails open automatically. My mouse settings are set to the lowest setting so I don't see how this is the problem. I'm using a wireless mouse, I believe its a Logitech. Isn't there a way to deactivate the Pop up Email nuisance ? I noticed the Configuration Editor function. So which function disables that pop up ? I know to go to the Advance Features and choose Options to Config Editor and all I have to do is double click to deactivate or disable. If it disables all pop ups I can live with that since I've been online since 1993 with WIN 3.0 also known as the days of the 33k modem or slooooow motion. I'm PC literate but this email is taxing my time. Thank you!!
Fandt du dette nyttigt?
Citér
Toad-Hall
  • Top 10 Contributor
1793 løsninger 12065 svar

re :I have message pane enable so that emails open in a separate window.

I think you might mean the Message Pane is disabled. The 'Message Pane' is not showing below the list of emails in the Thread Pane.

This means a single click will not open an email because the 'Message Pane' is closed.

So any opening of emails is relying on a 'Double click' signal sent from mouse to computer.

re :like to highlight multiple emails to delete from the inbox. Problem is sometimes I get the Pop Up asking if I want to open multiple email

Highlighting of multiple email requires that you do one of following: Hold down 'Ctrl' key on keyboard whilst using mouse left click to select * various emails.

  • Click on first email, Hold down 'Shift' whilst left clicking on last email to highlight all emails between as well.


If a load of highlighted emails are opening in a new window then you have made an error when selecting and I reproduce this with ease.

The computer carries out the instructions it gets from the keyboard and mouse which comes from you.

With same setup as you: Whilst holding down 'Ctrl' key I can click to select/highlight emails, but if I accidentally click one twice in rapid succession as I'm trying to select one email below another then all selected/highlighted emails are opening in a new window. This is basic user error and is often the most common reason for the problem you are describing.

Other reasons for a mouse sending wrong signal to computer: Often, people use a mouse for a long time and do not notice that their personal reaction time has altered. A slightly long or wobbled depressed click can be interpreted as a double click. Usually this can rectified by adjusting the sensitivity of the mouse or it may mean the mouse itself is becoming worn out.

In some cases the mouse and keyboard have not been cleaned in a while and this can effect the signals. eg: dirt under the 'ctrl' key can mean it is not always being detected as depressed and you select a couple of email in rapid succession - result computer thinks it has received a double click instruction.

If all is clean and you not accidentally causing the error then it is probable the Mouse has just reached end of life and is starting to misbehave.


re :Problem is sometimes I get the Pop Up asking if I want to open multiple email That annoying pop up asking if you want to open emails means you have inadvertantly applied some instruction. It would be really useful to see an image of this pop up as it sounds like it could be something else. Usually, you do not get asked to open emails in Thunderbird that is auto performed by single and or double click.

re :''I have message pane enable so that emails open in a separate window. '' I think you might mean the Message Pane is disabled. The 'Message Pane' is not showing below the list of emails in the Thread Pane. This means a single click will not open an email because the 'Message Pane' is closed. So any opening of emails is relying on a 'Double click' signal sent from mouse to computer. re :''like to highlight multiple emails to delete from the inbox. Problem is sometimes I get the Pop Up asking if I want to open multiple email'' Highlighting of multiple email requires that you do one of following: Hold down 'Ctrl' key on keyboard whilst using mouse left click to select * various emails. * Click on first email, Hold down 'Shift' whilst left clicking on last email to highlight all emails between as well. If a load of highlighted emails are opening in a new window then you have made an error when selecting and I reproduce this with ease. The computer carries out the instructions it gets from the keyboard and mouse which comes from you. With same setup as you: Whilst holding down 'Ctrl' key I can click to select/highlight emails, but if I accidentally click one twice in rapid succession as I'm trying to select one email below another then all selected/highlighted emails are opening in a new window. This is basic user error and is often the most common reason for the problem you are describing. Other reasons for a mouse sending wrong signal to computer: Often, people use a mouse for a long time and do not notice that their personal reaction time has altered. A slightly long or wobbled depressed click can be interpreted as a double click. Usually this can rectified by adjusting the sensitivity of the mouse or it may mean the mouse itself is becoming worn out. In some cases the mouse and keyboard have not been cleaned in a while and this can effect the signals. eg: dirt under the 'ctrl' key can mean it is not always being detected as depressed and you select a couple of email in rapid succession - result computer thinks it has received a double click instruction. If all is clean and you not accidentally causing the error then it is probable the Mouse has just reached end of life and is starting to misbehave. '''re :'''''Problem is sometimes I get the Pop Up asking if I want to open multiple email'' That annoying pop up asking if you want to open emails means you have inadvertantly applied some instruction. It would be really useful to see an image of this pop up as it sounds like it could be something else. Usually, you do not get asked to open emails in Thunderbird that is auto performed by single and or double click.
Fandt du dette nyttigt?
Citér
williamjameson 0 løsninger 5 svar

Good points but we still have several program related problems.

1- The user needs greater control of the program to eliminate this program error. Eliminate the pop up with a "check box" same as delete emails warning message that gives us the option to turn off the pop up. The open multiple emails pop up can't be turned off. Hope they can fix that because its maddening. But that don't ask me again check box shuts down the message.

2- Better mice but even with a wired mouse or my "new" wireless mouse the program goes nuts. Bad news is my PC doesn't have the same plug as my mouse so I'll be going back to a wireless mouse.

Is anyone who is reading message an employee of Mozilla ? If not I'll try to find a way to get it to them even if I have to snail mail it. Good news is, I adjusted mouse settings but the gremlin is still there but slower. What I hate is when it opens multiple emails without even popping up.

Good points but we still have several program related problems. 1- The user needs greater control of the program to eliminate this program error. Eliminate the pop up with a "check box" same as delete emails warning message that gives us the option to turn off the pop up. The open multiple emails pop up can't be turned off. Hope they can fix that because its maddening. But that don't ask me again check box shuts down the message. 2- Better mice but even with a wired mouse or my "new" wireless mouse the program goes nuts. Bad news is my PC doesn't have the same plug as my mouse so I'll be going back to a wireless mouse. Is anyone who is reading message an employee of Mozilla ? If not I'll try to find a way to get it to them even if I have to snail mail it. Good news is, I adjusted mouse settings but the gremlin is still there but slower. What I hate is when it opens multiple emails without even popping up.
Fandt du dette nyttigt?
Citér
Toad-Hall
  • Top 10 Contributor
1793 løsninger 12065 svar

re :Is anyone who is reading message an employee of Mozilla

'Mozilla' are not Thunderbird. The people who offer support are other Thunderbird users offering their help in a purely voluntary unpaid manner.

The actual opening of emails is not a Thunderbird problem, it is a user problem or a mouse problem.

re:1- The user needs greater control of the program to eliminate this program error. There is no program error.

re:1- Eliminate the pop up with a "check box" same as delete emails warning message that gives us the option to turn off the pop up. The open multiple emails pop up can't be turned off.

Could you please post an image of that particular pop up window. So I can try to identify it and possibly find a solution for you. I've tried to recreate a pop up regarding opening emails, but not successful so far. So it must be a particular trigger that generates it. Image would really help.

re :''Is anyone who is reading message an employee of Mozilla '' 'Mozilla' are not Thunderbird. The people who offer support are other Thunderbird users offering their help in a purely voluntary unpaid manner. The actual opening of emails is not a Thunderbird problem, it is a user problem or a mouse problem. re:1- '' The user needs greater control of the program to eliminate this program error.'' There is no program error. re:1- ''Eliminate the pop up with a "check box" same as delete emails warning message that gives us the option to turn off the pop up. The open multiple emails pop up can't be turned off. '' Could you please post an image of that particular pop up window. So I can try to identify it and possibly find a solution for you. I've tried to recreate a pop up regarding opening emails, but not successful so far. So it must be a particular trigger that generates it. Image would really help.
Fandt du dette nyttigt?
Citér
williamjameson 0 løsninger 5 svar

I'll take a picture of the image and upload it later today, my phone is at home, I left without it.

To trigger the warning open the Inbox and use the Shift key and select 10 or 15 or whatever number of emails and the message below pops up

"Opening 20 messages may be slow. Continue?"

Once you use shift & scroll down to select a number of emails the pop up warning should appear.

I'll take a picture of the image and upload it later today, my phone is at home, I left without it. To trigger the warning open the Inbox and use the Shift key and select 10 or 15 or whatever number of emails and the message below pops up "Opening 20 messages may be slow. Continue?" Once you use shift & scroll down to select a number of emails the pop up warning should appear.
Fandt du dette nyttigt?
Citér
Toad-Hall
  • Top 10 Contributor
1793 løsninger 12065 svar

re :I'll take a picture of the image and upload it later today, my phone is at home, I left without it.

Why do you need the phone ?

When you get the pop up, press 'Prt Scr' button on keyboard to capture a screendump. open the 'Paint' program Right click in Paint and select 'Paste'.

Save image as type .jpg on desktop.

In this forum question, type something like 'here is the image' in a 'Post a Reply' text box. Below that text box: Click on 'Browse' locate the *.jpg image on desktop and click on 'Open'. Image gets uploaded. When uploaded click on 'Post Reply'

re :I'll take a picture of the image and upload it later today, my phone is at home, I left without it. Why do you need the phone ? When you get the pop up, press 'Prt Scr' button on keyboard to capture a screendump. open the 'Paint' program Right click in Paint and select 'Paste'. Save image as type '''.jpg''' on desktop. In this forum question, type something like 'here is the image' in a 'Post a Reply' text box. Below that text box: Click on 'Browse' locate the *.jpg image on desktop and click on 'Open'. Image gets uploaded. When uploaded click on 'Post Reply'
Fandt du dette nyttigt?
Citér
Toad-Hall
  • Top 10 Contributor
1793 løsninger 12065 svar

re :"Opening 20 messages may be slow. Continue?"

Thanks for the info. I've managed to get some info on this. It was created about 7 years ago after a bug report of not warning users when large numbers of windows were about to be opened which could use lots of memory and cpu.

That specific message was created to warn people that slowness could occur due to memory and cpu usage when opening a large number of windows / tabs etc.

Options > Advanced > General click on Config Editor' In 'Config Editor' the relevant preference is:

  • mailnews.open_window_warning; 10
  • mailnews.open_tab_warning; 20

The number 10 set as default integer value is the trigger limit when opening mesasge in new windows. As memory and cpu is lower when opening in tabs it means the default threshold is higher eg: 20.

This means if you select/highlight say 6 emails and then get the click wrong or press 'Enter', it will auto open all those selected emails, but if you had selected 10 or more and then got the click wrong or pressed 'Enter' , you would see the pop up. This explains why you see pop up on some occasions but not all.

If you set the integer value to 0 (zero) then this would stop the pop up warning, but obviously you do this understanding that warning helps to prevent the cpu from high usage.

To reset value: Either: double click on line OR: right click and select 'Modify This opens a small window to enter a different value. Enter 0 and press ok

re :"Opening 20 messages may be slow. Continue?" Thanks for the info. I've managed to get some info on this. It was created about 7 years ago after a bug report of not warning users when large numbers of windows were about to be opened which could use lots of memory and cpu. That specific message was created to warn people that slowness could occur due to memory and cpu usage when opening a large number of windows / tabs etc. Options > Advanced > General click on Config Editor' In 'Config Editor' the relevant preference is: * mailnews.open_window_warning; 10 * mailnews.open_tab_warning; 20 The number 10 set as default integer value is the trigger limit when opening mesasge in new windows. As memory and cpu is lower when opening in tabs it means the default threshold is higher eg: 20. This means if you select/highlight say 6 emails and then get the click wrong or press 'Enter', it will auto open all those selected emails, but if you had selected 10 or more and then got the click wrong or pressed 'Enter' , you would see the pop up. This explains why you see pop up on some occasions but not all. If you set the integer value to 0 (zero) then this would stop the pop up warning, but obviously you do this understanding that warning helps to prevent the cpu from high usage. To reset value: Either: double click on line OR: right click and select 'Modify This opens a small window to enter a different value. Enter 0 and press ok
Fandt du dette nyttigt?
Citér
williamjameson 0 løsninger 5 svar

I'll try the ConfigEditor idea and hopefully that will shut down the culprit. I got lucky and found Paint in WIN7 so the screen capture worked. I'll update either way. If you can't see the image I'll try again. Thank you !!!

I'll try the ConfigEditor idea and hopefully that will shut down the culprit. I got lucky and found Paint in WIN7 so the screen capture worked. I'll update either way. If you can't see the image I'll try again. Thank you !!!
Fandt du dette nyttigt?
Citér
williamjameson 0 løsninger 5 svar

It worked, no more crazy email openings for several days. Plus yesterday I updated mouse drivers and the scrolling is better. Thanks again!

It worked, no more crazy email openings for several days. Plus yesterday I updated mouse drivers and the scrolling is better. Thanks again!
Fandt du dette nyttigt?
Citér
Stil et spørgsmål

Du skal logge ind på din konto for at svare på et indlæg. Start et nyt spørgsmål, hvis du ikke har en konto endnu.