Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Restore session only loading 10 tabs after latest update

  • 7 svar
  • 1 har dette problem
  • 36 visninger
  • Seneste svar af FFoxer

more options

I have been using the "restore session" feature along with a setting in Firefox to load all tabs simultaneously in the background for a while now and it has worked great. But after the latest update to Firefox about two weeks ago (now version 67.0), Firefox only loads 10 tabs of the previous session, instead of all of them like it used to. I need about 30 tabs for work, so this feature made it very convenient. Any suggestions? Thank you.

Alle svar (7)

more options

Hi FFoxer, I'm sorry to hear about this problem. Another user reported a similar thing, but we haven't figured out the cause of it. Here's a link to that thread to see whether any of the discussion or suggestions is helpful to you:


more options

Hmm, I noticed:

FFoxer said

I have been using the "restore session" feature along with a setting in Firefox to load all tabs simultaneously in the background for a while now and it has worked great.

Do you mean you set this preference to false in about:config to force inactive (background) tabs to load as well:


Maybe that is related, since it's probably a rare setting.

Could you turn off the feature to "unload" pages in less active tabs when memory is low in case the two settings conflict:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste lowmem and pause while the list is filtered

(3) Double-click the browser.tabs.unloadOnLowMemory preference to switch the value from true to false

Not sure that will make any difference, but it's worth a try.

more options

Thank you for the reply, jscher2000. Yes, I am using the browser.sessionstore.restore_on_demand = false setting. I don't mind waiting a minute or so after the browser starts for all the tabs to load so that I then have immediate access to them.

I have now changed the lowmem setting as per your instructions and will open about 30 tabs.

I will let you know in a couple of days (after a few system shutdowns) if the tabs persist.

Thank you and BR

more options

Note that there is also:

  • browser.sessionstore.restore_tabs_lazily
more options

Aaaaaaand ... they're gone. After about a week (5 system shutdowns or so), Firefox is back to just loading 10 tabs.

So, changing the browser.tabs.unloadOnLowMemory setting to false doesn't solve the problem.

I will now also try changing the browser.sessionstore.restore_tabs_lazily setting.

I'm willing to give it another go. It is quite annoying tho, so will probably be switching to Chrome if this doesn't get fixed.


more options

Yesterday's update has a fix for one bug that leads to incomplete restores. Did you already have that installed before the latest incident?


more options

Hi jscher2000 and thank you. No, I'm on 67.0.1. The "About FIrefox" box is prompting me to restart the browser in order to update.

I will do that now and set up all my tabs again. I will leave thebrowser.sessionstore.restore_tabs_lazily setting alone for now.

Will let you know in a few days if it works.