X
Tryk her for at gå til webstedets mobilversion.

Supportforum

Download failed. Please check your connection.

Skrevet

I had to do a reset on Windows 10 today,and installed Firefox just a half hour ago,i tried to get an add on but its saying in a long red box Download failed. Please check your connection.That add on was working great before my reset was done,is there a problem with Firefox because my connection is working great?

I had to do a reset on Windows 10 today,and installed Firefox just a half hour ago,i tried to get an add on but its saying in a long red box Download failed. Please check your connection.That add on was working great before my reset was done,is there a problem with Firefox because my connection is working great?

Valgt løsning

Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps.

In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled

  1. Go to [=] > Options > Privacy & Security.
  2. Make sure Allow Firefox to install and run studies is check marked.

I you had it disabled, you can disable studies again after your add-ons have been re-enabled.

They are working on a general fix that doesn't need to rely on this and will keep you updated.

Læs dette svar i sammenhæng 2

Yderligere systemdetaljer

Installerede plugins

tried to install them but getting that same message Download failed. Please check your connection.

Program

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Yderligere information

Luk
cor-el
  • Top 10 Contributor
  • Moderator
17569 løsninger 158915 svar

There is a problem with an expired intermediate certificate that is used to sign extensions. This is being worked on by the Add-ons team.

See:

At about 6:10 PST we received a report that a certificate issue for Firefox is causing add-ons to stop working and add-on installs to fail.
Our team is actively working on a fix. We will update as soon as we have more information.
  • Bug 1548973 - (armagadd-on-2.0) All extensions disabled due to expiration of intermediate signing cert

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

There is a problem with an expired intermediate certificate that is used to sign extensions. This is being worked on by the Add-ons team. See: *[[/questions/1257928]] Will the disabling of add-ons be fixed, or is it the new way? *https://discourse.mozilla.org/t/certificate-issue-causing-add-ons-to-be-disabled-or-fail-to-install/39047 <blockquote><pre>At about 6:10 PST we received a report that a certificate issue for Firefox is causing add-ons to stop working and add-on installs to fail. Our team is actively working on a fix. We will update as soon as we have more information.</pre></blockquote> *[https://bugzilla.mozilla.org/show_bug.cgi?id=1548973 Bug 1548973] - (armagadd-on-2.0) All extensions disabled due to expiration of intermediate signing cert (<i>please do not comment in bug reports<br>https://bugzilla.mozilla.org/page.cgi?id=etiquette.html</i>)
Chris Ilias
  • Moderator
357 løsninger 1952 svar

Valgt løsning

Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps.

In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled

  1. Go to [=] > Options > Privacy & Security.
  2. Make sure Allow Firefox to install and run studies is check marked.

I you had it disabled, you can disable studies again after your add-ons have been re-enabled.

They are working on a general fix that doesn't need to rely on this and will keep you updated.

Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps. In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled # Go to '''[=] > Options > Privacy & Security'''. # Make sure '''Allow Firefox to install and run studies''' is check marked. I you had it disabled, you can disable studies again after your add-ons have been re-enabled. They are working on a general fix that doesn't need to rely on this and will keep you updated.
Poochae 0 løsninger 2 svar

All of my Firefox extensions and themes have also suddenly disappeared and cannot be re-downloaded. I followed your suggestion and checked 'Allow Firefox to install and run studies' to no avail. Is there anything else I can do since Firefox is my default browser?

Thank you.

All of my Firefox extensions and themes have also suddenly disappeared and cannot be re-downloaded. I followed your suggestion and checked 'Allow Firefox to install and run studies' to no avail. Is there anything else I can do since Firefox is my default browser? Thank you.
cor-el
  • Top 10 Contributor
  • Moderator
17569 løsninger 158915 svar

You can temporarily set app.normandy.run_interval_seconds to a lower value (21600 => 60) to see whether that installs the hotfix. Close and restart Firefox and check about:studies.

  • hotfix-update-xpi-signing-intermediate-bug-1548973
  • hotfix-reset-xpi-verification-timestamp-1548973

You may have to refresh the about:studies page a few times.

Do NOT forget to reset app.normandy.run_interval_seconds when about:studies shows that the hotfix has been applied.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

See also:

Other option are to install the certificate manually in the Certificate Manager.

You can temporarily set <b>app.normandy.run_interval_seconds</b> to a lower value (21600 => 60) to see whether that installs the hotfix. Close and restart Firefox and check <b>about:studies</b>. *hotfix-update-xpi-signing-intermediate-bug-1548973 *hotfix-reset-xpi-verification-timestamp-1548973 You may have to refresh the about:studies page a few times. Do NOT forget to reset <b>app.normandy.run_interval_seconds</b> when <b>about:studies</b> shows that the hotfix has been applied. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *http://kb.mozillazine.org/about:config See also: *https://support.mozilla.org/en-US/kb/add-ons-disabled-or-fail-to-install-firefox *https://blog.mozilla.org/addons/2019/05/04/update-regarding-add-ons-in-firefox/ Other option are to install the certificate manually in the Certificate Manager. *[/questions/1258208] plugins could not be verified firefox esr 52 *[/questions/1258275] How do I re-enable the add-ons WITHOUT being forced to upgrade
JohnDohe 0 løsninger 17 svar

I continue to have this problem despite enabling, "Allow Firefox to install and run studies".

This option has been enabled for 2 days.

The FF Hotfix Update XPI signing-intermediate-bug 1548973 is showing in about:studies

I have shutdown and rebooted.

Still I continue to have add-ons that don't work.

Even it I try to re-install them I get, "Download failed. Please check your connection."

What to do??

Thanks!

I continue to have this problem despite enabling, "Allow Firefox to install and run studies". This option has been enabled for 2 days. The FF Hotfix Update XPI signing-intermediate-bug 1548973 is showing in '''about:studies''' I have shutdown and rebooted. Still I continue to have add-ons that don't work. Even it I try to re-install them I get, "Download failed. Please check your connection." What to do?? Thanks!
jscher2000
  • Top 10 Contributor
8787 løsninger 71865 svar

Hi JohnDohe, since you are running Firefox 56.0.2, the hotfix is not applicable to your version. Please continue in the other thread about manually installing the certificate if you are unable or unwilling to update your Firefox. https://support.mozilla.org/en-US/questions/1258275?page=2#answer-1220067

Hi JohnDohe, since you are running Firefox 56.0.2, the hotfix is not applicable to your version. Please continue in the other thread about manually installing the certificate if you are unable or unwilling to update your Firefox. https://support.mozilla.org/en-US/questions/1258275?page=2#answer-1220067
Poochae 0 løsninger 2 svar

Cor-el Thank you for your suggestions. However, only the new 66.0.4 update restored FireFox.

Humongous thanks to the entire FireFox team for the great work you continue to do..

Cor-el Thank you for your suggestions. However, only the new 66.0.4 update restored FireFox. Humongous thanks to the entire FireFox team for the great work you continue to do..
cor-el
  • Top 10 Contributor
  • Moderator
17569 løsninger 158915 svar

There is a legacy system add-on planned for older Firefox versions. [url=https://bugzilla.mozilla.org/show_bug.cgi?id=1549604]Bug 1549604/url - ship legacy system add-ons to remediate armagadd-on 2.0

There is a legacy system add-on planned for older Firefox versions. [url=https://bugzilla.mozilla.org/show_bug.cgi?id=1549604]Bug 1549604[/url] - ship legacy system add-ons to remediate armagadd-on 2.0
whatthe 1 løsninger 7 svar

I'm running 66.0.4. My extensions were not re-enabled with the release. They are showing up now under legacy extensions. I attempted to reinstall one from addons.mozilla.org, and all of my extensions attempted an update. One was updated. The rest are still showing as legacy, and when I try to reinstall from addons.mozilla.org I get the message "Download failed. Please check your connection." I am definitely connected to the internet.

I'm running 66.0.4. My extensions were not re-enabled with the release. They are showing up now under legacy extensions. I attempted to reinstall one from addons.mozilla.org, and all of my extensions attempted an update. One was updated. The rest are still showing as legacy, and when I try to reinstall from addons.mozilla.org I get the message "Download failed. Please check your connection." I am definitely connected to the internet.
jscher2000
  • Top 10 Contributor
8787 løsninger 71865 svar

Hi whatthe, there are some glitches with the addition of the new certificate in Firefox 66.0.4.

First, can you check whether it got installed? We'll look on the Options page:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type cert and Firefox should filter to the Certificates section. Click the "View Certificates" button.

In the Certificate Manager dialog, click the "Authorities" tab. This is listed in alphabetical order by "issuer." Scroll down to where "Mozilla Corporation" should be. Is it there? I am attaching a screenshot for comparison.

If the certificate did not install:

Do you use a Master Password?

For some reason, having a master password set in Firefox 55 or earlier can cause a problem. You can change the password and re-save it as a workaround. Then clear the flag indicating to Firefox that you already got the update so it tries again. Here are the details:

(1) Change your Master Password

You can change the Master Password from itself to the same thing again. See the last section of this article entitled "Changing the master password": Use a Master Password to protect stored logins and passwords

(2) Reset a preference

This preference is set when the new certificate is inserted, and prevents it from being done again. We need to check whether it was added and, if it was, switch it off.

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(B) In the search box above the list, type or paste signer and pause while the list is filtered

(C) If the extensions.signer.hotfixed preference is bolded and "modified" to true, double-click it to set it to false

If you do not have that preference, great, no need to create it.

(3) Exit and restart Firefox and see whether it adds the certificate this time

Any luck?

Hi whatthe, there are some glitches with the addition of the new certificate in Firefox 66.0.4. First, can you check whether it got installed? We'll look on the Options page: * Windows: "3-bar" menu button (or Tools menu) > Options * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Linux: "3-bar" menu button (or Edit menu) > Preferences * Any system: type or paste '''about:preferences''' into the address bar and press Enter/Return to load it In the search box at the top of the page, type ''cert'' and Firefox should filter to the '''Certificates''' section. Click the "View Certificates" button. In the Certificate Manager dialog, click the "Authorities" tab. This is listed in alphabetical order by "issuer." Scroll down to where "Mozilla Corporation" should be. Is it there? I am attaching a screenshot for comparison. ''If the certificate did not install:'' '''Do you use a Master Password?''' For some reason, having a master password set in Firefox 55 or earlier can cause a problem. You can change the password and re-save it as a workaround. Then clear the flag indicating to Firefox that you already got the update so it tries again. Here are the details: (1) Change your Master Password You can change the Master Password from itself to the same thing again. See the last section of this article entitled "Changing the master password": [[Use a Master Password to protect stored logins and passwords]] (2) Reset a preference This preference is set when the new certificate is inserted, and prevents it from being done again. We need to check whether it was added and, if it was, switch it off. ''(A)'' In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. ''(B)'' In the search box above the list, type or paste '''signer''' and pause while the list is filtered ''(C)'' If the '''extensions.signer.hotfixed''' preference is bolded and "modified" to true, double-click it to set it to false If you do not have that preference, great, no need to create it. (3) Exit and restart Firefox and see whether it adds the certificate this time Any luck?
whatthe 1 løsninger 7 svar

Hi jscher2000.

Mozilla Corporation is not shown in the certificate manager. I've attached a screen shot.

Is there a way to download the certificate to import it?

I do use a Master Password, but since you said it causes problems in Firefox 55 or earlier and I am on 66.0.4 I did not change the Master Password.

I do not have the extensions.signer.hotfixed preference, so there's nothing to do there.

Thanks for your help.

Hi jscher2000. Mozilla Corporation is not shown in the certificate manager. I've attached a screen shot. Is there a way to download the certificate to import it? I do use a Master Password, but since you said it causes problems in Firefox 55 or earlier and I am on 66.0.4 I did not change the Master Password. I do not have the extensions.signer.hotfixed preference, so there's nothing to do there. Thanks for your help.
jscher2000
  • Top 10 Contributor
8787 løsninger 71865 svar

whatthe said

I do use a Master Password, but since you said it causes problems in Firefox 55 or earlier and I am on 66.0.4 I did not change the Master Password.

What I meant was, Firefox 66.0.4 has a problem adding the certificate if your Master Password has not been updated since the old days when there was a separate popup window to create the master password, compared with now, when it is an overlay inside the page. I don't know why. But please try using the steps in my last reply.

''whatthe [[#answer-1220463|said]]'' <blockquote> I do use a Master Password, but since you said it causes problems in Firefox 55 or earlier and I am on 66.0.4 I did not change the Master Password. </blockquote> What I meant was, Firefox 66.0.4 has a problem adding the certificate if your Master Password has not been updated since the old days when there was a separate popup window to create the master password, compared with now, when it is an overlay inside the page. I don't know why. But please try using the steps in my last reply.
whatthe 1 løsninger 7 svar

I was able to export the certificate from another computer also running 66.0.4, and was able to import it. Then I was able to download / reinstall the extensions. User settings for noscript were picked up by the install, so that's good. The adblock plus user settings were not imported so I unfortunately I will be starting fresh with that.

Thanks again for your help.

I was able to export the certificate from another computer also running 66.0.4, and was able to import it. Then I was able to download / reinstall the extensions. User settings for noscript were picked up by the install, so that's good. The adblock plus user settings were not imported so I unfortunately I will be starting fresh with that. Thanks again for your help.
whatthe 1 løsninger 7 svar

Correction: my previous adblock plus settings were picked up as well.

Correction: my previous adblock plus settings were picked up as well.