Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox looking for URLs when searching in address bar

  • 6 svar
  • 3 har dette problem
  • 16 visninger
  • Seneste svar af jscher2000

more options

Hello,

I recently switched over to Firefox from using Chrome.

The issue I'm having is that when I search in the address bar, if there is a '.' anywhere in the search terms, Firefox will try to look for a URL instead of just google searching like Chrome would.

In Chrome, if I type 'mongoose.js' into the address bar, it knows to search google instead of look for a URL.

In Firefox, if I type 'mongoose.js' into the address bar, it will search for a URL and give me a server not found page.

Things I've done: 1) Go to about:config and change 'browser.fixup.alternate.enabled' to false. 2) Go to about:config and made sure keyword.enabled is set to true.

I would really like to continue using Firefox instead of Chrome, but this is a convenience feature that is a necessity for me. I realize I can just add another search bar next to the address bar, but this should honestly just be a feature and I shouldn't have to add more clutter to my browser.

Any help would be greatly appreciated.

Alle svar (6)

more options

Unless there's a new workaround, I think you need to add a character that is illegal in a URL, for example:

  • 'mongoose.js (works at the beginning only)
  • "mongoose.js
  • mongoose.js"
more options

In addition to the above (a little nitpicking) :

You could just type  : mongoosejs

The correct URL to that site is :

https://mongoosejs.com/ .......

more options

McCoy said

In addition to the above (a little nitpicking) : You could just type  : mongoosejs The correct URL to that site is : https://mongoosejs.com/ .......

I could just type that, but it's beside the point that Firefox is still looking for URLs when it shouldn't be.

more options

It's not just Firefox who does this - other browsers show the same 'behavior'.

Instead of having to type an extra character, it would be easier and faster to leave a space in front or after the dot.

To use the 'moose.js' again : type moose .js or moose. js

(even though it is moosejs - still nitpicking, but you get the gist)

Edit : typo ....

Ændret af McCoy den

more options

McCoy said

It's not just Firefox who does this - other browsers show the same 'behavior'. Instead of having to type an extra character, it would be easier and faster to leave a space in front or after the dot. To use the 'moose.js' again : type moose .js or moose. js (even though it is moosejs - still nitpicking, but you get the gist) Edit : typo ....

Thats is not true, chrome does not do that at all.

more options

For what it's worth: this also works in recent versions:

  •  ?mongoose.js
  • mongoose.js?