Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why is Firefox saving webpages as .htm files instead of Firefox .html files?

  • 5 svar
  • 1 har dette problem
  • 15 visninger
  • Seneste svar af icemandave

more options

Firefox isn't saving webpages as Firefox HTML documents any more.

I have a bunch of webpages saved as Firefox HTML documents. In the folders they appear as one file with the Firefox logo and an accompanying folder with the same name. The names of the files used to pop up automatically with a description of the web page, and an html extension. Now when I try to save web pages, the file name always has an .htm extension, no folder with the pictures accompanies the download (which fails have the time), so opening the file gives a raw text mess instead of a webpage.

And yes, my default app settings in Windows 10 are set to have Firefox open .html files, but htm files are set to open with Edge, and I don't want to use htm. Why is Firefox saving them as htm files?

Also, I've tried setting Firefox as my default search engine (I use Firefox most, but have Edge as my default because Win 10 gets pissy if I don't), but it's still saving web pages as .htm files, which is text only and a mess to read.

Further note: I can save webpages with Google Chrome as complete html files and they will open with Firefox as a complete webpage.

Ændret af icemandave den

Alle svar (5)

more options

Did you look at the file properties?

more options

Yes. The problem is with the popup window you get when when you have the "save as" option chosen in Firefox. The default save format has been changed from .html to .htm, which doesn't work.

I've found a workaround in that I can manually add the "L" to the end of the filename extension, but another curious thing is that the first download, regardless of whether I save it as .htm or html, will ALWAYS fail. Only by then retrying the download via the downloads progress dropdown menu can I successfully save the webpage in a readable form.

I don't have this problem with Google Chrome: the default format of the "save as" popup window is html, and it will download correctly the first time. (For some unfathomable reason you can't save webpages with Edge, which a big part of why I don't use it for anything other than dealing with Microsoft.)

more options

Another user mentioned having to use Save Page As twice when using the "Web page, complete" (HTML file + folder) format:

When I Use the Save Page As menu option, it no longer saves the page properly

I don't know whether the file extension is a factor for him as well.

more options

You can inspect the MIME database key with the registry editor (regedit.exe) and do a search for that MIME type (file extension) via Ctrl+F. Be cautious with editing the registry as there is NO UNDO possible: all changes are applied immediately. You can export key(s) in the registry editor before making changes. You can check specific file extension keys (e.g. .html) in the registry with the registry editor.

  • HKEY_CLASSES_ROOT\.xxx

You can check a possibly linked MIME type in the MIME Database registry key.

  • HKEY_CLASSES_ROOT\MIME\Database\Content Type\
more options

I think I'll just manually enter the "l" at the end of the extension and retry the download every time rather than muck about with the registry. Or use Google Chrome, because it still works fine with that browser, so this is clearly a Firefox glitch.