Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Flash on a specific website is no longer working in Firefox since FF updated to 64.0 and subsequent updates.

  • 14 svar
  • 1 har dette problem
  • 25 visninger
  • Seneste svar af Aeranon

more options

I've been accessing the following website for years on Firefox with no issues. It uses Flash, and I've never had a problem playing the game until Firefox updated to 64.0. Now when I click to play the game, it says it is loading, but it never does. I have disabled any ad blocker or other similar add-on, but it doesn't help. I keep Flash up to date, and have even unchecked the box in the plugin that says "Block dangerous and intrusive Flash content" in case that was the problem, but that hasn't helped.

I can access the site and play the game on Chrome without a problem, but not on Firefox. I'm not the only one who uses this website who is having this problem.

Any ideas what is going on? I don't want to revert to Firefox 63.0.3 if I don't have to, but I'd prefer to play this game in Firefox if possible.

Website: http://webccgame.com/?page=home

Thank you!

Valgt løsning

Just to update and close this out, I can now play the game in Firefox. I don't know what changed (I haven't altered any of my settings since last posting), but it works now. As oddly and suddenly as it didn't work, now it does.

Thanks for trying to help!!

Læs dette svar i sammenhæng 👍 0

All Replies (14)

more options

Did you uninstall all flash for firefox and reinstall them?

more options

I've done that, but it doesn't help.

more options

So what is the site and where are you getting the flash install?

more options

http://webccgame.com/?page=play

I get Flash directly from Adobe Flash. I've always gotten it from there, and it's always worked on that site, until FF updated to 64.0. The site hasn't changed the way it works, so I can only assume it's FF, since the site works fine in Chrome with Adobe Flash.

Thanks for trying to help.

more options

Screenshot of the page in Firefox. It stays on "Loading Maps."

more options

Screenshot of the page in Chrome. What it should look like.

more options

Do you see the Lego block icon at the left end of the location bar indicating that the website want to use the Shockwave Flash plugin?

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block (wanted) content.

Firefox shows the shield icon at the left end of the location/address bar in case Content Blocking is blocking content.

  • click the shield icon for more detail and possibly disable the protection

You can check the Web Console about what content is blocked

more options

Thank you for the suggestions, but it's not helping. I have disabled all extensions, and no content is being blocked (I disabled blocking on the site), but the game map still won't load. It's so odd.

more options

I even deleted/removed all extensions from FF, rebooted, and it still doesn't work.

more options

You didn't confirm if you see the Lego block icon in Firefox. Other browsers may use a similar icon to notify you that the Flash plugin is used.

Can you confirm that this is a Flash object by right-clicking this area in another browser?

If you only see a loading icon then it is possible that content is retrieved via XHR in the background and that no plugin is used.

Did you check the Web Console for error messages like I posted above?

more options

Yes, I see the Lego block, and yes, this is a Flash object. I play the game in Chrome, where I have Flash set to ask me every time it wants to run/activate. Screenshot attached. When I click "allow" the game runs normally (and I have the latest version of Flash installed).

I have no error messages in the Web console, and do not have a shield icon indicating that content is being blocked.

Thanks for trying to help. Like I said, I play the game in Chrome, so I can keep doing that, but it's just really weird that it stopped working in FF when FF updated to 64.0.

more options

You aren't using Private Browsing mode in Firefox?

See also the Flash storage settings.

more options

No, I'm not using private browsing, or denying or limiting storage (and the game is only using 1% of its maximum storage capacity).

more options

Valgt løsning

Just to update and close this out, I can now play the game in Firefox. I don't know what changed (I haven't altered any of my settings since last posting), but it works now. As oddly and suddenly as it didn't work, now it does.

Thanks for trying to help!!