X
Tryk her for at gå til webstedets mobilversion.

Supportforum

Firefox 65 - cannot keep certain cookies when clearing all others

Skrevet

After update from firefox 64 to 65.0 it stopped keeping certain cookies when clearing all others, even though the same site is listed in exceptions as 'Allow' (e.g., this no longer works: https://support.mozilla.org/en-US/questions/1200198 ). I tried to remove and add it again but because I clear cookies when firefox closes this exception is no longer working. Please restore this functionality! I use Windows 10.

After update from firefox 64 to 65.0 it stopped keeping certain cookies when clearing all others, even though the same site is listed in exceptions as 'Allow' (e.g., this no longer works: https://support.mozilla.org/en-US/questions/1200198 ). I tried to remove and add it again but because I clear cookies when firefox closes this exception is no longer working. Please restore this functionality! I use Windows 10.
Citér

Yderligere systemdetaljer

Installerede plugins

  • Shockwave Flash 32.0 r0

Program

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0

Yderligere information

Luk
cor-el
  • Top 10 Contributor
  • Moderator
17269 løsninger 156091 svar

Keeping specific cookies that have an Allow exception is only possible if you let the cookies expire when you close 32-bit Firefox. Using other ways to clear cookies like "Clear history when Firefox closes" or clearing all cookies directly in Options/Preferences will remove all cookies.

In case you use "Clear history when Firefox closes" or otherwise clear history.

  • do not clear the Cookies
  • do not clear the Site Preferences
  • clearing "Site Preferences" clears exceptions for cookies, images, pop-up windows, and software installation and exception for password and other website specific data
  • clearing "Cookies" will remove all selected cookies including cookies with an "Allow" exception you may want to keep
Keeping specific cookies that have an Allow exception is only possible if you let the cookies expire when you close 32-bit Firefox. Using other ways to clear cookies like "Clear history when Firefox closes" or clearing all cookies directly in Options/Preferences will remove all cookies. In case you use "Clear history when Firefox closes" or otherwise clear history. *do not clear the Cookies *do not clear the Site Preferences *Options/Preferences -> Privacy & Security<br>Firefox will: "Use custom settings for history":<br>[X] "Clear history when Firefox closes" -> Settings *https://support.mozilla.org/en-US/kb/delete-browsing-search-download-history-firefox *clearing "Site Preferences" clears exceptions for cookies, images, pop-up windows, and software installation and exception for password and other website specific data *clearing "Cookies" will remove all selected cookies including cookies with an "Allow" exception you may want to keep
Fandt du dette nyttigt? 0
Citér

Spørgsmålsstiller

Hi cor-el,

Thank you for your reply but this does not help. I have to note that I use 64-bit firefox- does it make a difference?

I haven't changed any settings when I updated from firefox 64 to 65.0. And right now I have the following relevant settings:

(V for selected)

V Delete cookies and site data when Firefox is closed (this is selected)

In "Manage Permissions" I have one site listed as "Allow"

Under "History", I have "Use custom settings for history", V Clear history when firefox closes (selected) But in the Settings, both Cookies and Site Preferences are unselected. So this conforms to what you are saying, and is similar to what I had in firefox 64 (which I also had on a different computer until yesterday and which worked just fine; the names and layout changed somewhat from firefox 64 to 65). But the cookies from the "Allow" site are gone in firefox 65 after I close it.

It seems like what worked no longer works ...

Hi cor-el, Thank you for your reply but this does not help. I have to note that I use 64-bit firefox- does it make a difference? I haven't changed any settings when I updated from firefox 64 to 65.0. And right now I have the following relevant settings: (V for selected) V Delete cookies and site data when Firefox is closed (this is selected) In "Manage Permissions" I have one site listed as "Allow" Under "History", I have "Use custom settings for history", V Clear history when firefox closes (selected) But in the Settings, both Cookies and Site Preferences are unselected. So this conforms to what you are saying, and is similar to what I had in firefox 64 (which I also had on a different computer until yesterday and which worked just fine; the names and layout changed somewhat from firefox 64 to 65). But the cookies from the "Allow" site are gone in firefox 65 after I close it. It seems like what worked no longer works ...
Fandt du dette nyttigt?
Citér
philipp
  • Top 25 Contributor
  • Moderator
5266 løsninger 23291 svar

Nyttigt svar

currently there is a bug in 65 that permissions set for subdomains seem to override preferences for the top level domain. say you have set "mail.google.com" to be allowed for a session only, but "google.com" to be allowed in general, the latter cookies would be deleted after the session nevertheless.

could you please take a look in the permission manager and confirm if these circumstances apply to the cookies that don't get kept after the update any longer?

currently there is a bug in 65 that permissions set for subdomains seem to override preferences for the top level domain. say you have set "mail.google.com" to be allowed for a session only, but "google.com" to be allowed in general, the latter cookies would be deleted after the session nevertheless. could you please take a look in the permission manager and confirm if these circumstances apply to the cookies that don't get kept after the update any longer?
Fandt du dette nyttigt? 1
Citér

Spørgsmålsstiller

Thanks philipp - sounds like it's related, but I am not an expert. I hoped someone would look into it - It looks like there is a bug but no one is interested ... I guess I'll have to try out chrome.

Thanks philipp - sounds like it's related, but I am not an expert. I hoped someone would look into it - It looks like there is a bug but no one is interested ... I guess I'll have to try out chrome.
Fandt du dette nyttigt?
Citér
philipp
  • Top 25 Contributor
  • Moderator
5266 løsninger 23291 svar

marylandan said

I hoped someone would look into it - It looks like there is a bug but no one is interested ...

this is certainly not the case - the developers have already worked on a fix for the problem i've described which will land in tomorrow's beta build of firefox 66 and if everything goes well perhaps also into a version 65.0.1 next week.

''marylandan [[#answer-1194738|said]]'' <blockquote> I hoped someone would look into it - It looks like there is a bug but no one is interested ... </blockquote> this is certainly not the case - the developers have already worked on a fix for the problem i've described which will land in tomorrow's beta build of firefox 66 and if everything goes well perhaps also into a version 65.0.1 next week.
Fandt du dette nyttigt?
Citér

Spørgsmålsstiller

It's April now but the problem is still there - just wanted to mention it [now on version 66.0.2]. I've moved to chrome a while ago ... I understand that it's a free software, and this specific issue likely bothers/bothered few people. Still, things stopped working but the advertisement stands. Disappointing.

It's April now but the problem is still there - just wanted to mention it [now on version 66.0.2]. I've moved to chrome a while ago ... I understand that it's a free software, and this specific issue likely bothers/bothered few people. Still, things stopped working but the advertisement stands. Disappointing.

Ændret af marylandan den

Fandt du dette nyttigt?
Citér
cor-el
  • Top 10 Contributor
  • Moderator
17269 løsninger 156091 svar

You can try to use "Forget About This Site" for affected websites and if necessary create a cookie allow exception for the top level domain (https://google.com).

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note. You can avoid losing passwords by clearing the master password prompt (if necessary click "Show Logins" in the Password Manager).

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.

You can try to use "Forget About This Site" for affected websites and if necessary create a cookie allow exception for the top level domain (https://google.com). You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History"). Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note. You can avoid losing passwords by clearing the master password prompt (if necessary click "Show Logins" in the Password Manager). You can't recover from this 'forget' unless you have a backup of involved files. If you revisit a 'forgotten' website then data from that website will be saved once again. *https://support.mozilla.org/en-US/kb/delete-browsing-search-download-history-firefox
Fandt du dette nyttigt?
Citér

Spørgsmålsstiller

This did not help. Neither I expected it to help,because the problem is not that I have some extra information saved that might interfere somehow. The problem is that nothing is saved, even what's supposed to be saved. I've already described my settings above.

This did not help. Neither I expected it to help,because the problem is not that I have some extra information saved that might interfere somehow. The problem is that nothing is saved, even what's supposed to be saved. I've already described my settings above.
Fandt du dette nyttigt?
Citér
Stil et spørgsmål

Du skal logge ind på din konto for at svare på et indlæg. Start et nyt spørgsmål, hvis du ikke har en konto endnu.