Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Passwords not being saved

  • 17 svar
  • 3 har dette problem
  • 111 visninger
  • Seneste svar af arejfour

more options

Greetings,

Firefox isn't offering to save passwords for a site. Does it respect "autocomplete=off" in the password input field?

Thanks, Shane.

Ændret af Shane den

Alle svar (17)

more options

You are using the LastPass add-on. You should contact its support.

more options

LastPass didn't disable Firefox's built-in Password Manager.

Does Firefox respect "autocomplete=off" in the password input field?

Thanks, Shane.

more options

Why are you messing around in the about:config when you can just do that change in the browser privacy settings instead.

more options

What browser privacy WestEnd said

Why are you messing around in the about:config when you can just do that change in the browser privacy settings instead.

I'm not in about:config.

What browser privacy settings are you talking about?

more options

Firefox doesn't respect "autocomplete=off" for quite some time now. When Firefox doesn't offer to store the username and password then there is usually something with the login form on the website and the submit might be done via AJAX (JavaScript) and not via a submit button.

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)?

more options

cor-el said

Firefox doesn't respect "autocomplete=off" for quite some time now.

I couldn't find any documentation on this.

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)?

I sent you a private message.

Thanks, Shane.

more options

See: Bug 956906 - ignore autocomplete="off" when offering to save passwords via the password manager

more options

That's a very long article. It's going to take time for me to read through it.

more options

There is a pref available to toggle this behavior.

  • signon.storeWhenAutocompleteOff
more options

Shane said

It's going to take time for me to read through it.

Don't bother. Much of it is the programmers talking high-level stuff about the issue.

more options

FredMcD said

You are using the LastPass add-on. You should contact its support.

I tried clicking Menu > Help > Restart with Add-ons Disabled. The password is still not being filled in safe mode.

Shane.

more options

It's likely that LastPass is storing your passwords and disabling Firefox own manager.

more options

Firefox's password manager is currently turned on. I can confirm this because Firefox's password manager works with other websites.

This must be getting long because this was already discussed further up the page.

Shane.

more options

cor-el said

Can you post a link to a publicly accessible page

Shane said

I sent you a private message.

cor-el Did you have a chance to check the webpage?

more options

This problem is often caused by mal-coding on a site so Firefox does not understand that a form is there to save. The site uses other methods relying on JavaScript to accept your input, an example is Apples own site!

There is a new add-on/extension which by-passes the problem and allows you to force Firefox to remember your passwords, its called Save my Password.

Ændret af Charles8 den

more options

https://addons.mozilla.org/en-US/firefox/addon/save-my-password/ Save my Password by Juraj Mäsiar On some pages, Firefox won't ask you to store your login information. Using this add-on you can force Firefox to remember your password! This add-on is NOT a password manager!

more options

I have a web site ttps://www.medicare.uhc.com/aarp that FF asks to save the password but, in fact, doesn't. Very odd. I don't have this problem with this web iste in Chrome.