Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

how to block a website?

  • 6 svar
  • 1 har dette problem
  • 24 visninger
  • Seneste svar af McCoy

more options

hi sir

I wish to block the website below form my firefox browser but cant seem to block it, pls help.


thanks regards sean

Alle svar (6)

more options

Hi sean, when does that site show up? It sounds familiar from past threads about unwanted software/malware infections, but I can't remember the full details.

(1) As the first step, could you clear out any questionable extensions? Here's how:

You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything suspicious or that you just do not remember installing or why? If in doubt, disable (or remove).

(2) Next, check your home page setting on the Options page. Here's how:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the left column, click Home

Then on the right side, if your Home Page is set to use Custom URLs, check the addresses listed there to make sure you only have the page or pages you actually want to load.

(3) Finally, check whether your Firefox shortcut has been hijacked. Here's how:

Sometimes your home page setting is fine, but the icon you use to start Firefox has been modified to load an unwanted page. To investigate that:

First, open the shortcut properties as follows:

  • Desktop shortcut: right-click the icon, choose Properties
  • Pinned taskbar icon: right-click the icon, right-click Mozilla Firefox, choose Properties

Windows normally will select the Shortcut tab. If not, go ahead and click the Shortcut tab.

You'll see the Target highlighted. On Windows, that usually is no more and no less than one of the following (depending on 32-bit/64-bit):

"C:\Program Files\Mozilla Firefox\firefox.exe"
"C:\Program Files (x86)\Mozilla Firefox\firefox.exe"

If anything follows after that (for example, "http://example.com"), try clearing it out.

After OK'ing the Properties dialog, you can test right away to confirm that the Firefox shortcut now launches only your desired home page. Either:

  • double-click desktop shortcut
  • right-click pinned taskbar icon, click Mozilla Firefox


more options


Hao123 is an online listings portal by Baidu.. It has a Portuguese and a Thai version. Hao123 has been accused of internet hijacking by installing a virus that inserts Hao123 onto the Desktop.

more options

Other threads mention various malware infections, so you may also need to do some cleaning outside of Firefox.


more options

You may have ad/mal-ware. Further information can be found in this article; https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware?cache=no

Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.

more options

still cant remove it , kindly help,cheers!

more options

LMWS214 said

still cant remove it , kindly help,cheers!

Hello LMWS214,

Would you take a look at these search results please  ?