X
Tryk her for at gå til webstedets mobilversion.

Supportforum

reduce page size

Skrevet

Your pages are too HUGE for my screen. I Tried the 2012 suggests of Alt-spacebar, Size, etc. but "Size" is banched out, meaning it cannot be resized. Give me a real solution to fit everything on my screen at once!

Your pages are too HUGE for my screen. I Tried the 2012 suggests of Alt-spacebar, Size, etc. but "Size" is banched out, meaning it cannot be resized. Give me a real solution to fit everything on my screen at once!

Yderligere systemdetaljer

Program

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

Yderligere information

Luk
cor-el
  • Top 10 Contributor
  • Moderator
17538 løsninger 158577 svar

Make sure you run Firefox in desktop mode and not in tablet mode.

Check that you do not run Firefox in compatibility mode. You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab. Make sure that all items are deselected in the "Compatibility" tab of the Properties window.

Make sure you run Firefox in desktop mode and not in tablet mode. *https://www.top-password.com/blog/windows-10-switch-between-tablet-mode-and-desktop-mode/ Check that you do not run Firefox in compatibility mode. You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab. Make sure that all items are deselected in the "Compatibility" tab of the Properties window.

Spørgsmålsstiller

"You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab." This is gibberish since it is not apparent where the context menu is.

"You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab." This is gibberish since it is not apparent where the context menu is.
cor-el
  • Top 10 Contributor
  • Moderator
17538 løsninger 158577 svar

The context menu that is meant is the context menu that opens if you right-click the Firefox shortcut on the desktop (i.e. the shortcut icon you use to start Firefox via a double-click).

The context menu that is meant is the context menu that opens if you right-click the Firefox shortcut on the desktop (i.e. the shortcut icon you use to start Firefox via a double-click).

Spørgsmålsstiller

There is no "Compatibility" tab when I right-click the context menu.

There is no "Compatibility" tab when I right-click the context menu.
cor-el
  • Top 10 Contributor
  • Moderator
17538 løsninger 158577 svar

There is Properties in the context menu. The window that open if you click Properties has tabs and one of them is named Compatibility. You can check the items in this menu.

Can you attach a screenshot that shows this problem with web pages?

You may have accidentally zoomed web page(s). Reset the page zoom on pages that cause problems.

  • View -> Zoom -> Reset (Ctrl+0/Command+0 (zero))
There is Properties in the context menu. The window that open if you click Properties has tabs and one of them is named Compatibility. You can check the items in this menu. Can you attach a screenshot that shows this problem with web pages? *https://support.mozilla.org/en-US/kb/how-do-i-create-screenshot-my-problem *use a compressed image type like PNG or JPG to save the screenshot You may have accidentally zoomed web page(s). Reset the page zoom on pages that cause problems. *<b>View -> Zoom -> Reset</b> (Ctrl+0/Command+0 (zero)) *https://support.mozilla.org/en-US/kb/how-do-i-use-zoom

Spørgsmålsstiller

Okay. Been there, done that. No boxes check on the Compatibility tab. Saw a suggestion to go to full screen. No difference. Firefox is useless unless it can fit on my display. Can you please advise what to try next?

Okay. Been there, done that. No boxes check on the Compatibility tab. Saw a suggestion to go to full screen. No difference. Firefox is useless unless it can fit on my display. Can you please advise what to try next?
cor-el
  • Top 10 Contributor
  • Moderator
17538 løsninger 158577 svar

I'm still not sure what you are seeing, so could you please attach a screenshot like i requested above?

I'm still not sure what you are seeing, so could you please attach a screenshot like i requested above? *https://support.mozilla.org/en-US/kb/how-do-i-create-screenshot-my-problem *use a compressed image type like PNG or JPG to save the screenshot
jscher2000
  • Top 10 Contributor
8773 løsninger 71729 svar

Hi TimmyF, is this a problem with website content, or does the toolbar area (tabs, address bar, etc.) also have too large a font?

For websites, the best tool usually is zoom. You can hold down the Ctrl key and tap the - key a couple times to reduce the size of web content.

Does that help?

Hi TimmyF, is this a problem with website content, or does the toolbar area (tabs, address bar, etc.) also have too large a font? For websites, the best tool usually is zoom. You can hold down the Ctrl key and tap the - key a couple times to reduce the size of web content. Does that help?

Spørgsmålsstiller

Nope. It's like I'm seeing 60% of the screen. Using the zoom feature only reduces the text size, but does not fit the Firefox entire screen on my monitor. I have made a screen shot and saved it to a .png file, but cannot figure how to get it here. I have "copied" the picture, and tried to paste it here, but nothing happens.

Nope. It's like I'm seeing 60% of the screen. Using the zoom feature only reduces the text size, but does not fit the Firefox entire screen on my monitor. I have made a screen shot and saved it to a .png file, but cannot figure how to get it here. I have "copied" the picture, and tried to paste it here, but nothing happens.
jscher2000
  • Top 10 Contributor
8773 løsninger 71729 svar

Hi TimmyF, below the box where you type replies is a "Browse" button to attach images from your computer.

When Firefox's window is maximized, it should fit exactly to the screen; you should see the entire Firefox window. Is that working, at least, even if the web page shown in the Firefox window is too wide?


Sometimes the settings file that stores window dimensions becomes corrupted with nonsensical values. You can rename the file and have Firefox rebuild it. Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > Exit
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename xulstore.json to something like xulstoreOLD.json. If you see an older file named localstore.rdf, you can delete it.

Start Firefox back up again. Do windows display normally again?

That mini-reset will hide the menu bar and bookmarks toolbar. You can use one of these methods to show the toolbar list and select the desired bars there:

  • right-click (on Mac Ctrl+click) a blank spot on the tab bar (or the "+" button)
  • (menu bar) View > Toolbars
    On Windows, tap the Alt key to activate the menu bar temporarily.
  • in Customize mode > Toolbars button (see: Customize Firefox controls, buttons and toolbars)

To turn on the Bookmarks Toolbar, Menu Bar, or other bars, click it on the list.

Hi TimmyF, below the box where you type replies is a "Browse" button to attach images from your computer. When Firefox's window is maximized, it should fit exactly to the screen; you should see the entire Firefox window. Is that working, at least, even if the web page shown in the Firefox window is too wide? ---- Sometimes the settings file that stores window dimensions becomes corrupted with nonsensical values. You can rename the file and have Firefox rebuild it. Here's how: Open your current Firefox settings (AKA Firefox profile) folder using either * "3-bar" menu button > "?" Help > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste '''about:support''' in the address bar and press Enter In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows Explorer. Leaving that window open, switch back to Firefox and Exit, either: * "3-bar" menu button > Exit * (menu bar) File > Exit Pause while Firefox finishes its cleanup, then rename '''xulstore.json''' to something like xulstoreOLD.json. If you see an older file named localstore.rdf, you can delete it. Start Firefox back up again. Do windows display normally again? ''That mini-reset will hide the menu bar and bookmarks toolbar.'' You can use one of these methods to show the toolbar list and select the desired bars there: * right-click (on Mac Ctrl+click) a blank spot on the tab bar (or the "+" button) * (menu bar) View > Toolbars<br><em>On Windows, tap the Alt key to activate the menu bar temporarily.</em> * in Customize mode > Toolbars button (see: [[Customize Firefox controls, buttons and toolbars]]) To turn on the Bookmarks Toolbar, Menu Bar, or other bars, click it on the list.

Spørgsmålsstiller

https://prod-cdn.sumo.mozilla.net/uploads/images/2018-11-13-10-30-04-005254.png

Hopefully this is the image. I was just in another portal and had to use the horizontal and vertical navigation bars just to bring something into view.

https://prod-cdn.sumo.mozilla.net/uploads/images/2018-11-13-10-30-04-005254.png Hopefully this is the image. I was just in another portal and had to use the horizontal and vertical navigation bars just to bring something into view.
jscher2000
  • Top 10 Contributor
8773 løsninger 71729 svar

Nyttigt svar

Hi TimmyF, thanks for the screenshot. Is your screen resolution really 1024x768 (XGA) or was that image size reduced from the original size?

Could you copy/paste the first 3 lines in the box on this page into a reply:

https://www.jeffersonscher.com/res/resolution.php

For example, mine says:

JavaScript screen.width x screen.height = 1536 x 864 window.devicePixelRatio = 1.25 device pixels per CSS pixel Computed "true" screen.width x screen.height = 1920 x 1080

Hi TimmyF, thanks for the screenshot. Is your screen resolution really 1024x768 (XGA) or was that image size reduced from the original size? Could you copy/paste the first 3 lines in the box on this page into a reply: https://www.jeffersonscher.com/res/resolution.php For example, mine says: JavaScript screen.width x screen.height = 1536 x 864 window.devicePixelRatio = 1.25 device pixels per CSS pixel Computed "true" screen.width x screen.height = 1920 x 1080

Spørgsmålsstiller

JavaScript screen.width x screen.height = 819 x 614 window.devicePixelRatio = 1.25 device pixels per CSS pixel Computed "true" screen.width x screen.height = 1024 x 768

Yup; 1024 x 768 as suggested by Windows 10.

JavaScript screen.width x screen.height = 819 x 614 window.devicePixelRatio = 1.25 device pixels per CSS pixel Computed "true" screen.width x screen.height = 1024 x 768 Yup; 1024 x 768 as suggested by Windows 10.
jscher2000
  • Top 10 Contributor
8773 løsninger 71729 svar

Nyttigt svar

Most monitors now have higher resolution, so I'm surprised Windows would suggest 1024x768. Is that your system-level resolution or is that what it suggested for Firefox??

Firefox isn't currently using the full resolution because it is globally scaling everything by 125%. To reduce it to 100%:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button accepting the risk.

(2) In the filter box, type or paste devp and pause while the list is filtered -- there should only be one preference left

(3) Double-click layout.css.devPixelsPerPx and change its value to 1 (normally it's -1.0 so you can just remove the minus) and after double-checking that it is 1 and not 10, click OK.

What do you think? Is that more usable?

Most monitors now have higher resolution, so I'm surprised Windows would suggest 1024x768. Is that your system-level resolution or is that what it suggested for Firefox?? Firefox isn't currently using the full resolution because it is globally scaling everything by 125%. To reduce it to 100%: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button accepting the risk. (2) In the filter box, type or paste '''devp''' and pause while the list is filtered -- there should only be one preference left (3) Double-click '''layout.css.devPixelsPerPx''' and change its value to '''1''' (normally it's '''-1.0''' so you can just remove the minus) and after double-checking that it is 1 and not 10, click OK. What do you think? Is that more usable?

Spørgsmålsstiller

I think together we solved the problem. This is for your future reference in case you see it come up again. I did the change from -1.0 to 1. That changed the home window when I pulled up Foxfire to fit the screen as desired. But when I tried to open a new "favorite" (the folder created when I imported my favorites from IE11) site, it was the same old problem. I tried copying some of the "favorite" folder sites into the "other bookmarks" folder in Firefox just to see how they would opened. Lucky guess. They were perfectly scaled to the screen. So I started copying all the files from "favorites" to "other bookmarks". Unfortunately I lost some because it is a cumbersome process, and the "favorites" folder was accidentally deleted about half way through. Windows 10 (on my PC at least) does not offer a screen resolution of 1536 x 864, but I did increase change the "size of text" back to that recommended by MS. I may experiment with my screen resolution a bit to see what happens.

Much thanks for your patient attendance. It appears there was some type of adverse software interaction between Firefox and the "favorites" I had copied from IE11 that was causing the problem. Odd.

I think together we solved the problem. This is for your future reference in case you see it come up again. I did the change from -1.0 to 1. That changed the home window when I pulled up Foxfire to fit the screen as desired. But when I tried to open a new "favorite" (the folder created when I imported my favorites from IE11) site, it was the same old problem. I tried copying some of the "favorite" folder sites into the "other bookmarks" folder in Firefox just to see how they would opened. Lucky guess. They were perfectly scaled to the screen. So I started copying all the files from "favorites" to "other bookmarks". Unfortunately I lost some because it is a cumbersome process, and the "favorites" folder was accidentally deleted about half way through. Windows 10 (on my PC at least) does not offer a screen resolution of 1536 x 864, but I did increase change the "size of text" back to that recommended by MS. I may experiment with my screen resolution a bit to see what happens. Much thanks for your patient attendance. It appears there was some type of adverse software interaction between Firefox and the "favorites" I had copied from IE11 that was causing the problem. Odd.