X
Tryk her for at gå til webstedets mobilversion.

Supportforum

Videos autoplaying even with all the new settings

Skrevet

Until today the options for stopping videos auto playing worked OK, suddenly they don't work at all. I had changed all the settings in about:config - please see screen shot attached - a couple of weeks ago when they suddenly started auto playing and that solved the issue, but now I am back to square one. Even when I have ensured that the autoplay option is changed in the preferences section they are still auto-playing. Any suggestions please as this is driving me crazy!

Thanks in advance for your help. It is much appreciated.

Until today the options for stopping videos auto playing worked OK, suddenly they don't work at all. I had changed all the settings in about:config - please see screen shot attached - a couple of weeks ago when they suddenly started auto playing and that solved the issue, but now I am back to square one. Even when I have ensured that the autoplay option is changed in the preferences section they are still auto-playing. Any suggestions please as this is driving me crazy! Thanks in advance for your help. It is much appreciated.
Vedhæftede skærmbilleder

Yderligere systemdetaljer

Installerede plugins

  • Shockwave Flash 31.0 r0

Program

  • Firefox 63.0.1
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:63.0) Gecko/20100101 Firefox/63.0
  • Support-URL: https://support.mozilla.org/1/firefox/63.0.1/Darwin/en-US/

Udvidelser

  • Adblock Plus 3.3.1 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • New Tab Tools 89.1 (newtabtools@darktrojan.net)
  • Video DownloadHelper 7.3.5 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d})
  • IBM Security Rapport 2.1.24 (rapportext@trusteer.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Grafik

  • adapterDescription:
  • adapterDeviceID: 0x0a2e
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x8086
  • contentUsesTiling: True
  • crashGuards: []
  • driverDate:
  • driverVersion:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'OpenGL Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'OPENGL_COMPOSITING'}, {u'status': u'opt-in', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}], u'name': u'WEBRENDER'}, {u'status': u'blocked', u'description': u'WebRender qualified', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'No qualified hardware', u'type': u'env'}], u'name': u'WEBRENDER_QUALIFIED'}, {u'status': u'available', u'description': u'Off Main Thread Painting', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'OMTP'}]}
  • info: {u'TileHeight': 512, u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'ApzAutoscrollInput': 1, u'AzureFallbackCanvasBackend': u'none', u'TileWidth': 512, u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • offMainThreadPaintEnabled: True
  • offMainThreadPaintWorkerCount: 3
  • usesTiling: True
  • webgl1DriverExtensions: GL_ARB_blend_func_extended GL_ARB_draw_buffers_blend GL_ARB_draw_indirect GL_ARB_ES2_compatibility GL_ARB_explicit_attrib_location GL_ARB_gpu_shader_fp64 GL_ARB_gpu_shader5 GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_occlusion_query2 GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_separate_shader_objects GL_ARB_shader_bit_encoding GL_ARB_shader_subroutine GL_ARB_shading_language_include GL_ARB_tessellation_shader GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_cube_map_array GL_ARB_texture_gather GL_ARB_texture_query_lod GL_ARB_texture_rgb10_a2ui GL_ARB_texture_storage GL_ARB_texture_swizzle GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_vertex_attrib_64bit GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_texture_compression_s3tc GL_EXT_texture_filter_anisotropic GL_EXT_texture_sRGB_decode GL_APPLE_client_storage GL_APPLE_container_object_shareable GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_texture_range GL_ATI_texture_mirror_once GL_NV_texture_barrier
  • webgl1Extensions: ANGLE_instanced_arrays EXT_blend_minmax EXT_color_buffer_half_float EXT_frag_depth EXT_sRGB EXT_shader_texture_lod EXT_texture_filter_anisotropic EXT_disjoint_timer_query OES_element_index_uint OES_standard_derivatives OES_texture_float OES_texture_float_linear OES_texture_half_float OES_texture_half_float_linear OES_vertex_array_object WEBGL_color_buffer_float WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_depth_texture WEBGL_draw_buffers WEBGL_lose_context
  • webgl1Renderer: Intel Inc. -- Intel Iris OpenGL Engine
  • webgl1Version: 4.1 INTEL-10.6.33
  • webgl1WSIInfo: CGL
  • webgl2DriverExtensions: GL_ARB_blend_func_extended GL_ARB_draw_buffers_blend GL_ARB_draw_indirect GL_ARB_ES2_compatibility GL_ARB_explicit_attrib_location GL_ARB_gpu_shader_fp64 GL_ARB_gpu_shader5 GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_occlusion_query2 GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_separate_shader_objects GL_ARB_shader_bit_encoding GL_ARB_shader_subroutine GL_ARB_shading_language_include GL_ARB_tessellation_shader GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_cube_map_array GL_ARB_texture_gather GL_ARB_texture_query_lod GL_ARB_texture_rgb10_a2ui GL_ARB_texture_storage GL_ARB_texture_swizzle GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_vertex_attrib_64bit GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_texture_compression_s3tc GL_EXT_texture_filter_anisotropic GL_EXT_texture_sRGB_decode GL_APPLE_client_storage GL_APPLE_container_object_shareable GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_texture_range GL_ATI_texture_mirror_once GL_NV_texture_barrier
  • webgl2Extensions: EXT_color_buffer_float EXT_texture_filter_anisotropic EXT_disjoint_timer_query OES_texture_float_linear WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_lose_context
  • webgl2Renderer: Intel Inc. -- Intel Iris OpenGL Engine
  • webgl2Version: 4.1 INTEL-10.6.33
  • webgl2WSIInfo: CGL
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL
  • windowUsingAdvancedLayers: False

Ændrede indstillinger

Diverse

  • User JS: Nej
  • Tilgængelighed: Nej
Luk

Spørgsmålsstiller

It is very odd, especially as it all worked perfectly yesterday.

Thanks for all your help: I really do appreciate the support given online as I am not that tech savvy.

It is very odd, especially as it all worked perfectly yesterday. Thanks for all your help: I really do appreciate the support given online as I am not that tech savvy.
cor-el
  • Top 10 Contributor
  • Moderator
17348 løsninger 156811 svar

Nyttigt svar

Note that the second screenshot you posted in this reply shows the http: protocol and not the https: protocol like it should.

Note that the second screenshot you posted in [/questions/1239777?page=1#answer-1171022 this reply] shows the http: protocol and not the https: protocol like it should.

Spørgsmålsstiller

cor-el said

Note that the second screenshot you posted in this reply shows the http: protocol and not the https: protocol like it should.

Thank you for pointing that out. I have now changed it and the problem is still there.

''cor-el [[#answer-1171838|said]]'' <blockquote> Note that the second screenshot you posted in [/questions/1239777?page=1#answer-1171022 this reply] shows the http: protocol and not the https: protocol like it should. </blockquote> Thank you for pointing that out. I have now changed it and the problem is still there.
cor-el
  • Top 10 Contributor
  • Moderator
17348 løsninger 156811 svar

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History"). Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note. You can't recover from this 'forget' unless you have a backup of involved files. If you revisit a 'forgotten' website then data from that website will be saved once again. *https://support.mozilla.org/en-US/kb/delete-browsing-search-download-history-firefox

Spørgsmålsstiller

Thank you for this tip. I shall try it later and see if that solves the problem.

Thank you for this tip. I shall try it later and see if that solves the problem.

Spørgsmålsstiller

I just tried the 'forget about this site' option and that hasn't worked either. Thank you anyway for the suggestion.

I just tried the 'forget about this site' option and that hasn't worked either. Thank you anyway for the suggestion.
jscher2000
  • Top 10 Contributor
8583 løsninger 70213 svar

Could you explain the steps to trigger the problem? I don't understand this part --

KezzerN said

KezzerN said
It is a bit odd what is happening: if I right click on a video and open it in a new tab the auto-play works, but if I just open a new tab and go to youtube it doesn't work.

That should saying blocking the auto-play works if I right click, but doesn't work if I open a new tab or window.

I can say that Firefox's feature applies to whether scripts are allowed to start a video after the initial page load. They do not affect YouTube's "next video autoplay" feature that moves to the next video on a play list after the current video ends, I think because there is no new page load. I'm pretty sure there are add-ons to turn off that YouTube feature so you don't have to flip the blue switch yourself.

Which of these have the problem (autoplay occurs after setting 1 as the default permission) on your Firefox:

  • On YouTube, right-click a thumbnail > Open Link in New Tab
  • On YouTube, right-click a thumbnail > Open Link in New Window
  • Open a Google search result in a new tab (for example, thanksgiving stuffing site:youtube.com
  • Something else
Could you explain the steps to trigger the problem? I don't understand this part -- ''KezzerN [[#answer-1171032|said]]'' <blockquote> ''KezzerN [[#answer-1171031|said]]'' <blockquote> It is a bit odd what is happening: if I right click on a video and open it in a new tab the auto-play works, but if I just open a new tab and go to youtube it doesn't work. </blockquote> That should saying blocking the auto-play works if I right click, but doesn't work if I open a new tab or window. </blockquote> ''I can say that Firefox's feature applies to whether scripts are allowed to start a video after the initial page load. They do not affect YouTube's "next video autoplay" feature that moves to the next video on a play list after the current video ends, I think because there is no new page load. I'm pretty sure there are add-ons to turn off that YouTube feature so you don't have to flip the blue switch yourself.'' Which of these have the problem (autoplay occurs after setting '''1''' as the default permission) on your Firefox: * On YouTube, right-click a thumbnail > Open Link in New Tab * On YouTube, right-click a thumbnail > Open Link in New Window * Open a Google search result in a new tab (for example, [https://www.google.com/search?q=thanksgiving+stuffing+site%3Ayoutube.com thanksgiving stuffing site:youtube.com] * Something else

Spørgsmålsstiller

What used to happen was that I could open youtube, click on a video , but that video wouldn't start to play until it had loaded and I clicked on it again. Now it starts to play immediately it has loaded.

With regard to youtubes autoplay button, that used to stay as greyed out, but now each time I open a new video it goes back to blue autoplay.

What used to happen was that I could open youtube, click on a video , but that video wouldn't start to play until it had loaded and I clicked on it again. Now it starts to play immediately it has loaded. With regard to youtubes autoplay button, that used to stay as greyed out, but now each time I open a new video it goes back to blue autoplay.
jscher2000
  • Top 10 Contributor
8583 løsninger 70213 svar

KezzerN said

What used to happen was that I could open youtube, click on a video , but that video wouldn't start to play until it had loaded and I clicked on it again. Now it starts to play immediately it has loaded.

Okay, with the default permission set to 1, when I open the YouTube home page and click a thumbnail to view a video, a new page loads with that video and it starts buffering but doesn't play. (I don't log into my Google account when using YouTube.)

Yours starts playing right away? That shouldn't happen. And you tested in Firefox's Safe Mode to rule out extensions as the source of the problem? Hmm...

With regard to youtubes autoplay button, that used to stay as greyed out, but now each time I open a new video it goes back to blue autoplay.

I think if you switch it off, YouTube stores that in a cookie. If you clear cookies, then the default behavior would occur on the next page load.

''KezzerN [[#answer-1171959|said]]'' <blockquote> What used to happen was that I could open youtube, click on a video , but that video wouldn't start to play until it had loaded and I clicked on it again. Now it starts to play immediately it has loaded. </blockquote> Okay, with the default permission set to '''1''', when I open the YouTube home page and click a thumbnail to view a video, a new page loads with that video and it starts buffering but doesn't play. (I don't log into my Google account when using YouTube.) Yours starts playing right away? That shouldn't happen. And you tested in Firefox's Safe Mode to rule out extensions as the source of the problem? Hmm... <blockquote>With regard to youtubes autoplay button, that used to stay as greyed out, but now each time I open a new video it goes back to blue autoplay. </blockquote> I think if you switch it off, YouTube stores that in a cookie. If you clear cookies, then the default behavior would occur on the next page load.

Spørgsmålsstiller

Yes, mine starts playing straight away with permissions set to 1. Yes I tried safe mode and that made no difference. Even when I haven't cleared cookies it is still switching autoplay back on. It all only started a couple of days back. Until then it all worked fine.

Yes, mine starts playing straight away with permissions set to 1. Yes I tried safe mode and that made no difference. Even when I haven't cleared cookies it is still switching autoplay back on. It all only started a couple of days back. Until then it all worked fine.
jscher2000
  • Top 10 Contributor
8583 løsninger 70213 svar

To see whether this is something in your settings vs. something in Firefox or external to Firefox, could you try:

New Profile Test

This takes about 3 minutes, plus the time to test YouTube.

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Click the Create a New Profile button, then click Next. Assign a name like Nov2018, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile, scroll down to it and click the Set as default profile button below that profile, then scroll back up and click the Restart normally button. (There are some other buttons, but please ignore them.)

Firefox should exit and then start up using the new profile, which will just look brand new. Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system so we can get a clean test.

Go ahead and change the permission in about:config.

Does YouTube still autoplay in the new profile?

When you are done with the experiment, open the about:profiles page again, click the Set as default profile button for your normal profile, then click the Restart normally button to get back to it.

To see whether this is something in your settings vs. something in Firefox or external to Firefox, could you try: '''New Profile Test''' This takes about 3 minutes, plus the time to test YouTube. Inside Firefox, type or paste '''about:profiles''' in the address bar and press Enter/Return to load it. Click the Create a New Profile button, then click Next. Assign a name like Nov2018, ignore the option to relocate the profile folder, and click the Finish button. After creating the profile, scroll down to it and click the '''Set as default profile''' button below that profile, then scroll back up and click the '''Restart normally''' button. (There are some other buttons, but please ignore them.) Firefox should exit and then start up using the new profile, which will just look brand new. Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system so we can get a clean test. Go ahead and change the permission in about:config. ''Does YouTube still autoplay in the new profile?'' When you are done with the experiment, open the about:profiles page again, click the '''Set as default profile''' button for your normal profile, then click the '''Restart normally''' button to get back to it.

Spørgsmålsstiller

No youtube doesn't autoplay, but it does say the connection isn't safe.

By the way, many thanks for all this help. It is much appreciated. :-)

No youtube doesn't autoplay, but it does say the connection isn't safe. By the way, many thanks for all this help. It is much appreciated. :-)
jscher2000
  • Top 10 Contributor
8583 løsninger 70213 svar

KezzerN said

No youtube doesn't autoplay, but it does say the connection isn't safe.

Do you mean instead of getting the video page you get the "Your connection is not secure" error page?

Could you see whether you have a "man in the middle" of your connection:

''KezzerN [[#answer-1172014|said]]'' <blockquote> No youtube doesn't autoplay, but it does say the connection isn't safe. </blockquote> Do you mean instead of getting the video page you get the "Your connection is not secure" error page? Could you see whether you have a "man in the middle" of your connection: * [[What do the security warning codes mean?]] * [[How to troubleshoot "Your connection is not secure" error codes on secure websites]]

Spørgsmålsstiller

I just logged on to new profile page again to get a screen shot of what it shows when I go to youtube, but I am not getting the security problem today, it just shows youtube normally and I had no problems with videos autoplaying when they shouldn't, but I still have the issue once I come out of the new profile and go back to my original one.

I just logged on to new profile page again to get a screen shot of what it shows when I go to youtube, but I am not getting the security problem today, it just shows youtube normally and I had no problems with videos autoplaying when they shouldn't, but I still have the issue once I come out of the new profile and go back to my original one.
jscher2000
  • Top 10 Contributor
8583 løsninger 70213 svar

Nyttigt svar

Hi KezzerN, there probably is a difference between the two profiles related to settings. The tricky part is tracking down the what those differences are.

To see whether the problem is a preference stored in the prefs.js file you could copy the regular one to the test profile and see whether that triggers the same problem. Alternately, you could spend some time setting up the test profile to work more like you like with preferred settings and add-ons and see whether that brings on the issue.

If you are going to copy files between profiles, please set Windows to show hidden files/folders and all file extensions or it may be difficult to find the various files.

Hi KezzerN, there probably is a difference between the two profiles related to settings. The tricky part is tracking down the what those differences are. To see whether the problem is a preference stored in the '''prefs.js''' file you could copy the regular one to the test profile and see whether that triggers the same problem. Alternately, you could spend some time setting up the test profile to work more like you like with preferred settings and add-ons and see whether that brings on the issue. If you are going to copy files between profiles, please set Windows to show hidden files/folders and all file extensions or it may be difficult to find the various files. * https://support.microsoft.com/en-us/help/14201/windows-show-hidden-files * https://www.bleepingcomputer.com/tutorials/how-to-show-file-extensions-in-windows/ * [[Profiles - Where Firefox stores your bookmarks, passwords and other user data]]

Spørgsmålsstiller

Thank you for the further suggestions. I am on a mac rather than windows, though I think I know where to find that file. I shall find the time to try it out and let you know how I get on.

Thanks again for all your help.

Thank you for the further suggestions. I am on a mac rather than windows, though I think I know where to find that file. I shall find the time to try it out and let you know how I get on. Thanks again for all your help.

Spørgsmålsstiller

Without me ever having figured out why I have this problem, it has now sorted itself and my videos are no longer automatically playing.

Without me ever having figured out why I have this problem, it has now sorted itself and my videos are no longer automatically playing.
JohnVillalovos 0 løsninger 1 svar

I have Firefox 64.0.2 (64 bit on Windows 10) and recently noticed that YouTube videos are now autoplaying. Previously they would not.

I have the following settings:

  • media.autoplay.allow-muted = false
  • media.autoplay.ask-permission = true
  • media.autoplay.default = 1
  • media.autoplay.enabled.user-gestures-needed = true

So if I paste the URL for a YouTube video into my browser it does NOT autoplay.

But if I then click a link to a second video from inside YouTube to open in the same tab it DOES autoplay. I don't want this.

If I middle-click a link to open the second video from inside YouTube to open in a new tab it does NOT autoplay.

I have Firefox 64.0.2 (64 bit on Windows 10) and recently noticed that YouTube videos are now autoplaying. Previously they would not. I have the following settings: * media.autoplay.allow-muted = false * media.autoplay.ask-permission = true * media.autoplay.default = 1 * media.autoplay.enabled.user-gestures-needed = true So if I paste the URL for a YouTube video into my browser it does NOT autoplay. But if I then click a link to a second video from inside YouTube to open in the same tab it DOES autoplay. I don't want this. If I middle-click a link to open the second video from inside YouTube to open in a new tab it does NOT autoplay.
jscher2000
  • Top 10 Contributor
8583 løsninger 70213 svar

Hi JohnVillalovos, the autoplay permission seems most directed to a newly opened page where you have not yet interacted with the content. When you click to view the next video in an existing page, YouTube may be changing out the tab's content without loading a new page, and/or your "click" might be considered you triggering the player.

Anyway, it's probably something that will need to be built out for a future version of Firefox. You can submit comments and suggestions for changes changes to future versions of Firefox through one or more of the following links:

Hi JohnVillalovos, the autoplay permission seems most directed to a newly opened page where you have not yet interacted with the content. When you click to view the next video in an existing page, YouTube may be changing out the tab's content without loading a new page, and/or your "click" might be considered you triggering the player. Anyway, it's probably something that will need to be built out for a future version of Firefox. You can submit comments and suggestions for changes changes to future versions of Firefox through one or more of the following links: * Feedback: https://qsurvey.mozilla.com/s3/FirefoxInput/ * Discourse: https://discourse.mozilla.org/c/firefox-development * Reddit: https://www.reddit.com/r/firefox/ * Twitter: https://twitter.com/firefox * Facebook: https://www.facebook.com/Firefox
cor-el
  • Top 10 Contributor
  • Moderator
17348 løsninger 156811 svar

You can look at this extension.

You can look at this extension. *Disable HTML5 Autoplay https://addons.mozilla.org/firefox/addon/disable-autoplay/