Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Save bookmarks does not work in FF 64.0b6

  • 9 svar
  • 1 har dette problem
  • 291 visninger
  • Seneste svar af ProfT

more options

All of a sudden, I cannot save bookmarks. I'm running FF on a Retina MacBookPro, 15", Late 2013, 2 GHz Intel Core i7, 16GB RAM, OS X 10.14. I did all the steps here <https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems#w_disable-all-extensions> and they did not fix the problem. I have downloaded a fresh copy of FF as well. That did not help either.

Help!

Valgt løsning

Please can you define what you mean by "Do not bookmark"?

How are you bookmarking these (as in, what actions do you take, what do you see)? When do you realise they aren't bookmarked?

Have you tried running the integrity check as suggested by cor-el?

Læs dette svar i sammenhæng 👍 1

Alle svar (9)

more options

If you use Sync then best is to disconnect Sync temporarily during troubleshooting.

You can check for problems with the places.sqlite database (bookmarks and history) in the Firefox profile folder.

  • use "Verify Integrity" on the "Help -> Troubleshooting Information" (about:support) page
    in case errors are reported close and restart Firefox and retry

See also:

If "Verify Integrity" on the "Help -> Troubleshooting Information" (about:support) page cannot repair places.sqlite then remove all places.sqlite files in the Firefox profile folder. Firefox will rebuild places.sqlite and restore the bookmarks from a recent JSON backup in the bookmarkbackups folder.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

more options
more options

Valgt løsning

Please can you define what you mean by "Do not bookmark"?

How are you bookmarking these (as in, what actions do you take, what do you see)? When do you realise they aren't bookmarked?

Have you tried running the integrity check as suggested by cor-el?

more options

Hi Standard8:

Thanks. When I did the Verify Integrity, I got the ability to bookmark back.

What I meant by "Do not bookmark" was that when I pressed CMD-D, nothing happened. I did not get an "Edit this bookmark" dialogue appearing.

more options

So you know, the current Beta build of Firefox 64.0 is 64.0b7

more options

The problem is back. Here's the Verify Integrity output. Any clues here?


> Task: checkIntegrity - Unable to check places.sqlite integrity: Error: Error(s) encountered during statement execution: database disk image is malformed > Task: invalidateCaches - The task queue was cleared by an error in another task. > Task: checkCoherence - The task queue was cleared by an error in another task. > Task: expire - The task queue was cleared by an error in another task. > Task: originFrecencyStats - The task queue was cleared by an error in another task. > Task: vacuum - The task queue was cleared by an error in another task. > Task: stats - The task queue was cleared by an error in another task. > Task: _refreshUI - The task queue was cleared by an error in another task.

more options

Sorry for the delay, I've been ill this week.

"database disk image is malformed" means there's something wrong with the database and can't read it. Most likely something has caused corruption.

Firefox does its best to recover from it, but the fundamental reason needs to be looked at.

Do you know if you've been having any hard drive issues? or maybe crashes?

more options

I hope you're feeling better now.

No, no "hard drive" crashes, as I have an SSD installed. I can print out a full system report and send it to you privately if you wish.

Update: I've now upgraded to 64.0b9 and bookmarking (CMD-D) is working again. Why don't we just wait a bit and see if things continue to work? If so, we can close the conversation.