Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox has stopped saving passwords

  • 17 svar
  • 1 har dette problem
  • 959 visninger
  • Seneste svar af FredMcD

more options

In Settings the box for saving logins and passwords is checked. Still the program refuses to save my passwords.

What can I do? Are other settings disabling the save passwords feature?

//

Valgt løsning

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

Læs dette svar i sammenhæng 👍 0

Alle svar (17)

more options

Hello Stringence,

Would you please take a look at this article and see if anything there applies to your situation :

https://support.mozilla.org/en-US/kb/usernames-and-passwords-are-not-saved

You might for instance be in permanent private browsing mode or have some password manager related software (however your system details don't show any such extension).

more options

Thanks for Your quick response/suggestion. I had already read through the resource you refer to.

Without changing any settings, making sure box for "Save passwords" is ticked, no "Exceptions" listed, I discovered there's a problem only with Google Gmail. It didn't matter how many times I logged in, cleared cashe, erased cookies, Firefox wouldn't keep the password.

Logging in on Youtube however, Firefox immediately asked to save the password. Then logging into Gmail, Firefox used the saved password, no problems at all.

I can't explain it.

Perhaps you might know what's different between these two sites? It's beyond me.

//

more options

There are other things that need attention.

Your System Details list shows that you have a user.js file in the profile folder to initialize prefs each time Firefox starts. The user.js file will only be present if you or other software has created this file and normally won't be present.

You can check its content with a text editor (right-click: "Open with"; do not double-click). The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

You can delete the user.js file if you didn't create this file yourself.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

more options

Stringence said

I discovered there's a problem only with Google Gmail. It didn't matter how many times I logged in, cleared cache, erased cookies, Firefox wouldn't keep the password.

You say that you erased cookies - that's what you should not do.

Would you do this please : When you're on Gmail click on the 'i' in a circle, next to the padlock at the left side of the address bar. That will take you to "Page Info". Then click on the little black arrow on the dropdown and then on "More Information". Click on the 'Permissions" tab and scroll down to "Set Cookies". Uncheck "Use Default" and check "Allow".

Then close and restart Firefox.

Does that work  ?

more options

No "Page Info" available.

more options

Stringence said

No "Page Info" available.

Your screenshot shows that you are on the Page Info, now all you have to do next is what I said in my previous post :

"Then click on the little black arrow on the dropdown (next to "mail.google.com") and then on "More Information". Click on the 'Permissions" tab and scroll down to "Set Cookies". Uncheck "Use Default" and check "Allow".

Then close and restart Firefox."

more options

Ah, I found it.

No, no change. Youtube remembers, Gmail refuses.

more options

Stringence said

No, no change. Youtube remembers, Gmail refuses.

Bummer  ! (must admit that it was a stab in the dark ..... )

I found this :

https://yourbusiness.azcentral.com/firefox-wont-keep-gmail-logged-10327.html

more options

Hail Mary's are Hail Mary's, worth trying, some times they do work.

Got the password saved using Youtube, so problem is partly solved. Now it's just sport finding out why Gmail behaves badly.

For others with the same problem using Gmail, the way around it is - use Youtube! =)

more options

Stringence said

Got the password saved using Youtube

Huh  ??? How  ???

What happens when you try to sign in to your Gmail account "the normal way"  ?

more options

OK.

1. Delete the Google account login in Settings > Privacy and Security 2. Shut down Firefox 3. Start up Firefox 4. Visit Gmail (or Google Drive, or Google Calendar) 5. Type mailaddress and password 6. Logged in, Firefox does not ask to save the password 7. Log out, and shut down Firefox

8. Start Firefox 9. Visit Youtube 10. Type mailaddress and password 11. Logged in, and Firefox nicely ask to save the password

12. Automatically logged into all Google sites, Gmail etc.

I can't explain it.

//

more options

Stringence said

11. Logged in, and Firefox nicely ask to save the password

And of course you clicked "Save" .....

12. Automatically logged into all Google sites, Gmail etc.

But the next time you want to access your Gmail account you're logged out again  ?

more options

If I just shut down Firefox, starting it up again I'm automatically logged into Gmail.

If I log ut from Gmail, shut down Firefox, I can log into Gmail with the saved account and password.

Firefox never ask to save the account/password when logging into Gmail, Drive or Calendar. Firefox always ask when I log into Youtube (after I've first deleted the saved Google account from Firefox' list)

It's very strange. There must be a difference between these platforms, at the same time as the same account login works for both.

//

more options

Valgt løsning

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

more options

Thanks FredMcD, safe mode was a good ideaI

I found the problem. It's a Youtube downloader 2.9.1 add-on that prevents Fox from saving the account/password for the Google platform. Why is probably beyond all of us?

Restarted Fox in safe mode, problem went away - logging into Google, Fox offered to save my password right away.

Tested all my add-ons one by one, Fox offers to save my password when all are activated, except Downloader 2.9.1.

So I created the problem myself, feel silly, my apology. =(

I thank You all so much for Your time and help!

This was really not a security bug, as I believed in the beginning. Let's be mindful of add-ons. Seems they're able to create all sorts of unexpected problems.

//

more options

Well, Stringence, that must be a huge relief.   !

Would you be a dear and mark FredMcD's post as
Chosen Solution  ?

(button to the right of his post)

Thank you in advance  !

Ændret af guigs den

more options

Glad to help. Safe Surfing.