Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox forces URL changes to unknown directory

  • 6 svar
  • 1 har dette problem
  • 40 visninger
  • Seneste svar af FredMcD

more options

I'm suffering issues with Firefox on just one of my laptops. When I type in a web address, the url changes to something that I've accessed previously, but won't refresh. For example, if I type in the url of a local website, "www.heriot.info" and then <return>, the url changes to "www.heriot.info/defaultsite". Clearing the history and cache doesn't appear to make any difference.

A possibly related issue is that Firefox won't refresh (at least some) pages. So, for example, I have a website analytics site that I access, but which doesn't refresh unless I delete all instances of the site from my web history and reaccess the page. So, if I forget to delete the history, I see data that isn't up to date - and clickin the refresh button doesn't change that.

Any suggestions as to the root cause? Thanks!

Valgt løsning

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

Læs dette svar i sammenhæng 👍 1

Alle svar (6)

more options

Valgt løsning

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

more options

Thanks Fred - turning off the hardware acceleration appears to have fixed it. At least, I can't recreate the problem!

I'd cleared the cache previously to get round this sort of issue, but it's a pretty ugly solution that causes more problems than it solves. One thing I just found was right-clicking the site on the history bar and selecting 'forget site' also worked - again, it's a solution, but it's better not to have a problem to resolve in the first place.

Hopefully, dropping the hardware acceleration has now solved it once and for all. Thanks again for the very quick and thorough solution.

more options

Glad to help. Safe Surfing.

more options

Note that you can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)
more options

Thanks cor-el - that's an incredibly useful tip. It saves me from having to open private browsing, which has been my fallback position when I didn't want to delete my cache.

more options

Another thing you can do it;

Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.