X
Tryk her for at gå til webstedets mobilversion.

Supportforum

Issue with login on nbcsports.com

Skrevet

On nbcsports.com domain, most pages have a comment section. There is no login to the website itself, but you can comment on the articles by signing in via several options- Google, Yahoo, Microsoft, Facebook,.... etc. The site facilitates the sign in when you click "Post" or "Thump up, Thump down" by prompting to "sign in with.." and only shows the first 2 choices and a "show more" button, when you click "Show more", it is supposed to drop down the rest of the login choices, but it doesn't. In Firefox the whole applet just freezes. I tried all trouble shooting options, including complete uninstall and reinstall, safe mode, disabling firewall, and every Firefox t/s option I came across , but the issue persists. BTW, it works fine in Opera, Edge, and IE11.

I've been having this issue since the forced update to Quantum- The worst upgrade I've ever seen. I'm sure Mozilla people thinks it's the greatest thing since sliced bread. Well, you're wrong.

On nbcsports.com domain, most pages have a comment section. There is no login to the website itself, but you can comment on the articles by signing in via several options- Google, Yahoo, Microsoft, Facebook,.... etc. The site facilitates the sign in when you click "Post" or "Thump up, Thump down" by prompting to "sign in with.." and only shows the first 2 choices and a "show more" button, when you click "Show more", it is supposed to drop down the rest of the login choices, but it doesn't. In Firefox the whole applet just freezes. I tried all trouble shooting options, including complete uninstall and reinstall, safe mode, disabling firewall, and every Firefox t/s option I came across , but the issue persists. BTW, it works fine in Opera, Edge, and IE11. I've been having this issue since the forced update to Quantum- The worst upgrade I've ever seen. I'm sure Mozilla people thinks it's the greatest thing since sliced bread. Well, you're wrong.
Vedhæftede skærmbilleder

Ændret af hk2000 den

Valgt løsning

I just realized your Firefox reported itself as version 60. It's not likely there will be any fixes for the Extended Support Release of Firefox 60, except for security, major crash, and enterprise issues.

The following workaround makes the menu work in Firefox 63 by emulating an old nonstandard behavior from Internet Explorer that Chrome/Opera also emulate. However, it's a new preference that doesn't exist in earlier versions of Firefox:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste event and pause while the list is filtered

(3) Double-click the dom.window.event.enabled preference to switch the value from false to true

Since this is brand new, sites that depend on NOT finding that behavior in Firefox may be broken by the change. We're all learning as we go with this one. It certainly would be nice if the "Gigya" comment system worked in Firefox without requiring this change.

Læs dette svar i sammenhæng 0

Yderligere systemdetaljer

Installerede plugins

  • Shockwave Flash 31.0 r0

Program

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:60.0) Gecko/20100101 Firefox/60.0

Yderligere information

Luk
jscher2000
  • Top 10 Contributor
8509 løsninger 69508 svar

What page has that style of box? When I look at comments on an NFL story, it wants me to log in through WordPress. (Screenshot attached.)

What page has that style of box? When I look at comments on an NFL story, it wants me to log in through WordPress. (Screenshot attached.)

Spørgsmålsstiller

I'm sorry, Here's a more specific address you can try- click on any article and try to comment or like/dislike https://www.nbcsports.com/washington/

I'm sorry, Here's a more specific address you can try- click on any article and try to comment or like/dislike https://www.nbcsports.com/washington/
jscher2000
  • Top 10 Contributor
8509 løsninger 69508 svar

Thanks. For some reason, Washington's pages use a totally different comment system. Anyway, when I click Show More that item disappears from the menu and nothing happens. An error message appears in the Web Console (part of the Developer Tools):

TypeError: i is undefined in gigya.services.plugins.base.min.js

I don't know why that script has an issue in Firefox that it doesn't have in other browsers. Maybe I'm blocking something, or it could be an oversight in testing.

Thanks. For some reason, Washington's pages use a totally different comment system. Anyway, when I click Show More that item disappears from the menu and nothing happens. An error message appears in the Web Console (part of the Developer Tools): TypeError: i is undefined in gigya.services.plugins.base.min.js I don't know why that script has an issue in Firefox that it doesn't have in other browsers. Maybe I'm blocking something, or it could be an oversight in testing.

Spørgsmålsstiller

I mean what are the chances both of us blocking the same thing? I tried with my adblock , and all add ons disabled, same result. I'm assuming you're part of the developers team? Could this issue be escalated? I'm having to use Opera for that site until FF get it fixed, and I hate to keep switching back and forth. Thanks.

I mean what are the chances both of us blocking the same thing? I tried with my adblock , and all add ons disabled, same result. I'm assuming you're part of the developers team? Could this issue be escalated? I'm having to use Opera for that site until FF get it fixed, and I hate to keep switching back and forth. Thanks.

Ændret af hk2000 den

jscher2000
  • Top 10 Contributor
8509 løsninger 69508 svar

Valgt løsning

I just realized your Firefox reported itself as version 60. It's not likely there will be any fixes for the Extended Support Release of Firefox 60, except for security, major crash, and enterprise issues.

The following workaround makes the menu work in Firefox 63 by emulating an old nonstandard behavior from Internet Explorer that Chrome/Opera also emulate. However, it's a new preference that doesn't exist in earlier versions of Firefox:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste event and pause while the list is filtered

(3) Double-click the dom.window.event.enabled preference to switch the value from false to true

Since this is brand new, sites that depend on NOT finding that behavior in Firefox may be broken by the change. We're all learning as we go with this one. It certainly would be nice if the "Gigya" comment system worked in Firefox without requiring this change.

I just realized your Firefox reported itself as version 60. It's not likely there will be any fixes for the Extended Support Release of Firefox 60, except for security, major crash, and enterprise issues. The following workaround makes the menu work in Firefox 63 by emulating an old nonstandard behavior from Internet Explorer that Chrome/Opera also emulate. However, it's a new preference that doesn't exist in earlier versions of Firefox: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''event''' and pause while the list is filtered (3) Double-click the '''dom.window.event.enabled''' preference to switch the value from false to true Since this is brand new, sites that depend on NOT finding that behavior in Firefox may be broken by the change. We're all learning as we go with this one. It certainly would be nice if the "Gigya" comment system worked in Firefox without requiring this change.
jscher2000
  • Top 10 Contributor
8509 løsninger 69508 svar

Nyttigt svar

By the way, to switch from Firefox 60 ESR to Firefox 63, you can grab an installer from

https://www.mozilla.org/firefox/all/

The installer should detect your existing settings and migrate them seamlessly. However, it certainly doesn't hurt to make a backup:

Back up and restore information in Firefox profiles

IMPORTANT

If you depend on the Descriptions field in your bookmarks, that went away in Firefox 62. There is an add-on to fill the gap. See: https://support.mozilla.org/questions/1238863#answer-1168520

By the way, to switch from Firefox 60 ESR to Firefox 63, you can grab an installer from https://www.mozilla.org/firefox/all/ The installer should detect your existing settings and migrate them seamlessly. However, it certainly doesn't hurt to make a backup: [[Back up and restore information in Firefox profiles]] '''IMPORTANT''' If you depend on the Descriptions field in your bookmarks, that went away in Firefox 62. There is an add-on to fill the gap. See: https://support.mozilla.org/questions/1238863#answer-1168520

Spørgsmålsstiller

Thank you. The "about:config" change did the trick. But switching from ESR to the regular Firefox Quantum 63.0.1 (64-bit) did not fix it.

Thank you. The "about:config" change did the trick. But switching from ESR to the regular Firefox Quantum 63.0.1 (64-bit) did not fix it.

Ændret af hk2000 den

Spørgsmålsstiller

Unfortunately, the issue has come back!!! Firefox now defaults the dom.window.event.enabled value to "True", and the issue is back as before the pop up to "Sign in with:. . . " comes up, you select "Show more", and it just sits there. this is not just Firefox issue- Edge, Opera and IE11 all behave the same, so it's a site issue.

Unfortunately, the issue has come back!!! Firefox now defaults the dom.window.event.enabled value to "True", and the issue is back as before the pop up to "Sign in with:. . . " comes up, you select "Show more", and it just sits there. this is not just Firefox issue- Edge, Opera and IE11 all behave the same, so it's a site issue.