X
Tryk her for at gå til webstedets mobilversion.

Supportforum

The Pop up Keyboard for Surface Book 2 will not work in the firefox browser, how can this be fixed?

Skrevet

I installed Firefox on my Microsoft Surface Book 2. Overall it works fine. But when my computer is in tablet mode the pop up keyboard won't appear when I click on a search bar or other text spaces. How can this be fixed if at all?

I installed Firefox on my Microsoft Surface Book 2. Overall it works fine. But when my computer is in tablet mode the pop up keyboard won't appear when I click on a search bar or other text spaces. How can this be fixed if at all?
WestEnd
  • Top 25 Contributor
60 løsninger 5379 svar

This could be a Microsoft issue that it doesn't recognize firefox browser in tablet mode.

This could be a Microsoft issue that it doesn't recognize firefox browser in tablet mode.
jscher2000
  • Top 10 Contributor
8684 løsninger 70998 svar

It's a little complicated. Firefox checks for a hardware keyboard and may suppress the on-screen keyboard in that case. You could experiment with this setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste osk and pause while the list is filtered

(3) Double-click the ui.osk.detect_physical_keyboard preference to switch the value from true to false

Any difference?

Or maybe the problem is that if Firefox is already running when you switch to tablet mode, Firefox doesn't check for the change.

See if you can put together the circumstances where it works as expected and doesn't and maybe someone will know how to address that pattern.

It's a little complicated. Firefox checks for a hardware keyboard and may suppress the on-screen keyboard in that case. You could experiment with this setting: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''osk''' and pause while the list is filtered (3) Double-click the '''ui.osk.detect_physical_keyboard''' preference to switch the value from true to false Any difference? Or maybe the problem is that if Firefox is already running when you switch to tablet mode, Firefox doesn't check for the change. See if you can put together the circumstances where it works as expected and doesn't and maybe someone will know how to address that pattern.