X
Tryk her for at gå til webstedets mobilversion.

Supportforum

how do I stop autoplay of vids on yahoo.com news page. Settings do not work in autocofig media.autoplay = false anymore

Skrevet

I have u block origin already.

I had media autoplay set to false. Now yahoo.com news autoplays vids (again). The autoplay literally started on October 24, 2018. 1- what happened to allow autoplay on yahoo when it was successfully blocked all this time? 2- what can I do to stop video autoplay? Idiot level instructions please- set one go here type instructions. I already went the "add on" route. Flash blockers didn't work at all. All other "vid blockers" are for youtube and will not work on yahoo news as I tried hoping one would work.

Maybe I am stupid, but exactly WHAT settings are needed to stop autoplay on yahoo.com that are in ublock origin or in firefox about: config settings (media.autoplay =false), which doesn't seem to have any effect anymore. Is something else in about:config needed?

Site example where annoy vid autoplay now exists: https://www.yahoo.com/lifestyle/dont-want-attention-mother-6-year-old-boy-whose-birthday-party-guests-no-shows-speaks-185110033.html

FF version: 63.0 , 64 bit, windows 10, Dell Laptop

I have u block origin already. I had media autoplay set to false. Now yahoo.com news autoplays vids (again). The autoplay literally started on October 24, 2018. 1- what happened to allow autoplay on yahoo when it was successfully blocked all this time? 2- what can I do to stop video autoplay? Idiot level instructions please- set one go here type instructions. I already went the "add on" route. Flash blockers didn't work at all. All other "vid blockers" are for youtube and will not work on yahoo news as I tried hoping one would work. Maybe I am stupid, but exactly WHAT settings are needed to stop autoplay on yahoo.com that are in ublock origin or in firefox about: config settings (media.autoplay =false), which doesn't seem to have any effect anymore. Is something else in about:config needed? Site example where annoy vid autoplay now exists: https://www.yahoo.com/lifestyle/dont-want-attention-mother-6-year-old-boy-whose-birthday-party-guests-no-shows-speaks-185110033.html FF version: 63.0 , 64 bit, windows 10, Dell Laptop

Valgt løsning

from https://support.mozilla.org/en-US/questions/1238026

Hi, the settings have evolved. The old media.autoplay.enabled preference has been replaced by several new ones. Let's give this a try: (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste autop and pause while the list is filtered To set your preferred behavior: Allow autoplay by default (default for Release)
  • Double-click the media.autoplay.default preference and set it to 0 (or right-click > Reset)
Block autoplay by default
  • Double-click the media.autoplay.default preference and set it to 1
=> Does that work for you? Ask on a site-by-site basis (default for "Nightly")
  • Double-click the media.autoplay.default preference and set it to 2
  • Double-click the media.autoplay.ask-permission preference to switch the value from false to true
  • Double-click the media.autoplay.enabled.user-gestures-needed preference to switch the value from false to true
I'm sure we'll learn more about the interaction of these various preference and what sites can bypass them as more users begin to run Firefox 63.
Læs dette svar i sammenhæng 2

Yderligere systemdetaljer

Installerede plugins

  • Shockwave Flash 31.0 r0

Program

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

Yderligere information

Luk
James
  • Top 25 Contributor
  • Moderator
1593 løsninger 11222 svar

Valgt løsning

from https://support.mozilla.org/en-US/questions/1238026

Hi, the settings have evolved. The old media.autoplay.enabled preference has been replaced by several new ones. Let's give this a try: (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste autop and pause while the list is filtered To set your preferred behavior: Allow autoplay by default (default for Release)
  • Double-click the media.autoplay.default preference and set it to 0 (or right-click > Reset)
Block autoplay by default
  • Double-click the media.autoplay.default preference and set it to 1
=> Does that work for you? Ask on a site-by-site basis (default for "Nightly")
  • Double-click the media.autoplay.default preference and set it to 2
  • Double-click the media.autoplay.ask-permission preference to switch the value from false to true
  • Double-click the media.autoplay.enabled.user-gestures-needed preference to switch the value from false to true
I'm sure we'll learn more about the interaction of these various preference and what sites can bypass them as more users begin to run Firefox 63.
from https://support.mozilla.org/en-US/questions/1238026 <blockquote>Hi, the settings have evolved. The old '''media.autoplay.enabled''' preference has been replaced by several new ones. Let's give this a try: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''autop''' and pause while the list is filtered To set your preferred behavior: '''''Allow autoplay by default''''' (default for Release) * Double-click the '''media.autoplay.default''' preference and set it to '''0''' (or right-click > Reset) '''''Block autoplay by default''''' * Double-click the '''media.autoplay.default''' preference and set it to '''1''' => ''Does that work for you?'' '''''Ask on a site-by-site basis''''' (default for "Nightly") * Double-click the '''media.autoplay.default''' preference and set it to '''2''' * Double-click the '''media.autoplay.ask-permission''' preference to switch the value from false to true * Double-click the '''media.autoplay.enabled.user-gestures-needed''' preference to switch the value from false to true I'm sure we'll learn more about the interaction of these various preference and what sites can bypass them as more users begin to run Firefox 63.</blockquote>

Nyttigt svar

The fix provided partially worked. I made sure every setting listed was set as posted above. However this yahoo plays a vids with audio.

https://www.yahoo.com/entertainment/caitlyn-jenner-changed-mind-trump-cannot-support-anyone-working-lgbtq-community-210743586.html

So as it stands, the solution is a partial fix. It stops some vids, but not all. Pre 63 solved it solid. I just do not understand why sites force (non advertising) video autoplay on end users.

The fix provided partially worked. I made sure every setting listed was set as posted above. However this yahoo plays a vids with audio. https://www.yahoo.com/entertainment/caitlyn-jenner-changed-mind-trump-cannot-support-anyone-working-lgbtq-community-210743586.html So as it stands, the solution is a partial fix. It stops some vids, but not all. Pre 63 solved it solid. I just do not understand why sites force (non advertising) video autoplay on end users.
jscher2000
  • Top 10 Contributor
8520 løsninger 69619 svar

That Yahoo video seems to trigger on scrolling and/or mouseover, which might not technically be considered autoplay, although it's very annoying. Another reason to avoid Yahoo.

As a defense until someone finds a better workaround, you might try one of the muting extensions so even if the video starts it doesn't destroy your eardrums.

That Yahoo video seems to trigger on scrolling and/or mouseover, which might not technically be considered autoplay, although it's very annoying. Another reason to avoid Yahoo. As a defense until someone finds a better workaround, you might try one of the muting extensions so even if the video starts it doesn't destroy your eardrums. * https://addons.mozilla.org/firefox/addon/mute-sites-by-default/ * https://addons.mozilla.org/firefox/addon/auto-mute/ * https://addons.mozilla.org/firefox/addon/mute-tab-webextension/

Spørgsmålsstiller

Well I have no real other alternatives to yahoo as I do not support google, facebook or witter. But thank you! I will clear this trouble. Also, thank you so much for putting up with my problem and helping.

Well I have no real other alternatives to yahoo as I do not support google, facebook or witter. But thank you! I will clear this trouble. Also, thank you so much for putting up with my problem and helping.

Ændret af Droxy den

MozInAZ 0 løsninger 8 svar

Every other site respects my autoplay settings (all of them, as they currently exist). No site, except news.yahoo.com autoplays video with sound. Only Yahoo! News plays it. Besides the numerous settings where it's disabled I have explicitly disallowed it on all of Yahoo's sites, individually- yet it still autoplays! (Privacy & security | For websites that autoplay sound - I have blocked exceptions for all of Yahoo's sites).

When I scroll down a page after having paused the video at the top of the page, then I scroll back up to the top, which displays the video area- it starts again!

Every other site respects my autoplay settings (all of them, as they currently exist). No site, except news.yahoo.com autoplays video with sound. Only Yahoo! News plays it. Besides the numerous settings where it's disabled '''I have explicitly disallowed it on all of Yahoo's sites, individually- yet it still autoplays'''! (''Privacy & security | For websites that autoplay sound'' - I have blocked exceptions for all of Yahoo's sites). When I scroll down a page after having paused the video at the top of the page, then I scroll back up to the top, which displays the video area-''' it starts again'''!

Ændret af MozInAZ den

MozInAZ 0 løsninger 8 svar
Here's an example: https://news.yahoo.com/twitter-users-troll-trump-hilariously-103701689.html

Spørgsmålsstiller

@ Mozln I have the same problem. Nothing is stopping the autoplay on yahoo. The solutions provided above is as a good as it got, in short, no stopping auto play on yahoo news. Eventually someone will figure it out. I run my PC w/o sound but I feel sorry for ppl with data plans that get eaten alive by this crappy behavior of websites and their vid autoplay.

@ Mozln I have the same problem. Nothing is stopping the autoplay on yahoo. The solutions provided above is as a good as it got, in short, no stopping auto play on yahoo news. Eventually someone will figure it out. I run my PC w/o sound but I feel sorry for ppl with data plans that get eaten alive by this crappy behavior of websites and their vid autoplay.
Harry.Caul 0 løsninger 1 svar

<yes, I realize these are instructions on a very old system and version ... it might possibly have some use on more modern configurations as well though>

To stop Yahoo autoplay in Windows 7 w/ Firefox 56 ...

As noted above, goto about:config ... search for "autop" ...

Where two entries are returned ... media.autoplay.enabled and media.block-autoplay-until-in-foreground

First, change media.block-autoplay-until-in-foreground to false then change media.autoplay.enabled to false then change media.block-autoplay-until-in-foreground back to true that's it. That worked for me 4-8-19.

<yes, I realize these are instructions on a very old system and version ... it might possibly have some use on more modern configurations as well though> To stop Yahoo autoplay in Windows 7 w/ Firefox 56 ... As noted above, goto about:config ... search for "autop" ... Where two entries are returned ... media.autoplay.enabled and media.block-autoplay-until-in-foreground First, change media.block-autoplay-until-in-foreground to false then change media.autoplay.enabled to false then change media.block-autoplay-until-in-foreground back to true that's it. That worked for me 4-8-19.
cor-el
  • Top 10 Contributor
  • Moderator
17278 løsninger 156199 svar

The Boolean pref media.autoplay.enabled no longer exists in current Firefox releases and has been replaced by the Integer pref media.autoplay.default (0=Allowed, 1=Blocked, 2=Prompt).

The Boolean pref media.autoplay.enabled no longer exists in current Firefox releases and has been replaced by the Integer pref media.autoplay.default (0=Allowed, 1=Blocked, 2=Prompt). *https://support.mozilla.org/en-US/kb/block-autoplay