Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When I open a new tab, no inscriptions can be read, as they are shown in strange charachters

  • 13 svar
  • 1 har dette problem
  • 24 visninger
  • Seneste svar af cor-el

more options

I have tried installing the program in different languages (Russian, Ukrainian, and English), but each time I have the same result (please see the print screen below).

Alle svar (13)

more options

Unfortunately, the screenshot did not upload. Could you try attaching the image(s) to a new reply: https://support.mozilla.org/questions/1236309#question-reply

more options

Sorry. Please see the screenshot below

more options

This looks like a problem with the font that Firefox wants to use. The characters I see are in the normal ASCII Unicode range (0x00-0x7f) and thus should display without a problem.

  • %54%4f%50%20%53%49%54%45%53 = TOP SITES

You can check what font Firefox tries to use via the Fonts tab in the right panel of the Inspector.

You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected. You can check the font used for selected text in the Font tab in the right panel of the Inspector.

Note that this is not about the font-family CSS rule, but about the font that Firefox actually uses as shown in the Font tab.

Ændret af cor-el den

more options

Oh, that's not pretty. My Firefox is using the Windows Segoe UI font in those areas where you have unrecognized characters. I'm not sure where Firefox gets that selection from, it might be from Windows settings.

To check what font Firefox is trying (unsuccessfully) to use on yours, could you:

right-click some of the problem text on the page (not the ones in the search box, some of the other text) and choose Inspect Element. This should open Firefox's Page Inspector tool and highlight that part of the page in the HTML "tree" diagram.

On the right side, Firefox should display some information about that highlighted element. Look for a Fonts panel as in the attached screenshot. What font is shown there?

more options

It says "Twemoji Mozilla"

more options

Yakov59 said

It says "Twemoji Mozilla"

Hmm, that font should only be used for emoji's and not for letters. Could you inspect other parts of the page where you expect text and see whether that is showing up there as well?

more options

Yes, and it shows the same for characters in other pages as well, like in the bottom left corner area of the other page (please see screenshot below).

more options

Could you look for that font here:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste emoji and pause while the list is filtered

Do you see the font anywhere that seems inappropriate?

more options

Please see below the result in the form of screenshot attached. Thank you for all your assistance as I do not understand much in this. I have to use Google Chrome in the meantime :-(

more options

Hi Yakov59, yours matches mine, the font should only be used where emoji are meant to appear. I don't have a good idea on why it is used for other characters.

Did this problem start after a recent update, and Firefox was working normally before that?

Do you recall ever creating a customization file named userContent.css (this is the only way I know of to change the font in the new tab page)?

more options

Hi, I do not remember the exact moment when the problem started, as I was away for a few months and did not use my notebook then. I think it was related to some Windows update, which affected Registry settings. And I have never created any customization file as I am just an ordinary user. Again, thank you very much for all your assistance efforts.

more options

download the full version of the current firefox in all lajguages:

OR

visit the mozilla dictionaries & language packs page:

Language packs change your browser's interface language, including menu options and settings.

more options

Maybe check for font substitutions in the Windows Registry.