X
Tryk her for at gå til webstedets mobilversion.

Supportforum

STOP gmail notifications when I am browsing the web! Preferences does not work, about this page does not work. I am one hour away from deleting firefox forever

Skrevet

ok firefox - I am just about ready to delete you forever, these gmail notifications are driving me crazy! How do I stop them??? I tried (1) menu, preferences, privacy and security, notifications, settings, block (deleted all) and (2) on gmail: right click, view page info, permissions, receive notifications, and (3)..something else I did I don't remember that included going into some code and checking that somethings was "off". Agghh. can anyone help????

ok firefox - I am just about ready to delete you forever, these gmail notifications are driving me crazy! How do I stop them??? I tried (1) menu, preferences, privacy and security, notifications, settings, block (deleted all) and (2) on gmail: right click, view page info, permissions, receive notifications, and (3)..something else I did I don't remember that included going into some code and checking that somethings was "off". Agghh. can anyone help????

Yderligere systemdetaljer

Installerede plugins

  • Shockwave Flash 21.0 r0

Program

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:62.0) Gecko/20100101 Firefox/62.0

Yderligere information

Luk
McCoy
  • Top 10 Contributor
545 løsninger 5143 svar

Nyttigt svar

Hello pilarP,

Are you by any chance using Thunderbird  ?

And if so, do you have this add-on installed :

https://addons.mozilla.org/en-US/firefox/addon/gnotifier/  ?


Separate issue :

Your system details show that you need to update your Adobe Flash Player - you are running a very old version, which can cause problems. Would you please uninstall your current version and install the latest version, which is 31.0.0.108

https://helpx.adobe.com/flash-player/kb/uninstall-flash-player-mac-os.html

https://get.adobe.com/flashplayer/otherversions/

Note : some 'extras' may be offered in the download.

Hello pilarP, Are you by any chance using Thunderbird ? And if so, do you have this add-on installed : https://addons.mozilla.org/en-US/firefox/addon/gnotifier/ ? --------------------------------------------------------------------------------------------------------- Separate issue : Your system details show that you need to update your Adobe Flash Player - you are running a very old version, which can cause problems. Would you please uninstall your current version and install the latest version, which is '''31.0.0.108''' https://helpx.adobe.com/flash-player/kb/uninstall-flash-player-mac-os.html https://get.adobe.com/flashplayer/otherversions/ Note : some 'extras' may be offered in the download.
jscher2000
  • Top 10 Contributor
8774 løsninger 71729 svar

Nyttigt svar

pilarP said

ok firefox - I am just about ready to delete you forever, these gmail notifications are driving me crazy! How do I stop them??? I tried (1) menu, preferences, privacy and security, notifications, settings, block (deleted all) and (2) on gmail: right click, view page info, permissions, receive notifications, and (3)..something else I did I don't remember that included going into some code and checking that somethings was "off". Agghh. can anyone help????

I haven't noticed Gmail displaying "desktop notifications," but maybe that's because I have this setting in my mailbox settings:

https://mail.google.com/mail/u/0/#settings/general

Under General, "Desktop Notifications" => "Mail notifications off"

(Screenshot attached)

If you have that turned off and you STILL get notifications, then McCoy's insight about an add-on possibly doing it sounds right to me.

You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything Gmail related, or notification related, or that you do not remember installing or why? If in doubt, disable (or remove).

Any improvement?

''pilarP [[#question-1234861|said]]'' <blockquote> ok firefox - I am just about ready to delete you forever, these gmail notifications are driving me crazy! How do I stop them??? I tried (1) menu, preferences, privacy and security, notifications, settings, block (deleted all) and (2) on gmail: right click, view page info, permissions, receive notifications, and (3)..something else I did I don't remember that included going into some code and checking that somethings was "off". Agghh. can anyone help???? </blockquote> I haven't noticed Gmail displaying "desktop notifications," but maybe that's because I have this setting in my mailbox settings: https://mail.google.com/mail/u/0/#settings/general Under General, "Desktop Notifications" => "Mail notifications off" (Screenshot attached) If you have that turned off and you STILL get notifications, then McCoy's insight about an add-on possibly doing it sounds right to me. You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either: * Command+Shift+a (Windows: Ctrl+Shift+a) * "3-bar" menu button (or Tools menu) > Add-ons * type or paste '''about:addons''' in the address bar and press Enter/Return In the left column of the Add-ons page, click Extensions. Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything Gmail related, or notification related, or that you do not remember installing or why? If in doubt, disable (or remove). Any improvement?

Spørgsmålsstiller

thank you both for taking the time to reply!! I really appreciate it.

so far... I have tried these things:

-for gmail notifications, my page says my gmail version is too old for notifications, and to load chrome if I want notifications

about:addons- there were none listed for me

No I do not have thunderbird.

Yes - can uninstall and install adobe flash player - but how do you know what my system details are? I didnt know people can know all that! My husband says Mac (what I have) stopped installing it a long time ago, and we don't use it.

Idk....I guess I could install chrome for gmail and see if that helps? I am not a techy person, but open to more advise. I'll watch for a day or two and see if anything changes. Thank you both again very much!!

thank you both for taking the time to reply!! I really appreciate it. so far... I have tried these things: -for gmail notifications, my page says my gmail version is too old for notifications, and to load chrome if I want notifications about:addons- there were none listed for me No I do not have thunderbird. Yes - can uninstall and install adobe flash player - but how do you know what my system details are? I didnt know people can know all that! My husband says Mac (what I have) stopped installing it a long time ago, and we don't use it. Idk....I guess I could install chrome for gmail and see if that helps? I am not a techy person, but open to more advise. I'll watch for a day or two and see if anything changes. Thank you both again very much!!
jscher2000
  • Top 10 Contributor
8774 løsninger 71729 svar

pilarP said

-for gmail notifications, my page says my gmail version is too old for notifications, and to load chrome if I want notifications

If Gmail isn't sending notifications, there must be something else watching your Inbox. But what??!!

This problem only occurs when Firefox is running, not if you Quit Firefox and use Safari for similar sites?

''pilarP [[#answer-1157573|said]]'' <blockquote> -for gmail notifications, my page says my gmail version is too old for notifications, and to load chrome if I want notifications </blockquote> If Gmail isn't sending notifications, there must be something else watching your Inbox. But what??!! This problem only occurs when Firefox is running, not if you Quit Firefox and use Safari for similar sites?

Spørgsmålsstiller

correct - firefox issue only. And started maybe 4-6 weeks ago?....

correct - firefox issue only. And started maybe 4-6 weeks ago?....
Shadow110 1072 løsninger 14836 svar

Hi, Flash can be picked up as well as what version OS you have and the browser version.

When you decide not to share info when you make the question you stop us from seeing your installed Extensions which could be a issue so we end up having to make you do a test and ask for a list.

It also stops us from looking at your Video Card Drivers which if are bad cause issues in a lot of places. Mac has always issues with Video Card Drivers but nothing can do about till next release.

So yes we get some info, same as what others sites get and actually less as we do not want it in Support.

If you do not use Flash, do not install it. Or do.

SO the solution should be not install Chrome but to follow jscher2000's suggestion of setting in your gmail settings.

Or : If do not use or want any notifications you can turn it all off.

Websites can ask you to accept several different kinds of communications and updates:

  • Desktop notifications - if allowed, the site can send notifications for Firefox to display in the lower corner of your screen until you close the last tab for a site.
  • Web push notifications - if allowed, the site can send desktop notifications for Firefox to display in the lower corner of your screen even after the last tab for the site is closed (until you exit Firefox).
  • Web push updates - if allowed, the site can send Firefox updates in the background, which presumably is more efficient that forcibly refreshing a page or having a script in the page keep checking for updates. This push feature is NOT a desktop notification, but Firefox may use the notification permission panel, which I hope will be changed in the future since that's a bit confusing.

Site-Specific Permissions/Blocks

If the drop-panel is not available or does not work for you, while viewing the site where you want to modify a previously given permission, you can use the Permissions panel of the Page Info dialog. To call that up, either:

  • right-click (on Mac, Ctrl+click) a blank area of the page and choose View Page Info > Permissions

(menu bar) Tools menu > Page Info > Permissions or click the padlock or "i" icon to the left of the site address, then the ">" icon, then More Information > Permissions

Scroll down to "Receive Notifications" and you can check the "Use default" box (so you are prompted in the future) or uncheck that box and select the permission you prefer (for example, Block).

There's no save button for this panel, changes are saved as you go.

Session Do Not Disturb

To disable all desktop notifications for the rest of your Firefox session (i.e., until you exit Firefox), you can turn on "Do Not Disturb" on the Options/Preferences page, Content panel. Either:

  • Windows: "3-bar" menu button (or Tools menu) > Options, then in the left column click Content

Mac: "3-bar" menu button (or Firefox menu) > Preferences, then in the left column click Content Linux: "3-bar" menu button (or Edit menu) > Preferences, then in the left column click Content Anyone: Type or paste about:preferences#content in the address bar and press Enter/Return (you can bookmark this for faster future access)

On the right side, under "Notifications", check the "Do not disturb me" box. This is for your current session only.

All-Site Persistent Disable

There are two different preferences for notifications, a master switch, and one which is specific to background (web push) notifications that can appear after you leave the site which sends them.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste webno and pause while the list is filtered

(3) To disable PUSH NOTIFICATIONS, double-click the dom.webnotifications.serviceworker.enabled preference to switch its value from true to false -- sites can still generate desktop notifications while you have a tab open to the site

(4) To disable ALL NOTIFICATIONS, double-click the dom.webnotifications.enabled preference to switch its value from true to false -- this is a master switch, you won't get any desktop notifications from sites

(5) To also disable BACKGROUND UPDATES, double-click the dom.push.enabled preference to switch its value from true to false -- but that may block actually useful services from sites you trust, so I don't recommend it at this point. (Note: you need to edit the text in the filter box above the list to display this preference.)

Troubleshooting: Site-Specific Permissions Are Forgotten?

Whether you enter a site permission through a drop-panel or the Page Info dialog, Firefox should remember your choice. If you are losing site-specific permissions, one possible reason is if Firefox is set to "Clear history" when it closes on the Options/Preferences page.

If you use that setting, check to the right of it for a Settings button. Click that, and make sure that "Site Preferences" is not checked -- when that's checked, you'll lose all your Allow/Block settings every time you close Firefox.

Hi, Flash can be picked up as well as what version OS you have and the browser version. When you decide not to share info when you make the question you stop us from seeing your installed Extensions which could be a issue so we end up having to make you do a test and ask for a list. It also stops us from looking at your Video Card Drivers which if are bad cause issues in a lot of places. Mac has always issues with Video Card Drivers but nothing can do about till next release. So yes we get some info, same as what others sites get and actually less as we do not want it in Support. If you do not use Flash, do not install it. Or do. SO the solution should be not install Chrome but to follow jscher2000's suggestion of setting in your gmail settings. Or : If do not use or want any notifications you can turn it all off. Websites can ask you to accept several different kinds of communications and updates: *Desktop notifications - if allowed, the site can send notifications for Firefox to display in the lower corner of your screen until you close the last tab for a site. *Web push notifications - if allowed, the site can send desktop notifications for Firefox to display in the lower corner of your screen even after the last tab for the site is closed (until you exit Firefox). *Web push updates - if allowed, the site can send Firefox updates in the background, which presumably is more efficient that forcibly refreshing a page or having a script in the page keep checking for updates. This push feature is NOT a desktop notification, but Firefox may use the notification permission panel, which I hope will be changed in the future since that's a bit confusing. Site-Specific Permissions/Blocks If the drop-panel is not available or does not work for you, while viewing the site where you want to modify a previously given permission, you can use the Permissions panel of the Page Info dialog. To call that up, either: *right-click (on Mac, Ctrl+click) a blank area of the page and choose View Page Info > Permissions (menu bar) Tools menu > Page Info > Permissions or click the padlock or "i" icon to the left of the site address, then the ">" icon, then More Information > Permissions Scroll down to "Receive Notifications" and you can check the "Use default" box (so you are prompted in the future) or uncheck that box and select the permission you prefer (for example, Block). There's no save button for this panel, changes are saved as you go. Session Do Not Disturb To disable all desktop notifications for the rest of your Firefox session (i.e., until you exit Firefox), you can turn on "Do Not Disturb" on the Options/Preferences page, Content panel. Either: *Windows: "3-bar" menu button (or Tools menu) > Options, then in the left column click Content Mac: "3-bar" menu button (or Firefox menu) > Preferences, then in the left column click Content Linux: "3-bar" menu button (or Edit menu) > Preferences, then in the left column click Content Anyone: Type or paste about:preferences#content in the address bar and press Enter/Return (you can bookmark this for faster future access) On the right side, under "Notifications", check the "Do not disturb me" box. This is for your current session only. All-Site Persistent Disable There are two different preferences for notifications, a master switch, and one which is specific to background (web push) notifications that can appear after you leave the site which sends them. (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste webno and pause while the list is filtered (3) To disable PUSH NOTIFICATIONS, double-click the dom.webnotifications.serviceworker.enabled preference to switch its value from true to false -- sites can still generate desktop notifications while you have a tab open to the site (4) To disable ALL NOTIFICATIONS, double-click the dom.webnotifications.enabled preference to switch its value from true to false -- this is a master switch, you won't get any desktop notifications from sites (5) To also disable BACKGROUND UPDATES, double-click the dom.push.enabled preference to switch its value from true to false -- but that may block actually useful services from sites you trust, so I don't recommend it at this point. (Note: you need to edit the text in the filter box above the list to display this preference.) Troubleshooting: Site-Specific Permissions Are Forgotten? Whether you enter a site permission through a drop-panel or the Page Info dialog, Firefox should remember your choice. If you are losing site-specific permissions, one possible reason is if Firefox is set to "Clear history" when it closes on the Options/Preferences page. If you use that setting, check to the right of it for a Settings button. Click that, and make sure that "Site Preferences" is not checked -- when that's checked, you'll lose all your Allow/Block settings every time you close Firefox.

Ændret af Shadow110 den