X
Tryk her for at gå til webstedets mobilversion.

Supportforum

Firefox 62 broke the solution for "I want to open new tabs in a local page", how to repair?

Skrevet

The solution posted here: https://support.mozilla.org/en-US/questions/1210576

worked wonderfully for providing an automatic load of a *local* homepage in a new tab until FF v62.0. I've checked my config file and js file, and both are correct and in the correct location, but now FF 62 broke this again. Two questions: *WHY*, and how do I force this back to the *obvious* choice of wanting a new tab to load your homepage (including *LOCAL*, no-net-needed, no junk, fast loading pages). No good explanation has ever been provided for why this simple functionality is forced away from users. This is *obvious* functionality, why is there not a good explanation of why FF developers won't provide their users with this capability.

The solution posted here: https://support.mozilla.org/en-US/questions/1210576 worked wonderfully for providing an automatic load of a *local* homepage in a new tab until FF v62.0. I've checked my config file and js file, and both are correct and in the correct location, but now FF 62 broke this again. Two questions: *WHY*, and how do I force this back to the *obvious* choice of wanting a new tab to load your homepage (including *LOCAL*, no-net-needed, no junk, fast loading pages). No good explanation has ever been provided for why this simple functionality is forced away from users. This is *obvious* functionality, why is there not a good explanation of why FF developers won't provide their users with this capability.

Yderligere systemdetaljer

Installerede plugins

  • Shockwave Flash 27.0 r0

Program

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0

Yderligere information

Luk
cor-el
  • Top 10 Contributor
  • Moderator
17540 løsninger 158599 svar

In Firefox 62 the autoconfig file is run in a sandbox that doesn't support such privileged JavaScript code. You can probably see messages in the Browser Console about this change. It is also mentioned in the Release Notes.

Updates for enterprise environments:

    AutoConfig is sandboxed to the documented API by default. You
    can disable the sandbox by setting the preference
    general.config.sandbox_enabled to false. Our long term plan is to
    remove the ability to turn off the sandboxing. If you need to
    continue to use more complex AutoConfig scripts, you will need to use
    Firefox Extended Support Release (ESR).

See also:

In Firefox 62 the autoconfig file is run in a sandbox that doesn't support such privileged JavaScript code. You can probably see messages in the Browser Console about this change. It is also mentioned in the Release Notes. *https://www.mozilla.org/en-US/firefox/62.0/releasenotes/ <blockquote><pre>Updates for enterprise environments: AutoConfig is sandboxed to the documented API by default. You can disable the sandbox by setting the preference general.config.sandbox_enabled to false. Our long term plan is to remove the ability to turn off the sandboxing. If you need to continue to use more complex AutoConfig scripts, you will need to use Firefox Extended Support Release (ESR).</pre></blockquote> See also: *https://support.mozilla.org/en-US/questions/1230731