Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I am having problems with Local Storage on some websites (ERS 52.9)

  • 3 svar
  • 1 har dette problem
  • 7 visninger
  • Seneste svar af Shadow110

more options

So I had my firefox update to ESR 60, and I restored my old browser and profile from backup. Details of that are here: https://support.mozilla.org/en-US/questions/1232392

The problem? I am having trouble with Local Storage.

I tried restoring different profiles from different days from Time Machine. I managed to get one where things seemed to work. Until I quit and restarted firefox.

Mega (mega.nz) tells me: Sorry, we were unable to initialize the browser's local storage, either you're using an outdated/misconfigured browser or it's something from our side.

If you think it's our fault, please report the issue back to us.

Reason: [Exception... "File error: Corrupted" nsresult: "0x8052000b (NS_ERROR_FILE_CORRUPTED)" location: "JS frame :: https://mega.nz/secureboot.js?r=1536229029 :: <TOP_LEVEL> :: line 331" data: no] Browser: mozilla/5.0 (macintosh; intel mac os x 10.9; rv:52.0) gecko/20100101 firefox/52.0

Trimps (trimps.github.io) tells me:

Your browser is preventing Trimps from accessing localStorage, and you will not be able to save or load your progress. Please check your browser settings to ensure that 3rd party cookies are not disabled, and that you're not using any addons that might interrupt storage!

AutoSave has been disabled to prevent damage to your save. If you previously had a save file, it should still be waiting for you once you fix your browser settings.

Antimatter dimensions (ivark.github.io) just shows me a brand-new game, 9 months of progress lost.

Preferences -> advanced only lists 5 sites with offline data, all of them listed with 0 bytes. Two of these are twitter, the other three are unknown.

Profile_dir/storage has three folders -- temporary, default, permanent -- and inside there are lots of folders for various websites. But I don't see one for either github.io site. Permissions on these folders are normal. But the dates are mostly OLD.

But, only mostly. If I just open firefox, and then close a minute or two later, a bunch of them are updated to "now". Even if I am not visiting the site in question.

Alle svar (3)

more options

You get errors with local storage when you downgrade a profile from a recent Firefox version to on older Firefox version like 52 ESR.

If that is what you did then try to remove the storage folder and the storage.sqlite file in the profile folder.

more options

Odd. I had this problem when I restored my profile, and when I restarted firefox.

So, it wasn't just running my profile on an earlier version. I tried that, found that my add-ons had been munged, restored my profile, and things were back to normal for one launch of the browser.

Right now, I have done another restore, and restart. I'm going to save/export everything that I can out of local storage before my next reset.

more options