Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox high use of CPU even when not open

  • 7 svar
  • 1 har dette problem
  • 21 visninger
  • Seneste svar af Shadow110

more options

I turn on my computer and hear my PC sweating a little. Check Task Manager and there's Firefox using 28.8% of my CPU and I hadn't even opened it or used it. Even now as I type still uses high CPU.

Vedhæftede skærmbilleder

Alle svar (7)

more options

Hello,

The Refresh feature (called "Reset" in older Firefox versions) can fix many issues by restoring Firefox to its factory default state while saving your bookmarks, history, passwords, cookies, and other essential information.

Note: When you use this feature, you will lose any extensions, toolbar customizations, and some preferences. See the Refresh Firefox - reset add-ons and settings article for more information.

To Refresh Firefox:

  1. Open the Troubleshooting Information page using one of these methods:
    • Click the menu button New Fx Menu , click help Help-29 and select Troubleshooting Information. A new tab containing your troubleshooting information should open.
    • If you're unable to access the Help menu, type about:support in your address bar to bring up the Troubleshooting Information page.
  2. At the top right corner of the page, you should see a button that says "Refresh Firefox" ("Reset Firefox" in older Firefox versions). Click on it.
  3. Firefox will close. After the refresh process is completed, Firefox will show a window with the information that is imported.
  4. Click Finish and Firefox will reopen.

Did this fix the problem? Please report back to us!

Thank you.

more options

Tyler Downer said

Hello, The Refresh feature (called "Reset" in older Firefox versions) can fix many issues by restoring Firefox to its factory default state while saving your bookmarks, history, passwords, cookies, and other essential information. Note: When you use this feature, you will lose any extensions, toolbar customizations, and some preferences. See the Refresh Firefox - reset add-ons and settings article for more information. To Refresh Firefox:
  1. Open the Troubleshooting Information page using one of these methods:
    • Click the menu button New Fx Menu , click help Help-29 and select Troubleshooting Information. A new tab containing your troubleshooting information should open.
    • If you're unable to access the Help menu, type about:support in your address bar to bring up the Troubleshooting Information page.
  2. At the top right corner of the page, you should see a button that says "Refresh Firefox" ("Reset Firefox" in older Firefox versions). Click on it.
  3. Firefox will close. After the refresh process is completed, Firefox will show a window with the information that is imported.
  4. Click Finish and Firefox will reopen.
Did this fix the problem? Please report back to us! Thank you.

Thanks for a swift reply. But I don't want to Reset Firefox every time there's some problem. I am not experiencing slowness or anything like that. But the process opens on it's own. Can we investigate this issue.

more options

Let's try the refresh, and see if there are still issues. Firefox shouldn't be leaving a process open, so obviously something is wrong. A refresh can help.

more options

Did the refresh. Still the same.

more options

Hi, maybe something here : To be Checked and turned off unless needed for accessibility : Please : go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser.

Multi-Processor Support : Go to the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please. Note : Hardware Acceleration is for Video Card, Monitor to see if remain off or to turn back on.

Only Disable as last resort.

Multi-processor Can completely disable it this way in about:config : dom.ipc.processCount set to 1 browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

Only move to esr if low ram and old system.

Firefox Extended Release Version : Firefox ESR does not come with the latest features but it has the latest security and stability fixes.

If do please :

more options

Just re-installed Firefox and the problem is still the same. Restarted computer and Firefox just starts on its own after restart and opens up browser plus this window.

more options

Hi, If you do not have a backup of bookmarks and Profile please grab it from here :

Make sure store it in a safe place the below can not find. Also download this :

Can you kill the processes that are running to uninstall Firefox ? So you want to stop Firefox from running.

If need to go to Safe Mode in Windows 10 :

Reinstall with Current Release Firefox 62.0.0 with a Full Version Installer