Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox extremely slow to load pages after startup

  • 12 svar
  • 17 har dette problem
  • 42971 visninger
  • Seneste svar af bornival

more options

For the past few days, Firefox has been extremely slow to load pages at startup. The browser itself launches pretty much instantly, but it's taking over six minutes after that just to look up domains. At some point it gets past whatever hiccup is holding things up and browsing works for the rest of the session -- noticeably slower than usual, but usable.

It happens with add-ons disabled, after multiple refreshes, and even after a full reinstall (with new profile). I've played with all the common suspects -- disabling accessibility options, hardware acceleration, IPv6, etc. I closed my pinned tabs and disabled auto-restoring the previous session. I even disabled Avast and MalwareBytes. Nothing has helped so far (which is seriously disappointing, considering the 6-minute restart between each change!)

The odd thing is that there are a few seconds, immediately after startup, where things seem to work normally. If I'm quick, I can sometimes get most of one webpage to load before the problem begins.

I've been a Firefox power user since version 0.6.2 and never encountered anything like this. I'm very comfortable with changing settings, configuration files, etc., and am willing to try just about anything to get things cranking again. But right now I'm simply out of other ideas to try.

Using 61.0.2, 64-bit version on fully-patched Windows 10 on a very fast fiber connection. <edit> I also tried the 32-bit version; no joy. </edit>

Ændret af MatthewJay den

Valgt løsning

Well, Windows updated last night, and this morning this problem is gone and Firefox is back to being blazingly fast. I have no idea if it was the Windows update, or perhaps an update to my security apps, but it evidently wasn't a problem with Firefox.

Læs dette svar i sammenhæng 👍 0

Alle svar (12)

more options
more options

Yep, I've done that several times (including with a fresh profile).

more options

Valgt løsning

Well, Windows updated last night, and this morning this problem is gone and Firefox is back to being blazingly fast. I have no idea if it was the Windows update, or perhaps an update to my security apps, but it evidently wasn't a problem with Firefox.

more options

That was very good work. Well done.

more options

GOOD NEWS!! I BELIEVE I HAVE FINALLY DISCOVERED THE SOLUTION TO THIS PROBLEM THAT SEEMS TO AFFECT MANY USERS WITH NO REAL SOLUTIONS.......

I have fought this issue for months. I am currently running windows XP SP3 with Firefox 52.9.0 ESR. I've went through all the suggestions posted all over the web and on the support pages of Mozilla. Refreshed (didn't work).....Started in Safe Mode (Didn't Work)......uninstalled Firefox and wiped every reference to Firefox. Then, reinstalled Firefox and it worked fine for about 1 day. Then, back to slow loading of the first page.....sometimes as long as 45 seconds. It was very irritating.

I have experimented with numerous settings and configurations and finally...........I discovered that after I delete the Archive folders from the data reporting folder of my profile...everything returns to normal for a short time. After awhile, when the first web page loads slowly, I go to my profile folder and delete the current Archive Folder from the Data Reporting folder and everything returns to normal once again.

I now have ccCleaner configured to delete this folder each time I run ccCleaner......viola ....... problem solved!!!!! The first page now loads promptly at startup as it should....

I certainly hope this workaround helps someone else experiencing this irritating problem. Oh, and out of curiousity, what is that archive folder's job anyway? Apparently it isn't a critical file necessary to run Firefox. In my case, removing it actually improves the performance of my browser.

more options

delclemons,

Good find, I too have suffered this issue especially with FF 62.N.N

Deleting the Archive folders gave me the same results; page loading speed is now near instantaneous as compared to before removing the files.

Pages where taking as you said up to 45 seconds.

Interesting as the Archive files were actually quit small in my case, just about 900KB..

But getting rid of them makes all the difference in the world.

Thanks, Bill

more options

Hi, I have the same problem and wish to try the same solution. But where can I find the Archive files (Archive folder) ?

more options

bornival,

A couple of different ways to do this and here is one.

Open File Explorer, at the top of FE in the Directory Bar enter:

%APPDATA%\Mozilla\Firefox\Profiles\ (enter)

If you have more than one sub directory you need to find the active one by looking at the Last Modified date of each. The most recent one is your active FF home dir.

Change to that directory, then change to DataReporting, Archived.

Remove any sub directories there. I do it without closing FF and have had no issues.

So the whole path would look something like:

%APPDATA%\Mozilla\Firefox\Profiles\LastModifiedDir\DataReporting\Archived

For me, I have found once I removed the initial sub dirs my problem went away, it was like the ones that were there may have been corrupted. I removed them for about a week and then have quit doing this since the problem has since gone away.

Good luck with your issue!

more options

Thank you. I have now found the archive folder and deleted its content as suggested, but it did not help. Maybe I need to describe a little better my (minor) problem.

When I launch FireFox, it starts almost instantly but takes some time before the home page opens. From the home page, the text comes very quickly but the images not... They eventually come but slowly. Once the home page is loaded, it reloads very quickly if I open a new tab (I have the extension "New Tab Homepage" that loads my homepage when I open a new tab).

This did not happen with the older version of FireFox and does not happen with Google Chrome (both loaded/loads the text and the images almost instantly).

I disabled all my extensions, dictionaries, and plug-ins but to no avail.

What could be the reason ?

Ændret af bornival den

more options

I understand your pain. I have had these issues also over time.

Completely clearing cache and history?

Have you tried creating a new profile?

Do a total uninstall of FF and remove old directories?

And just a comment on your New Tab Homepage. Why not set it to a blank page? Maybe you have a reason to see multiple Home pages across your tabs, if not by choosing a blank page there is a lot less overhead.

Of the suggestions I made above of course clearing cache and history are the least painful. I have had luck with creating a new profile more often than not.

Hope this helps. Also I did find a good page on things that you can try in general for performance "tuning" if you are interested:

https://www.webnots.com/fix-slow-page-loading-issue-in-mozilla-firefox/

more options

Try adding Firefox to firewall permissions.

Windows 10: Settings > Updates & Security > Windows Security > Firewall & network protection > Allow an app through firewall > Change settings > Allow another app

Worked for me

Might be a huge security concern though...

Ændret af p3rs0n_0f_1nt3rn3t den

more options

Thank you but I use Win7 (not Win10) and I have the ZoneAlarm firewall (that turns off the Windows firewall). Cheers, Paul