X
Tryk her for at gå til webstedets mobilversion.

Supportforum

Firefox does not respect system audio settings in MacOS

Skrevet

I have a 2012 Macbook Pro, MacOS 10.13.5 (17F77), with MOTU Traveler Mk3 audio interface. MOTU has several analogue and digital outputs. I normally use just the AES/EBU digital outputs, and the analogue outputs are not connected to anything. This is the system default and all audio-using applications that I use, including Chrome and Safari, respect this default and use the AES/EBU output, except Firefox. From MOTU's software mixer I see that whenever I play audio with Firefox, it goes to the first two analogue channels of the MOTU. I have carefully gone through all OS and MOTU settings that could pertain to this and set them to use AES/EBU. Firefox is version 61.0b12 developer edition.

I have a 2012 Macbook Pro, MacOS 10.13.5 (17F77), with MOTU Traveler Mk3 audio interface. MOTU has several analogue and digital outputs. I normally use just the AES/EBU digital outputs, and the analogue outputs are not connected to anything. This is the system default and all audio-using applications that I use, including Chrome and Safari, respect this default and use the AES/EBU output, except Firefox. From MOTU's software mixer I see that whenever I play audio with Firefox, it goes to the first two analogue channels of the MOTU. I have carefully gone through all OS and MOTU settings that could pertain to this and set them to use AES/EBU. Firefox is version 61.0b12 developer edition.

Yderligere systemdetaljer

Installerede plugins

  • Shockwave Flash 28.0 r0

Program

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:61.0) Gecko/20100101 Firefox/61.0

Yderligere information

Luk
Shadow110 1072 løsninger 14836 svar

Hi, that is what you get for running a Beta. https://bugzilla.mozilla.org/ https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines


Have you tried it on a regular release ?

Hi, that is what you get for running a Beta. https://bugzilla.mozilla.org/ https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines Have you tried it on a regular release ?

Spørgsmålsstiller

I did now. Indeed in most cases latest version 60 does route sound to the right place. The only case where that too was using the analogue channels was Soundcloud. I am not sure what is special about Soundcloud.

Anyway, thanks for the reminder. I suppose it's a matter of time when the bug is fixed in 61.

I did now. Indeed in most cases latest version 60 does route sound to the right place. The only case where that too was using the analogue channels was Soundcloud. I am not sure what is special about Soundcloud. Anyway, thanks for the reminder. I suppose it's a matter of time when the bug is fixed in 61.
the-edmeister
  • Top 25 Contributor
  • Moderator
5425 løsninger 40489 svar

Nyttigt svar

shem73 said

I suppose it's a matter of time when the bug is fixed in 61.

Nothing is going to be fixed if the Bugzilla triage people aren't even aware of your problem. At a minimum you should search for a related Bugzilla report, and if you don't find one open your own Bugzilla report.

Plus, fixing it by the next release version is very rare unless the Bug report was filed during the Nightly or Beta phases of development and the Bug wasn't considered important enough to halt the Release version of Fx 60.

''shem73 [[#answer-1121841|said]]'' <blockquote> I suppose it's a matter of time when the bug is fixed in 61. </blockquote> Nothing is going to be fixed if the Bugzilla triage people aren't even aware of your problem. At a minimum you should search for a related Bugzilla report, and if you don't find one open your own Bugzilla report. Plus, fixing it by the next release version is very rare unless the Bug report was filed during the Nightly or Beta phases of development and the Bug wasn't considered important enough to halt the Release version of Fx 60.

Spørgsmålsstiller

Right. I'll go hunting for Bugzilla.

Right. I'll go hunting for Bugzilla.
rdent4 0 løsninger 1 svar

Nyttigt svar

I have same problem in Firefox 61. Chrome does chose the native audio device but not Firefox,

I have same problem in Firefox 61. Chrome does chose the native audio device but not Firefox,