Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cookie management in FF 60.0 not working properly

  • 14 svar
  • 1 har dette problem
  • 30 visninger
  • Seneste svar af user1494117

more options

I have noticed now in Firefox 60.0 on Linux, that I'm now unable to delete cookies.

If I'm using Facebook for example, then exit, I have always been able to go to the cookies and remove the Facebook cookie. However, even though it is not showing (Under Prefs, Privacy & Security / Manage data), the cookie is obviously still there, as when I then go to the FB site, I'm already logged in.

No cookies at all are showing under Firefox.

Alle svar (14)

more options

Which flavor of Linux are you running?

more options

tesko said

Which flavor of Linux are you running?

Kubuntu 16.04.4 LTS

more options

a LOT of people are running into problems with firefox on Ubuntu and it's family (kubuntu, xubuntu, edubuntu and the rest)

is kubuntu up to 18.04 now? i would suggest updating to it if you can or if you wanted to try and erase the problem run pure Debian/GNU (which i believe is the best solution)

you could also download the beta or nightly as nightly gets auto-updated as it progresses.

would you like to know how i ran it when i was on Debian?

more options

You can also use the Storage Inspector.

Do you mean that you close Firefox with tabs still open?

If that is the case then Firefox stores its cookies in sessionstore.jsonlz4 as part of the session data. To prevent this you can set browser.sessionstore.privacy_level = 2 on the about:config page.

Are you possibly running Firefox in Private Browsing mode (never remember history)?

more options

tesko said

a LOT of people are running into problems with firefox on Ubuntu and it's family (kubuntu, xubuntu, edubuntu and the rest) is kubuntu up to 18.04 now? i would suggest updating to it if you can or if you wanted to try and erase the problem run pure Debian/GNU (which i believe is the best solution)

Yes, Kubuntu is up to 18.04.0 LTS now. It's a huge job to upgrade to 18.04 for me. I did look at Debian once, but it wasn't suitable for running all the "K" apps I use. I _think_ that was the reason ?? Not sure.

tesko said

you could also download the beta or nightly as nightly gets auto-updated as it progresses.

Okay thanks, I'll look at doing that, possibly.

My major concern is that I have "lost" the ability to manage cookies. I will attach a screen dump of what Firefox 'thinks' are the cookies, when in actual fact there are a number of cookies not being shown. In fact, none of them are being shown.

more options

You can also check if using: Accept cookies and site data from websites (recommended) set to: (Until Firefox is Closed)

That setting is in Privacy & Security preferences tab.

more options

How are you opening the Cookie Manager?

Do you use the button on the "Options/Preferences -> Privacy & Security" page because the screenshot shows the 'classic' Cookie Manager and not the new Cookie Manager that shows other types of storage?

more options

cor-el said

You can also use the Storage Inspector.

Okay thanks, I will look at using that. This has caused me to look through some of the other SQLite db's that are kept by Firefox. When I looked through the 'forms' one, I was a bit shocked that it had credit card details in it.

I do know that some sites, like Facebook, read third party cookies, and as I do internet banking, I'd rather manually delete any internet banking (cookies) after I exit the internet banking session.

I might be wise to backup the bookmarks, delete everything under the ~/.mozilla path and reinstall Firefox.

cor-el said

Do you mean that you close Firefox with tabs still open?

Yes, I often close Firefox in that manner, rather than having to close many tabs. I have 'keep cookies until I closee Firefox', so assume that all cookies will be removed by closing Firefox with tabs open.

cor-el said

If that is the case then Firefox stores its cookies in sessionstore.jsonlz4 as part of the session data. To prevent this you can set browser.sessionstore.privacy_level = 2 on the about:config page.

I looked for the file 'sessionstore.jsonlz4' and it is not present.

cor-el said

Are you possibly running Firefox in Private Browsing mode (never remember history)?

No, I don't use private browsing mode.

For some reason, facebook keeps adding folders under the .../storage/temporary and .../storage/default folders for some reason ? Not sure if that is connected with the private browsing mode ??

more options

Corey 'linuxmodder' Sheldon said

You can also check if using: Accept cookies and site data from websites (recommended) set to: (Until Firefox is Closed) That setting is in Privacy & Security preferences tab.

Yes, that is set the way you have explained, thanks.

more options

cor-el said

How are you opening the Cookie Manager? Do you use the button on the "Options/Preferences -> Privacy & Security" page because the screenshot shows the 'classic' Cookie Manager and not the new Cookie Manager that shows other types of storage?

Yes, I display cookies by using the button in the manner in which you have explained. Definitely.

Possibly the (i) backup bookmarks, (ii) delete everything and (iii) reinstall Firefox is a good start for now.

more options

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

Try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution.

more options

cor-el said

Try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution.

I downloaded the Linux version, then extracted to a temp folder. The one I downloaded looks about a week older than what I currently have installed. The one downloaded has dates 4th May 2017 and the firefox installed has dates 10th May 2017.

more options

try this :

make a folder in your ~/ called "stuff" or "junk" or anything you like.

download this nightly build (im going to assume you run a 64 bit machine, if not ill link you to a 32bit version)

once in the console, cd to "stuff" or "junk" or whatever"

extract the archive there

cd to firefox

then type ./firefox &

this is how I got firefox nightly to run when i wanted to use nightly. its easier to rm -rf /firefox/ this way as it comes precompiled.

if you need me, im in #sumo on irc, same nick

Ændret af user1494117 den