Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox sometimes opens dialogs and menus off screen when run in Win10 auto start

  • 7 svar
  • 1 har dette problem
  • 5 visninger
  • Seneste svar af Shadow110

more options

I had this problem for a while now, although it seems to start ocurring randomly and it is almost always fixed by restarting firefox.

First I thought Firefox is just not opening dialogs and menus at all. - The menu button (upper right corner) does nothing - When I press ALT to open the menu bar, the bar is visible, but the submenus are not - The download button does nothing

But today I had a certificate warning dialog. This dialog (if memory serves right) increases in height after the first action. this made it partially visible for me: The lower end of the dialog peeked into my desktop from above, showing me the buttons of the dialog. I experimented a bit and found out that when all these GUI elements should be visible, they can be interacted with via the keyboard. This leads me to think that these elements are in fact just off screen instead of missing completely.

As I said, restarting Firefox usually fixes this behaviour, but the problem comes back up again; either after a while of usage, or sometimes even directly after starting/restarting Firefox.

Things I have already tried: - Removed all plugins - Removed profile and started a fresh, new one - Reinstalled Firefox - Windows 10 "start fresh" reset (this one was not really to fix this issue, but for a different reason. this Firefox issue persisted anyway)

I am on Win 10 Pro version 1709, build 16229.371

Ændret af lostmekka den

Alle svar (7)

more options

Hi, try uninstalling this way : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do :

Reinstall with Current Release Firefox 59.0.2 with a Full Version Installer

Please let us know if this solved your issue or if need further assistance.

more options

Just in case this is a issue : *Repair System Registry and Files Find the Dos Prompt or Powershell then Right Click and Run as Administrator then : Copy/Paste to Dos Window : DISM /Online /Cleanup-Image /RestoreHealth then hit Enter. Reboot when completed. Note : DISM goes up to Microsoft for new files.

more options

You can try to disable hardware acceleration in Firefox.

Close and restart Firefox after modifying the setting to make the change effective.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

more options

Pkshadow said

Hi, try uninstalling this way : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do : Reinstall with Current Release Firefox 59.0.2 with a Full Version Installer Please let us know if this solved your issue or if need further assistance.

I have done this and so far, Firefox behaves correctly. I will test this a bit more, but it looks promising.

Before applying this fix, the best way to reproduce the issue was to have Firefox in autostart and restarting Windows. The first time that Firefox started was almost always having this issue. I even thought that maybe my original thinking was wrong: It could be that it always was the first startup of Firefox that triggered the issue, given that it takes some time to notice since I do not always use the download or main menu.

Now after system cleanup and reinstall, I could not reproduce the issue with autostarting Firefox after rebooting.

I will test it a bit more thoroughly and will get back to you with the results. Thanks to you and cor-el for your quick replies :)

more options

Unfortunately, the issue reappeared today. Even when I initiate a download, the standard dialog which is asking what I want to do with the file is somewhere off screen...

I have run `DISM /Online /Cleanup-Image /RestoreHealth`, disabled hardware acceleration for Firefox and my graphics drivers are up to date. The issue still persists :(

It seems like Firefox is somehow assuming that the desktop screen setup is different from what it actually is. I have two monitors side by side and Firefox is always on the left one. The certificate warning dialog I discovered earlier peeked into the desktop from above the right screen.

The one thing that might be a bit uncommon is that I have a HTC Vive that I only connect via HDMI when I play/develop VR games. Maybe Firefox sometimes assumes that there is a third screen above my normal two displays? I also think that it just occurs after a reboot when Firefox is auto started. Could it be that Firefox starts before the Windows display initialization is done?

I don't know for sure how Windows handle auto start apps nowadays, but it seems like it starts them even before the user has logged in. (or at least in that instance, before the first real desktop frame hits the screen) Maybe Firefox gets uninitialized data about what displays exist and where they are located?

Next time the issue occurs I will try to move the Firefox window to another screen and change the screen layout in the Windows settings, instead of restarting Firefox. Maybe this could also trigger Firefox to fetch the current display arrangement.

All just speculation, but better than nothing I guess ^^

Ændret af lostmekka den

more options

I had the Issue again. Moving Firefox to another screen didn't fix it, but changing the screen setup in the windows display settings did! So it really is an issue where Firefox seems to have wrong data on how the screens are arranged.

So... How to fix this then?

I would assume that a dirty workaround would be to not let Firefox auto start directly, but to auto start a script instead that will wait some time and then start Firefox. (this assumes that the auto start items are executed on login, not before) This of course is not a satisfying long term solution ^^

Maybe Firefox should poll the screen arrangement from time to time? This may be overkill too ^^

more options

Hi, you could really through a wrinkle into things and update Win10 to 1803 after updating your programs and make sure your files are safe : Windows Spring Update out April 30th so back up stuff you want to save to another drive. https://www.windowscentral.com/microsoft-announces-windows-10-april-2018-update Use Media Creation Tool to Update, or not. If decide to stay at what ever version you are running then would be best to : file a bug report. https://bugzilla.mozilla.org/ Bug Writing Guidelines : https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines

Or if go up see what happens.

Please let us know if this solved your issue or if need further assistance.