X
Tryk her for at gå til webstedets mobilversion.

Supportforum

Firefox is extremely laggy when on YouTube or other media websites

Skrevet

Hello everyone,

So yeah the tittle is pretty self-explanatory: whenever I go to a website playing a medai (music, or video) firefox becomes super slow, and the sound starts to crash / shutter. I'm on windows 10, latest Firefox 59.

For example when I go and lauch a youtube video, the first few seconds of the video are impossible to understand because it's so laggy and bugged. I really don't know what to do. Here's a non-exaustive list of what I've tried so far: - Disabling hardware accelaration - Updating Adobe Flash - Updating my sound drivers - Updating my windows - Switching to the beta version firefox 60 - Making a clean install of my Firefox and refreshing it - Disabling OpenGL - Scanning my computer for viruses (nope)

Anyway maybe I forgot some stuff because I did a lot of things before asking this question, so if anyone has an idea... I'm all ears.

Hello everyone, So yeah the tittle is pretty self-explanatory: whenever I go to a website playing a medai (music, or video) firefox becomes super slow, and the sound starts to crash / shutter. I'm on windows 10, latest Firefox 59. For example when I go and lauch a youtube video, the first few seconds of the video are impossible to understand because it's so laggy and bugged. I really don't know what to do. Here's a non-exaustive list of what I've tried so far: - Disabling hardware accelaration - Updating Adobe Flash - Updating my sound drivers - Updating my windows - Switching to the beta version firefox 60 - Making a clean install of my Firefox and refreshing it - Disabling OpenGL - Scanning my computer for viruses (nope) Anyway maybe I forgot some stuff because I did a lot of things before asking this question, so if anyone has an idea... I'm all ears.

Valgt løsning

I called for more help.

This is not a cure, but should let the web page load without crashing.

https://addons.mozilla.org/firefox/addon/disable-autoplay/ Disable HTML5 Autoplay by Afnan Khan Firefox 55+ Disable autoplay and preloading of HTML5 video and audio players.


https://addons.mozilla.org/en-US/firefox/addon/flashblock/ Flash block Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way, but if you want to see it, just click on it

or

You can set this pref; media.block-autoplay-until-in-foreground = true

Type about:config<enter> in the address bar. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar.

Læs dette svar i sammenhæng 0

Yderligere systemdetaljer

Installerede plugins

  • Shockwave Flash 29.0 r0

Program

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0

Yderligere information

Luk
FredMcD
  • Top 10 Contributor
4271 løsninger 59904 svar

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}

Make sure you are not blocking content. [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? --------------- One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: [https://support.mozilla.org/en-US/kb/tracking-protection Tracking Protection] {web link}

Spørgsmålsstiller

Hi,

The problem persists when in safe mode. Same with the tracking protection, that I've disabled to run a test... Problem's still here.

Thanks for trying to help :)

Hi, The problem persists when in safe mode. Same with the tracking protection, that I've disabled to run a test... Problem's still here. Thanks for trying to help :)
FredMcD
  • Top 10 Contributor
4271 løsninger 59904 svar

Start your Computer in safe mode with network support. Then start Firefox. Try Safe websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Start your '''Computer''' in safe mode with network support. Then start Firefox. Try '''Safe''' websites. Is the problem still there? http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Spørgsmålsstiller

Hi FredMcD, first of all sorry for the long time to answer.

I tried to run in safe mode, and it is a bit better: the sound distortion is not as bad and my firefox isn't freezing completely, however I still have some stuttering and the audio gets out of sync with the video.

Anw clues what might cause this? I'm really out of solutions here... Thank you for your time :)

Hi FredMcD, first of all sorry for the long time to answer. I tried to run in safe mode, and it is a bit better: the sound distortion is not as bad and my firefox isn't freezing completely, however I still have some stuttering and the audio gets out of sync with the video. Anw clues what might cause this? I'm really out of solutions here... Thank you for your time :)
FredMcD
  • Top 10 Contributor
4271 løsninger 59904 svar

With 'some' improvement in Computer Safe Mode means that one of the other programs on your system is causing the issue.


See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration


As a test, disable your protection programs.

With 'some' improvement in Computer Safe Mode means that one of the other programs on your system is causing the issue. ---------------- See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration -------------- As a test, disable your protection programs.

Spørgsmålsstiller

So, there's no update for my driver (I'm using a Nvidia GeForce) but I'll try to re-install the driver to see if this helps.

i also tried to turn off my protection program (Avast and ZoneAlarm) and no changes were made.

So, there's no update for my driver (I'm using a Nvidia GeForce) but I'll try to re-install the driver to see if this helps. i also tried to turn off my protection program (Avast and ZoneAlarm) and no changes were made.
FredMcD
  • Top 10 Contributor
4271 løsninger 59904 svar

Valgt løsning

I called for more help.

This is not a cure, but should let the web page load without crashing.

https://addons.mozilla.org/firefox/addon/disable-autoplay/ Disable HTML5 Autoplay by Afnan Khan Firefox 55+ Disable autoplay and preloading of HTML5 video and audio players.


https://addons.mozilla.org/en-US/firefox/addon/flashblock/ Flash block Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way, but if you want to see it, just click on it

or

You can set this pref; media.block-autoplay-until-in-foreground = true

Type about:config<enter> in the address bar. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar.

I called for more help. This is not a cure, but should let the web page load without crashing. https://addons.mozilla.org/firefox/addon/disable-autoplay/ Disable HTML5 Autoplay by Afnan Khan Firefox 55+ Disable autoplay and preloading of HTML5 video and audio players. https://addons.mozilla.org/en-US/firefox/addon/flashblock/ Flash block Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way, but if you want to see it, just click on it or You can set this pref; '''media.block-autoplay-until-in-foreground = true''' Type '''about:config'''<enter> in the address bar. If a warning screen comes up, press the '''I Accept the Risk''' button. At the top of the screen is a search bar.

Spørgsmålsstiller

Hi,

I couldn't use flashbock on my firefox, nor I had the media.block-autoplay-until-in-foreground pref in about:config; but enabling Disable Autoplay on Youtube (which I had disabled) solved my problem.

Allowing the media to fully charge before launching it seems to prevent it from crashing, so I hope this solution will be permanent!

Thanks a lot for your help!

Hi, I couldn't use flashbock on my firefox, nor I had the '''media.block-autoplay-until-in-foreground''' pref in about:config; but enabling Disable Autoplay on Youtube (which I had disabled) solved my problem. Allowing the media to fully charge before launching it seems to prevent it from crashing, so I hope this solution will be permanent! Thanks a lot for your help!
FredMcD
  • Top 10 Contributor
4271 løsninger 59904 svar

Glad to help. Safe Surfing.

Glad to help. Safe Surfing.