X
Tryk her for at gå til webstedets mobilversion.

Supportforum

High memory usage

Skrevet

I recently bought a new laptop of which I updated all the drivers & software first. With everything updated I then installed the latest 64-bit Firefox, and then checked my mail. No addons, or themes, or whatever was installed as of yet.

With just my mail open Firefox was already using near 1GB of memory (865MB)! Is this normal for Firefox to use this much for just one tab? I have Firefox 53 on my old laptop and it can go 10 tabs before it even reaches 1GB...

I recently bought a new laptop of which I updated all the drivers & software first. With everything updated I then installed the latest 64-bit Firefox, and then checked my mail. No addons, or themes, or whatever was installed as of yet. With just my mail open Firefox was already using near 1GB of memory (865MB)! Is this normal for Firefox to use this much for just one tab? I have Firefox 53 on my old laptop and it can go 10 tabs before it even reaches 1GB...

Yderligere systemdetaljer

Installerede plugins

  • Shockwave Flash 26.0 r0

Program

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0

Yderligere information

Luk
FredMcD
  • Top 10 Contributor
4247 løsninger 59410 svar

Your system details shows you are using Firefox 53. Is there a reason? (I am still using v54)

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/kb/Firefox+is+already+running+but+is+not+responding

https://support.mozilla.org/en-US/kb/firefox-slow-how-make-it-faster

https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix

https://support.mozilla.org/en-US/kb/firefox-uses-too-much-memory-ram

https://support.mozilla.org/en-US/kb/firefox-hangs-or-not-responding

Your system details shows you are using Firefox 53. Is there a reason? (I am still using v54) [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? https://support.mozilla.org/kb/Firefox+is+already+running+but+is+not+responding https://support.mozilla.org/en-US/kb/firefox-slow-how-make-it-faster https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix https://support.mozilla.org/en-US/kb/firefox-uses-too-much-memory-ram https://support.mozilla.org/en-US/kb/firefox-hangs-or-not-responding
FredMcD
  • Top 10 Contributor
4247 løsninger 59410 svar

Are you using a beta version of Firefox?

Are you using a beta version of Firefox?

Nyttigt svar

Yes I'm still currently using my old laptop with Firefox 53 right now because I'm still transferring files to place on my new machine.

My new laptop is literally fresh out of the box. After getting everything up to date the only thing I've installed is the 64-bit stable version of Firefox . With everything so new I don't know why 1 tab will make it go up to 1GB... It doesn't matter what website I visit. Safe mode did nothing plus all those other links as well. Also tried setting the Performance from 4 -> 2 which also did nothing.

And you're asking why I don't update? It's to avoid troubles like this. Firefox 53 is literally doing a better job than the latest build. I mean I have 32 tabs open right now but just look at the memory difference!

Latest Firefox: 1 tab = 1GB Firefox 53: 32 tab = 1.2 GB

Yes I'm still currently using my old laptop with Firefox 53 right now because I'm still transferring files to place on my new machine. My new laptop is literally fresh out of the box. After getting everything up to date the only thing I've installed is the [https://download.mozilla.org/?product=firefox-latest-ssl&os=win64&lang=en-US 64-bit stable version of Firefox] . With everything so new I don't know why 1 tab will make it go up to 1GB... It doesn't matter what website I visit. Safe mode did nothing plus all those other links as well. Also tried setting the Performance from 4 -> 2 which also did nothing. And you're asking why I don't update? It's to avoid troubles like this. Firefox 53 is literally doing a better job than the latest build. I mean I have 32 tabs open right now but just look at the memory difference! Latest Firefox: 1 tab = 1GB Firefox 53: 32 tab = 1.2 GB
FredMcD
  • Top 10 Contributor
4247 løsninger 59410 svar

The image you uploaded failed to load. Can you try again?

Many have reported issues using the 64bit Firefox. Install the 32bit version.

Install Older Version Of Firefox {web link} Be sure to read everything here.

If you still want to downgrade, look under; I still want to downgrade. Click the Directory of other versions and languages link. Look for the directory of the version that you want. But, remember that old versions may have security issues.

You should also check out Firefox; Extended Support Release {web link} ESR Notes System Requirements

The image you uploaded failed to load. Can you try again? Many have reported issues using the 64bit Firefox. Install the 32bit version. [https://support.mozilla.org/en-US/kb/install-older-version-of-firefox?cache=no Install Older Version Of Firefox] {web link} Be sure to read everything here. If you still want to downgrade, look under; '''I still want to downgrade. ''' Click the '''Directory of other versions and languages''' link. Look for the directory of the version that you want. But, remember that '''old versions may have security issues. ''' You should also check out [https://www.mozilla.org/en-US/firefox/organizations/ Firefox; Extended Support Release] {web link} [https://www.mozilla.org/en-US/firefox/organizations/notes/ ESR Notes] [https://www.mozilla.org/en-US/firefox/organizations/system-requirements/ System Requirements]

Spørgsmålsstiller

Unfortunately, using 32-bit didn't fix the problem.

The image attached is a comparison between the latest 64-bit Firefox and 64-bit Firefox 53. Using the same websites, the same amount of tabs, no installed add-ons or themes, etc. you can see there is a 'BIG!' difference when it comes to memory management.

In case the image upload fails again here's a link.

Unfortunately, using 32-bit didn't fix the problem. The image attached is a comparison between the latest 64-bit Firefox and 64-bit Firefox 53. Using the same websites, the same amount of tabs, no installed add-ons or themes, etc. you can see there is a ''''''BIG!'''''' difference when it comes to memory management. In case the image upload fails again here's a [https://i.imgur.com/toDPFq3.jpg link.]
FredMcD
  • Top 10 Contributor
4247 løsninger 59410 svar

I called for more help.

I called for more help.

Spørgsmålsstiller

> Called for more help > No one comes for more than a week

Okay I'm marking this thread as solved because obviously the solution was to ignore this thread in hopes that I stop caring.

> Called for more help > No one comes for more than a week Okay I'm marking this thread as solved because obviously the solution was to ignore this thread in hopes that I stop caring.
cor-el
  • Top 10 Contributor
  • Moderator
17479 løsninger 157962 svar

You can try to adjust multi-process settings to see if this has effect.

  • set number of content processes to 1 if it is currently set to a higher value (4)
    Options/Preferences -> General -> Performance
    remove checkmark: [ ] "Use recommended performance settings"
  • disable multi-process windows in Firefox

You can disable multi-process windows in Firefox by setting this pref to false on the about:config page.

  • browser.tabs.remote.autostart = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

You can try to adjust multi-process settings to see if this has effect. *set number of content processes to 1 if it is currently set to a higher value (4)<br>Options/Preferences -> General -> Performance<br>remove checkmark: [ ] "Use recommended performance settings" *disable multi-process windows in Firefox You can disable multi-process windows in Firefox by setting this pref to false on the <b>about:config</b> page. *browser.tabs.remote.autostart = false You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *http://kb.mozillazine.org/about:config *http://www.ghacks.net/2016/07/22/multi-process-firefox/