Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

in Google mouse clicks are not functioning. In google maps right click doesn't work. Since update 58.0.1(?)

  • 15 svar
  • 3 har dette problem
  • 47 visninger
  • Seneste svar af roelantsi

more options

Seems like since last update especially Google has problems with all the features: On normal Google page in the right upper corner there are 9 small blocks, normally you can left-click on them and you get a (javascript?) dropdown menu. Now not. Also in Google maps almost nothing works: only dragging and zooming is okay. Right-click does nothing (normally menu to see 'what is here' etc). Also no login is available in right upper corner. When left-click on menu (left upper) nothing happens.

I've tried Firefox in Safemode: nothing changes. I've tried updating Java script: no changes. I've tried ADWcleaner: found couple of minor things. Erased them. Nothing changes. I've looked at add-ons. Turned most of them of (all of them at one point) but they don't seem to be the problem. I've googled for answers and closed were some results from 2010 describing same. (Javascript seemed to be the problem back then). I've tried using Windows Internet Edge ($%^@&#): it works perfectly. Drop down menus and everything works fine. But I hate Edge, Chrome etc and want to use FireFox.

Hope someone knows what's going on.

Alle svar (15)

more options

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Type about:preferences<enter> in the address bar.

  • Cookies; Select Privacy. Under History, select

Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.

  • Cache; Select Advanced > Network.

[v57+] Select Privacy. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

more options

Thank you for your quick response! It didn't work out though..

I looked up all cookies from google and deleted them. Cleared the cache. Used latest version of CCleaner to clean everything else (except for the cookie exemptions which do not include any google cookies (in other words, I deleted them).

On the hardware acceleration I found that indeed, the box was ticked. So I unticked it and restarted, but didn't work.

Deeper into that it was recommended I check for the latest driver. Checked out (GeForce9600 etc had latest version installed). To be able to do that I had to install Java, which FireFox does no longer support. So I went to Internet Explorer, installed latest Java, scanned NVidia and see above (latest driver).

Again, in Explorer en %^&*-Edge maps.google works perfectly. I dare not download Chrome, but FireFox is getting increasingly worse since 2 years.

Any other thoughts or suggestions?

more options

https://support.mozilla.org/kb/Clear+Recent+History#w_how-do-i-remove-a-single-website-from-my-history

Remove History For One Site

Open the History Manager <Control><Shift> H. In the search bar, enter the name of the site. Right-click on one of the listings and select Forget About This Site. This should remove all information, including any passwords / settings.

more options

Thank you for the new suggestion! I tried it, restarted computer but it didn't work. I'm posting a screenshot to show the most obvious part of the problem:

Upper-left: FireFox Lower-left: Internet Explorer Right: Windows Edge.

The left-click on 'Menu' doesn't even work in FireFox.

Again, this could have nothing to do with FireFox (but rather something I did, or additionally needed software, or..?) but this seems to have started since the last update from FireFox to 58.

more options

I called for more help.

Start your Computer in safe mode with network support. Then start Firefox. Try Safe websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

more options

Starting Windows 10 up in Safe Mode with Network works! I directly went to FireFox and maps.google.com and it loaded alright. :)

That's a good step :)

more options

Now in normal mode maps.google loads better (see screenshot). The upper-left menu works. Right-click mouse works. But left-click mouse on upper-right menus don't work. Not on 9 blocks nor on account picture.

I don't understand what changed after this login on in Safe Mode, but something did and it works partially..

Getting there! Thank you for your support!

more options

In most computers, there are several types of Safe Mode. The primary ones used most are; *Safe Mode: Only programs that came with the computer are started. No other programs will be started unless the user starts them. *Safe Mode with Networking: Same as above but the network drivers (internet) will also be running. This is a way to test if one of the other programs on the computer is causing the issue.


As a test, disable your protection programs. Is the problem still there?

more options

I turned of all protection from Windows Defender: virus protection, firewalls, real time protection. Is this what you meant? Nothing changed as a result: still the buttons upper-right don't work, and the buttons left do work. As are streetview functions etc. Right-click on my account button/picture and open-in-new-tab directs me to the right page (sign in/change sign in). The same with the 'more Google products' button (normally dropdown and google icons) results in a Our Products Google page (see attachment). Note that the icons do not load on this page.

What is strange to me is that the left (google maps) menu started working again after I booted Windows in safe mode. So something changed for the better after that.

more options

Okay. I think it is one of the other programs causing the problem. You can restore your protection.

Look at the other programs on your system. Does anything look like a suspect?

Can you provide a list of what is running?

more options

See attachments. What strikes me is that even though I have one instance of FF open, it has 7 processes running. CFT is also unfamiliar with me. The last screenshot shows maps after I click on 'traffic'. So the process of loading seems to stop somewhere.

One other thing I am going to tr right now is to disable the Java update scheduler in Startup and restart. To see if this back ground program is causing some disturbance.

more options

I don't see anything. Maybe someone else will.

more options

roelantsi said

What strikes me is that even though I have one instance of FF open, it has 7 processes running.

More than one process is normal for the current Firefox. http://www.ghacks.net/2016/07/22/multi-process-firefox/

Multi-process Firefox is codenamed "e10s". https://wiki.mozilla.org/Firefox/multiprocess


Try to disable multi-process tabs in Firefox. You can disable multi-process tabs in Firefox by setting the related prefs to false on the about:config page.

browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

Type about:config<enter> in the address bar. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar.

more options

Okay, this one is new. I tried to update my google search preferences (not 10 results but 50 results), it let me do so. I could also Save it, but then when it automatically wants to return to the search page I get this message:

Apparently google detects I am sending stuff, which could be true because I just updated my search preferences.. But maybe it's something else..?

more options

the autostart.2 was 'aangepast' (adjusted manually I guess) to be true. I will alter both of them..