Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

The spell check doesn't work!

  • 5 svar
  • 7 har dette problem
  • 4 visninger
  • Seneste svar af gfunk

more options

The spell check does not work. I have been into settings, tried various forms of English, and I do not get the squiggly red line that advises me of a spelling error.

The spell check does not work. I have been into settings, tried various forms of English, and I do not get the squiggly red line that advises me of a spelling error.

Alle svar (5)

more options

Hi, make sure it is selected in Options > General (Language and Appearance).


Right click on a word to make sure it is enabled.


If you are outside the US you may need to add a dictionary - https://addons.mozilla.org/en-US/firefox/language-tools/ You should see it in the Add-ons Manager (Ctrl+Shift+A) > Dictionaries. Note: restart Firefox afterwards to enable it.


If it's still not working, try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu, click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem. Thank you!

more options

I have just wased 1/2 an hour of my life trying all that, and it still doesn't work!

more options

Your Video Card Drivers are out of date big time. 8-6-2015 Please update regularly for your AMD Radeon(TM) R5 Graphics https://support.amd.com/en-us/download

Suggest then since do not want to waste time. Uninstall Firefox and reinstall 56.0.2 from a Full Version Installer. (note your profile will be saved.) (note it could be the profile that is the problem which we can help you with) https://www.mozilla.org/firefox/all/

Note : Firefox 57 Quantum release date Nov 14th https://www.mozilla.org/en-US/firefox/quantum/ Note : Legacy Extensions will be disabled and or removed.

Please let us know if this solved your issue or if need further assistance.

more options

Do you have a dictionary installed and selected?

You can see which dictionary is selected if you right-click in a text area and open the Languages sub menu. At least one dictionary should be installed and have a check mark to indicate that it is selected.

  • open the "Add Dictionaries" link to install a dictionary if you do not have one.

The spelling checker is enabled if [X] "Check Spelling" in the right-click context menu has a checkmark.

You can enable or disable spell checking globally:

  • Options/Preferences -> General: Browsing: "Check my spelling as I type"

You can look here for dictionaries:

See also these prefs on the about:config page:

more options

I have the same problem, -en-gb dictionary extension added -check spelling is ticked -en-gb selected in languages -spelling enabled in about:config -TRIED RESTARTING WITH ADD-ONS DISABLED

windows 10 x64, firefox 56.xx FWIW I have MSoffice installed

no squigglies under miss-spelt words and no right click spelling options

Ændret af gfunk den