Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox doesn't remember window sizes or positions

  • 36 svar
  • 49 har dette problem
  • 15446 visninger
  • Seneste svar af raywjohnson

more options

I know there are a variety of solutions posted here to this problem (like deleting xulstore) but Firefox recently (v55?) stopped remembering my window sizes and positions on restore. I thought it was an add-on problem like Classic Theme Restorer or SessionManager or TabMixPlus but I tried with a brand new profile with no add-ons installed and it still is displaying the same broken behaviour: all restored windows are restored to the same stock size and position and new windows open with that same stock size also (even if they are opened from windows whose size I have changed).

Anyone know what is going on? Is this a recent regression?

Valgt løsning

Nope, none of this applies to me, and this is happening on a brand new profile.

However, I did the whole "Refresh Firefox..." thing and that seems to have worked so far. Had to resync everything and set a lot of stuff back up but so far *fingers crossed* it's working as expected.

Læs dette svar i sammenhæng 👍 0

Alle svar (16)

more options

Hi dorcom, as noted in Fred's post after yours, the most relevant file is named xulstore.json. However, other settings or extensions may influence Firefox's behavior. If removing the xulstore.json file makes no difference, you could try only restoring portions of your old profile, or experiment with disabling some of your extensions.

more options

I had similar problem and found a solution:

deleting xulstore.json did not fix, but

firefox -P create new profile start firefox with new profile -- normal sized window close firefox

copy xulstore.json from the new profile to the broken profile fixed it

more options

That was very good work. Well done. .

more options

Same issue here with 57b7. Tried all the above, only a fresh profile cures it. Also deleted Windows 10 window position cache to no avail. walers suggestion also did not work. Any other ideas?

more options

TwoXfour Please go to the top of any support.mozilla.org web page and use the Ask A Question link; https://support.mozilla.org/en-US/questions/new Select the product for what the problem is (Firefox or whatever).

Now select the category for the problem. At the bottom is Other.

Describe the problem in brief. Then press <enter>. The website will display any prior posts that might help you. If nothing on the list can help, at the bottom press the button; None Of These Solve My Problem.

Now enter all the relative information on the problem. At the bottom of this, you can Add Images.

Under this is Troubleshooting Information. Please press the Share Data button. This will let us look at your system details. No Personal Information Is Collected.

more options

Using Linux: MATE Desktop 1.14.1 -- Firefox 57.0 (64-bit)

I have multiple profiles and this issue specifically effects the "default" profile. However, the location (top/left -- x/y) effects all profiles. Firefox always opens centered. If I change the size in any profile (accept "default"), close and reopens centered. Even if I move out of center. If I maximize, that is saved are reopens maximized (for all profile accept "default").

The solution "refresh firefox" is not a solution. It does not solve the cause. If I wanted to restart, refresh, reboot every time there is a problem, i would run windoze. I will not try the "refresh" option. I do not want to spend time restoring everything afterwards. This should be fixable without nuking firefox.

Steps for testing "default" profile (and the state of xulstore.json for each step).

Initial {"chrome://browser/content/browser.xul":{"navigator-toolbox":{"iconsize":"small"},"main-window":{"screenX":"488","screenY":"16","width":"1000","height":"986","sizemode":"normal"},"sidebar-box":{"sidebarcommand":"","width":""},"sidebar-title":{"value":""}}}

Open firefox and maximize, then close: {"chrome://browser/content/browser.xul":{"navigator-toolbox":{"iconsize":"small"},"main-window":{"screenX":"488","screenY":"16","width":"1000","height":"986","sizemode":"maximized"},"sidebar-title":{"value":""}}}

Open firefox (fails to be maximized, manually resize), then close: {"chrome://browser/content/browser.xul":{"navigator-toolbox":{"iconsize":"small"},"main-window":{"screenX":"93","screenY":"6","width":"1785","height":"1012","sizemode":"normal"},"sidebar-box":{"sidebarcommand":"","width":""},"sidebar-title":{"value":""}}}

Open firefox (fails to be restored to manual size/location), then close: {"chrome://browser/content/browser.xul":{"navigator-toolbox":{"iconsize":"small"},"main-window":{"screenX":"488","screenY":"16","width":"1000","height":"986","sizemode":"normal"},"sidebar-title":{"value":""}}}

Always stays at these settings when opened : "screenX":"488","screenY":"16","width":"1000","height":"986","sizemode":"normal"

/usr/bin/firefox /usr/bin/firefox -P default /usr/bin/firefox -no-remote -P default

more options

Hi raywjohnson, could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement from one Safe Mode session to the next?

more options

I am happy to test!

I tried several times. One issue (left position) worked.

If I resize and move, then Restart with Add-ons Disabled, it returns the same (centered and size), then moves to the spot where I set it (left/right only).

Height, Top, and Max still not working.

more options

Note: If I maximize, the Restart with Add-ons Disabled, the window sticks to the top left corner. Size stays : "width":"1000","height":"1006"

more options

Screen shot of of my add-ons...

more options

Hi raywjohnson, I can't explain it. It definitely doesn't do that on Windows.

more options

It is a mystery. I tried creating a new profile, clean. But it has the same issue as all the non "default" profiles.

Oh well, on extra click to maximize every time I start Firefox. Done.

more options

Ok. One mystery discovered. My desktop was set to "center" new windows. That solved the left/right issue.

more options

cor-el said

Also make sure that you do not run Firefox in Private Browsing mode (never remember history).

I was wondering why? Does this mean that window size/position might also not be restored when doing things like clearing cache/cookies ?

(i'm also experiencing this issue, only in the "Default" profile. Deleting xulstore.json, Localstore.rdf, sessionstore doesn't fix it. Also copying xulstore.json from a working profile to the Default profile didn't fix it.)

Firefox 59.0b6, macOS 10.13.3

more options

By now I have a whole other problem with Firefox 57x Two thirds of our plug-ins don't work with the 57x version and nobody bothers to update their plug-ins so the whole thing has become so useless that I might just have to find another browser. For now we restored an older version, 56 to be able to work.

As for not memorizing the window size, you can save yourself the time of deleting files or creating new profiles. The problem is buried somewhere else.

I resolved that by reinstalling a backup version (I simply copied the contents of Firefox backup into the Mozilla Firefox folder and all worked fine. Then I did a reverse cross check by copying the (mentioned and recommended to be deleted) files of the version that does not remember window size into the backup version I have reinstalled.

Surprise, surprise! No effect. Everything worked fine. This lets me conclude that the not remembering window size bug has nothing to do with those files but with something else for which I don't have the time and patience to find out.

Ændret af dorcom den

more options

In the end, my only solution was to create a new profile and delete the "default" one. Then rename the new one to "Default" (that step not required), then set the new profile as default. I reconnected to my Mozilla account, so bookmarks and add-ons are restores, but all cookies and settings are lost (the reason I did not want to "reset" things).

Prior to doing that, I just continued to manually maximized Firefox. But, at some point (not sure if it was an update or something else), it stared working again. Remembering to be maximized when I first start Firefox.

However, soon after other issues started. Serious ones. My online accounting site stopped working (pages stuck in a refresh loop), Firefox closing unexpectedly (no error or report, just gone), Firefox freezing for a short time (15-20 seconds), Firefox loading my CPUs to 100%+ (slowing everything down) and other anomalies.

So I gave up and just created a new profile. Solved.

Seem to me some corruption in the files. But since the creators of Firefox do not seem to know how to verify and repair their own system, you are stuck with starting over every so often (you know the Microsoft way).

One more debacle with a reset. My dictionary was lost. So now I have to "add to dictionary" all the words I previously added (like: online).

  1. 1
  2. 2