Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox crashes - EXCEPTION_ACCESS_VIOLATION_EXEC

  • 15 svar
  • 1 har dette problem
  • 63 visninger
  • Seneste svar af FredMcD

more options

Firefox Support,

I need your help fixing the constant crash of my Firefox installation. I have spent DAYS following all the troubleshooting guides that I have been able to find but the issue continues.

Below you will find 3 sections. 1) Crash Report IDs 2) Context to how problem surfaced 3) Troubleshooting thus far

1) Crash Report IDs:

The Crash Reason stated is ALWAYS the same, namely: EXCEPTION_ACCESS_VIOLATION_EXEC The Crash Address is also always the same, namely: 0x7ff92576fa77

bp-cb719f3a-d2c8-4ede-94c6-378dc1170802 bp-1ff8ec54-1cc7-44e7-9f89-1012c1170802 bp-fd4137f2-50db-427a-8abb-6acaa1170802 bp-39e6c52f-d8cc-44e1-9814-91e531170802 bp-74abeea1-41e2-409e-82b5-e8ceb1170802

2) Context of how problem surfaced:

- In late June Roboform informed me that a new version was available (8.3.7). -I upgraded as I normally do, but to my surprise the upper toolbar of Roboform was missing. - Upon further investigation I learned that the upper toolbar had been removed beginning with Roboform version 8.3.7 because Firefox had announced that they were only supporting WebExtensions API beginning with Firefox 57. - Since I hated having Roboform as a 'button' or as a lower toolbar I decided to stop using Firefox and try to live with Internet Explorer. - Needless to say I didn't like that solution as Internet Explorer has been practically abandoned by Microsoft as is not very powerful. So I explored other options and I was told that if I installed Roboform 8.3.5.5 (the last version to support the upper toolbar) it would work OK up to Firefox version 56. - I downgraded to Roboform 8.3.5.5 (after having used version 8.3.7) and the crashes began. - I downgraded Firefox to version 52.2.1 ESR and the crashes continued. - I began reading and following troubleshooting instructions on the Mozilla support forum but nothing solved the issue. - I tried look for the crash logs but despite Firefox crashing there was no logs - I upgraded to Firefox 54.0.1 64 bits and while that didn't solve the issue, at least the crash logs returned (those are the ones I am enclosing).

3) Troubleshooting thus far:

- I have removed Firefox multiple times and tried different versions - I have removed Roboform multiple times and tried different versions - I have done the 'Refresh Firefox' multiple times with no success. - I have followed 'clean install' procedures for both Firefox and Roboform that included erasing remaining files in program files and user directories and even flushing remaining entries from the registry - I have upgraded the BIOS of my computer

None of the above has worked. I suspect that it may have to do with Roboform because the modules area of all crash reports are highlighting the roboborm modules in red. However since there is no explanation of what the red highlighting means in the crash reports I am not sure if my interpretation (that they are the cause of the problem) is correct.

Firefox IS definitely compatible with Roboform as it worked on my system for years. I suspect that after having installed to the new version of Roboform and Firefox something has been left behind after downgrading that is causing the reinstall not to work perfectly and to crash.

I don't want to move to the new version of Roboform because I hate not having the upper toolbar, so I need your help to be able to go back to any Firefox and Roboform combination that won't cause the crash.

Vedhæftede skærmbilleder

Alle svar (15)

more options

From the crash report, it looks like RoboForm is causing the problem. Remove it from your system. Is the problem still there?

more options

Modules that are flagged and show as red simply means that the crash server doesn't have symbols of this module, so you only see a crash address and not a link to a function in the source code like you see with modules that aren't flagged.


I see this DLL in the crashing thread: onecorecommonproxystub.dll , but I don't know what it is used for.

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.


When multi-process windows in Firefox is enabled then Firefox will use more memory and may be less responsive.

You can try this to see if it has effect:

  • set dom.ipc.processCount to 1 if it is currently set to a higher value (4)
  • disable multi-process windows in Firefox

You can disable multi-process windows in Firefox by setting these prefs to false on the about:config page.

  • browser.tabs.remote.autostart = false
  • browser.tabs.remote.autostart.2 = false

You can open the about:config page: via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

more options
more options

FredMcD said

From the crash report, it looks like RoboForm is causing the problem. Remove it from your system. Is the problem still there?

I am going to try to do this, but to be quite honest it is easier said than done. Roboform acts as my bookmark and password repository and if I remove it I have no easy way to go to the websites I visit, reducing my use of the browser and hence causing less crashes as a result of no use.

Sure I can manually type every single webpage address that i want to go to and manually enter usernames and passwords, but clearly that is a very painful process and it will take a lot of time and patience to detect if it crashes or not, as I won't be navigating as much and often as I normally do.

As I said before the crashes are random, and they don't happen every time I visit certain websites. So it is very difficult to replicate unless I am actively navigating the internet as I normally do, and to replicate such activity without a way to go to all the websites that I normally go is a bit difficult. However I will definitely try, but it won't be an exact comparison of activity.

Ændret af witschey den

more options

cor-el said

I see this DLL in the crashing thread: onecorecommonproxystub.dll , but I don't know what it is used for.

I did a quick search on that DLL and it is definitely a Microsoft file that is part of Windows 10, so it is unlikely that I can do anything about it.

Based on many days of experiencing crashes I think that I have spotted a relationship in the patterns. They seem to happen more often when I have Microsoft Outlook 2016 open at the same time that I am navigating to an HTTPS website using Firefox.

The problem with verifying my observation is that the crashes are a bit random in that if I visit an https website where firefox has crashed before, it does not cause the crash every time I visit. It only happens once in a while.

Yesterday I experienced about 6-7 crashes within minutes of each other, and then the system was 'crashless' for at least 4-5 hours before it started again.

For the time being I am trying the suggestion of removing Roboform to see if that returns stability to Firefox. Ofcourse that is not a solution for me as I have no use for Firefox if I can't use Roboform. But at least that will perhaps isolate the issue.

Once I have established that I can proceed with trying some of the other suggestions.

Thanks for all the suggestions thus far. I will post back after a day or two of navigating without Roboform.

more options

Remove Roboform as a test. Is the problem still there?

You can always reinstall from its web site later.

more options

FredMcD said

Remove Roboform as a test. Is the problem still there? You can always reinstall from its web site later.

I removed Roboform 8.3.5.5 (the last version with a toolbar for Firefox) about 6 hours ago and there has been no crashes. Obviously that doesn't solve my problem as I see no value in Firefox if it doesn't support Roboform.

I have installed the new version of Roboform (8.3.9 which has no toolbar) to test if it works without crashes. Needless to say that is NO workable solution as I want the upper toolbar. But at least this way we will begin to isolate the issue.

more options

Have you contacted Roboform support?

Type about:customizing<enter> in the address bar. Look for Show / Hide Toolbars at the bottom left.

There is also a Restore Defaults button at the bottom middle.

Note: about:customizing is no longer present in Firefox 47+ releases.

  • Press Alt or F10 to bring up the toolbar.
    Then View > Toolbars > Customize.
  • Right-click on a blank spot in the toolbar and select Customize.
more options

FredMcD said

Have you contacted Roboform support?

Yes, I have contacted Roboform and they have been 100% quiet about this particular issue. I think they are provably as puzzled as I am that installing an old version of Roboform caused the entire Firefox to crash, when that exact same combination of Firefox and Roboform worked perfectly before.

As to the rest of your comments I don't understand what they have to do with the issue that I am facing. I can see the toolbar without any issues what so ever. The problem is that Firefox crashes.

Ændret af witschey den

more options

FredMcD said

Have you contacted Roboform support?

Roboform finally came back to me suggesting that I do what I had already done (refresh roboform and reinstall plugins). Needless to say, I had already done that and it hasn't worked.

Then they suggested that if the firefox reset failed I should install the new version of Roboform despite not liking it.

Well, I have done that and ironically it also crashed...ON THEIR SUPPORT WEBSITE. This time it wasn't Firefox crashing but their spanking new 'so called upgrade'. How is that for an unwanted and unappreciated customer 'upgrade' to both Firefox and Roboform.

To be clear the enclosed image is the new crash I am experiencing with Roboform 8.3.9 (the latest version available as of the writing of this note), and Firefox 54.0.1 (64 Bit) which is also the latest version available.

Ændret af witschey den

more options

Does if have any effect whether you use a 32 bit Firefox version or the 64-bit Firefox version?

more options

I have found a combination of old Roboform and old Firefox files that does not cause the Firefox crash. Its Roboform 8.2.9.5 and Firefox 54.0.1 (64 bit).

They worked flawlessly for the 3-4 hours immediately after I installed them yesterday, unfortunately this morning when I turned on my PC tthe Roboform toolbar started acting strangely.

It did NOT cause Firefox to crash as was the case with the new version of Firefox (54.0.1) and the new version of Roboform (and also with the new version of Firefox (54.0.1) with Roboform 8.3.5.5)

With this particular combination the problem that surfaced this morning is that the Roboform toolbar logged off constantly (sometimes within a minute or less after log-in). I also noticed that the System toolbar showed multiple instances of the Roboform Taskbar Icon, but that if I hovered my mouse over them they would disappear.

I removed Roboform from my system (yes again!) and reinstalled the very same version. It is again working OK. However, I am not sure if the same log-in/log-off issue will resurface perhaps tomorrow after shutting down my system. I will have to wait and see.

more options

I have FINALLY solved my problem with Roboform. I had to reinstall my entire computer from scratch (erased entire hard drive) for it to work.

I now have Roboform version 8.3.5.5 (latest version with an upper toolbar) running with Firefox 55.0.3 in a perfectly stable way. I don't plan to upgrade my Firefox or my Roboform until an upper toolbar that meets customer needs is made available again (be it through the creativity of Roboform of through Firefox realizing that they lost all their customer base with the crappy transformation they are pushing upon us).

more options

That was very good work. Well done. Please flag your last post as Solved Problem so others will know.