Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

XP Firefox will not open after being launched

  • 37 svar
  • 7 har dette problem
  • 1600 visninger
  • Seneste svar af ahlquinn

more options

I was using Firefox 52.0.2esr and it was working fine. I got a Microsoft Update and after that it would not open after being launched. I am using Chrome browser and have troubleshooted renaming profiles which did not work. I have uninstalled, rebooted, and reinstalled ver 49.0.1 and I still have the problem. I have run my Virus, Malware, and Spyware and it is clean. Firefox shows in Task Manager as running but the window never opens. I have killed the process subsequently to doing everything I have said above. Please help. I do not like using Chrome but it's the only other internet browser that is working on my XP PC.

Valgt løsning

FredMcD said


OMG....FredMcD, what a simple ANSWER/FIX this was to down-date Firefox to this lower 32bit version that truly works with XP SP3. However as soon as I got my open window I was prompted to update to Firefox 52.2.1esr, but I will not be doing that. The notes say this version is intended for groups who deploy and maintain desktop environments in large organizations. I am 1 desktop gateway with wifi laptop and cellphones.

There is a big gap in version numbers from 45.X.X to 52.2.1 but I couldn't find any, so will stick with 45.9.0esr for now.


Evidently all the other stuff we tried was superfluous. I wonder if any of it actually hurt (made less secure) my PC or my AVG security, Malwarebytes, or Spyware at all. Hope NOT !!

Læs dette svar i sammenhæng 👍 0

Alle svar (20)

more options

https://support.mozilla.org/en-US/kb/changes-toolbars-and-window-sizes-are-not-saved You may have corrupt xulstore.json or Localstore.rdf file.

Close Firefox. Open your file browser to this hidden location:

  • Mac: *~/Library/Application Support/Firefox/Profiles
  • Linux: *~/.mozilla/firefox/Profiles
  • Windows: %AppData%\Mozilla\Firefox\Profiles
  • *C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles

Search for the above files. Then rename or delete them. Restart Firefox.

more options

Thanks FredMcD, but in my question I already said I tried that and it did not work, infact I got a message saying "there was no profile present" when trying to launch Firefox so I renamed them back. I am looking for other answers than what I already found on this site for fixing this problem. And I have used Wise Registry Cleaner too which did not solve the problem, even though it corrected 1142 various problems. And prior to all this, I ended up uninstalling Microsoft Security Essentials because upon booting I got this message "0x80070002, an error occurred during program initialization. If problem continues contact your systems administrator" which I do not have one. And when trying to reinstall MSEssentials I got "0x8004FF52" so I gave up completely with MSEssentials.

Ændret af ahlquinn den

more options

I think with all this you have done you should check the integrity of your windows files before we try and help more. So please do these 2. OOPs....your on XP Do not think Dism will work for you.

Repair System Registry and Files

Run the Windows Deployment Image Servicing and Management (DISM) and System File Checker (SFC) tools as Administrator. The DISM and SFC tools scan the integrity of the Windows image and all protected system files replaces corrupted, damaged and incorrect versions.

To run the DISM command use the Windows key + X keyboard shortcut to open the Power User menu, then select Command Prompt (Admin). Type "DISM /Online /Cleanup-Image /RestoreHealth" (without quotes or copy/paste) and press Enter. While running DISM you may notice the process will appear to pause at 20%. After a few minutes the operation will continue.

To run the SFC command use the Windows key + X keyboard shortcut to open the Power User menu and select Command Prompt (Admin). Type "SFC /SCANNOW" (without quotes or copy/paste) and press Enter. For more information on using SFC, please refer to the Microsoft KB: Use the System File Checker tool to repair missing or corrupted system files

This is the kitchen sink of everything we can help with from our docs. Does not mean can not help more. Check this out. Keep Document URLs you have tried so you can post them back here if need to. This so we will not repeat stuff you have done. https://support.mozilla.org/en-US/kb/firefox-support-troubleshooting-guide

Please let us know if this solved your issue or if need further assistance.

Ændret af Shadow110 den

more options

Thanks PKSHADOW for trying to help me further. I do not have an administrator login on my XP machine only my personal login. When I try to run DISM it says: "DISM is not recognized as an internal or external command, operable program or batch file". What is an option for this command? I am in the process of running the SFC command. Thanks again. P.S. SFC ran with no messages - got C prompt back. I assume Windows files are original and unchanged.

Ændret af ahlquinn den

more options

SFC should have given you a message good or bad. As well as showing test results as it goes.

Note: SFC must be run using; Run As Administrator.

Ændret af FredMcD den

more options

Thanks FredMcD. OK, I figured out how to logon as an Administrator so am re-running SFC. But DISM still gave me the error: "DISM is not recognized as an internal or external command, operable program or batch file."

OK....ran SFC as Administrator (I think) and only got a return C prompt, no list or log or GOOD or BAD. I also modified the regedit to give me Admin on the Welcome screen but after rebooting Admin did not show up. When I initiated this PC I don't think I set an Admin cause I am the only one that uses this PC. But when I went to Control Panel I see Administrator and Guest have been added and also Owner (ME) is identified as Account Type = Administrator.

Ændret af ahlquinn den

more options
more options

FredMcD said

Note: SFC must be run using; Run As Administrator.

Right click on SFC.exe and select Run As Administrator.

more options

The link to DISM was not helpful as it does NOT apply to XP, only 7,8,8.1,Server2008 R2, Server2012, Server 2012 R2. So is it still OK to get it for XP ?

On the suggestion for SFC.exe right-clicking - only Owner is available to Runas..., no Administrator, and another option is APNS certificate with a red X on top of the icon. What should I do?

more options

In that case, log into the computer as the administrator. It does not matter what user account runs the command.

more options

What security software do you have?

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

more options

cor-el, I have AVG, Malwarebytes, SuperAntiSpyware and SpywareBlaster. I use to have Microsoft Security Essentials prior to this problem but I uninstalled it (not the normal way, but deleted it as there was no uninstall available) and I was getting these errors: 0x80070002 and 0x8004FF52 and MSE would never launch either. That is why I uninstalled it. Also uninstalled Mozilla Firefox 52.0.2 and installed a prior version 49.0.1 but still have the problem Firefox will not launch even though it shows in Task Manager as using memory.

FredMcD, I am running in Safe Mode with Networking as Admin logon and when I type sfc/scannow I get the message "Windows File Protection could not initiate a scan of protected system files" and this code error: 0x000006ba (The RPC server is unavailable)

more options
more options

ahlquinn said

FredMcD, I am running in Safe Mode with Networking as Admin logon and when I type sfc/scannow I get the message . . . . .

You should get help on this from; https://support.microsoft.com


more options

co-rel your suggestion was much too confusing as I am not the server nor do I have access to the RPC and don't understand any of it.

FredMcD, I managed to launch Firefox in Admin SafeMode but no pages load and message is "the connection has timed out". Am using Microsoft Answers, but there is a lot there to sort through. AGAIN, also tried running sfc/scannow in SafeMode Admin and got same message: "Windows File Protection could not initiate a scan of protected system files" error code 0x000006ba (the RPC server is unavailable). I don't understand what RPC server has to do with what I can do on my PC.

Additionally, Firewall was off again. Why is my Firewall periodically going from On to Off after I manually turn it On? I was able to turn my Firewall ON again but the pages in Firefox still "connection has timed out".

I am sorry I am not understanding much of the tens of items on the Microsoft Answers site based on my problem. Maybe I should just call them and let them have remote access to my PC to fix whatever is wrong. I really appreciate the help you tried to give me. Everything is just too complicated and this is a simple old XP operating system.

more options

When a computer is in Safe Mode, only system files are loaded.

Can you post the links to your question to Microsoft? We might be able to translate it for you.

ahlquinn said

Maybe I should just call them and let them have remote access to my PC to fix whatever is wrong. I really appreciate the help you tried to give me. Everything is just too complicated and this is a simple old XP operating system.

One last thing, make sure you are using Microsoft links. There are others that claim to be help sites, but some of them are spammers.

Or you can check with your local repair center.

more options

I do have antivirus and security with Firewall protection so that is why it is turning off in the control panel because of the conflict when I turn it on. I will look on Microsoft Support for the Firefox & IE opening problem and if nothing there I will ask them for help. I know to be on a legitimate site and not ask for help from bogus places. Thanks again FredMcD for trying to help me.

more options

{Please ignore if I am not helping, I just briefly went over this thread}

That error your got when running rpc is because you have Windows File Protection disabled in the registry. You may need to do the scan in normal mode after rebooting the computer. Did you get anywhere with bleepingcomputer.com?

more options


First, I’m sorry to see MS sent you back here in your posted thread. We could assume it’s their update causing Firefox as well as MSE (correct?) to break, not Firefox’s update. Ending support for an OS is not a reason to do leave you without a little effort to help find an explanation. You mentioned it breaks MSE, so I’d expect to see that addressed at least.

For sfc.exe: you could also start a command prompt as Administrator in your user account from the start menu > Accessories, then right-click > Run as, choose Administrator and enter your current login’s password, although logging in to Windows as Administrator already did the trick. I prefer that method personally as it will allow you to do a bit more in that dialog only and from the own account, and faster.

As for MSE not working: there are some sources on the net to fix them, as you may have seen. That may not be the biggest concern now but I personally prefer doing that beforehand. Such errors may not necessarily indicate an issue with the OS, but it could point to a low-level issue with networking that affects both MSE and Firefox, and perhaps other software.

The 0x000006bc error for SFC code about protected files may be solved by following the steps here.

How to resolve the 0x8004ff52 MSE error code is described here.

And here is a description for 0x800070002 and pointing to more info for uninstalling, but there are more and they may vary.

It’s clear you can open FF as Administrator and in Windows Safe Mode only, and that there still seems to be a networking issue. Personally I would remove any piece of security software first (yes, even on XP, but only when behind a router), reboot (!) and retry, and if that doesn’t work, reset the TCP/IP stack as explained here.

If that works for Administrator, try fixing the user account. As you wrote renaming profiles didn’t work out but you did reach the point of Firefox telling there was no profile (perfect!), I would again rename or rather just move the entire Firefox profiles folder to reach that point again, and then start the Profile Manager to create a new profile and launch that. Instructions for it can be found here too, though they only mention renaming the profiles.ini file which would theoretically be enough, but moving the entire profiles folder is better.

Example: rename C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles\ to C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\OldProfiles\ or move that \Profiles folder elsewhere. When at it, you do the same for C:\Users\<user>\AppData\Local\Mozilla\Firefox\Profiles\

Then try starting Firefox. If that profile still fails to load, try starting it in Safe Mode from the command prompt in the Program Files\Mozilla\Firefox folder using firefox.exe -safe-mode. If that works, some additional fixing may be required for the user account.

Hope this helps a bit, keep us posted.

more options

guigs. I did go to bleepingcomputer.com and there wasn't any help topics for my problem. I'm still working on it. Nobody from Microsoft.Support has posted a response so I'm still trying on my own with what I know.

  1. 1
  2. 2