X
Tryk her for at gå til webstedets mobilversion.

Supportforum

Firefox ESR 52.1.0 on Linux 64bit: Still connects to cloudfront.net (keep alive) although browser.selfsupport.url value is changed to a blank string

Skrevet

Firefox ESR 52.1.0 on Linux 64bit: Still connects to cloudfront.net (keep alive) although browser.selfsupport.url value is changed to a blank string, using about:config.

Firefox ESR 52.1.0 on Linux 64bit: Still connects to cloudfront.net (keep alive) although browser.selfsupport.url value is changed to a blank string, using about:config.

Valgt løsning

Solution, two actions needed:

First change "network.tcp.keepalive.enabled" to false. This disabled the keep-alives to cloudfront.net.

After disabling this, I also noticed traffic to cloudfront.net once more. Every now and then a GET [string].cloudfront.net/success.txt. Apparently this traffic was also happening before, just couldn't see the difference, thought it was part of keep-alives. So,

Secondly change "network.captive-portal-service.enabled" to false.

As I can see now, opening Firefox with a blank page produces no traffic. I believe that that should be the default behaviour for a decent browser. Thanx Mozilla for the great browser and the ability to customize everything on it, but please keep it simple and low overhead by default.

Læs dette svar i sammenhæng 0

Yderligere systemdetaljer

Program

  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0

Yderligere information

Luk

Spørgsmålsstiller

Update: Using wireshark I found that "browser.selfsupport.url" is indeed working. If leaving the default setting I can see connections to "shield-normandy-elb-prod-2099053585.us-west-2.elb.amazonaws.com". Leaving "browser.selfsupport.url" empty vanishes connections to amazonws.com.

So the question should be rephrased; how can I disable this keep-alive to [somestring].cloudfront.net?

All my tests are being done with disabled add-ons or executing firefox in safe mode.

Update: Using wireshark I found that "browser.selfsupport.url" is indeed working. If leaving the default setting I can see connections to "shield-normandy-elb-prod-2099053585.us-west-2.elb.amazonaws.com". Leaving "browser.selfsupport.url" empty vanishes connections to amazonws.com. So the question should be rephrased; how can I disable this keep-alive to [somestring].cloudfront.net? All my tests are being done with disabled add-ons or executing firefox in safe mode.

Valgt løsning

Solution, two actions needed:

First change "network.tcp.keepalive.enabled" to false. This disabled the keep-alives to cloudfront.net.

After disabling this, I also noticed traffic to cloudfront.net once more. Every now and then a GET [string].cloudfront.net/success.txt. Apparently this traffic was also happening before, just couldn't see the difference, thought it was part of keep-alives. So,

Secondly change "network.captive-portal-service.enabled" to false.

As I can see now, opening Firefox with a blank page produces no traffic. I believe that that should be the default behaviour for a decent browser. Thanx Mozilla for the great browser and the ability to customize everything on it, but please keep it simple and low overhead by default.

Solution, two actions needed: First change "network.tcp.keepalive.enabled" to false. This disabled the keep-alives to cloudfront.net. After disabling this, I also noticed traffic to cloudfront.net once more. Every now and then a GET [string].cloudfront.net/success.txt. Apparently this traffic was also happening before, just couldn't see the difference, thought it was part of keep-alives. So, Secondly change "network.captive-portal-service.enabled" to false. As I can see now, opening Firefox with a blank page produces no traffic. I believe that that should be the default behaviour for a decent browser. Thanx Mozilla for the great browser and the ability to customize everything on it, but please keep it simple and low overhead by default.