Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

On startup FF 50.1 opens multiple windows.

  • 3 svar
  • 2 har dette problem
  • 675 visninger
  • Seneste svar af weybrew

more options

When I first open FF 50.1, I get multiple windows, usually 3. Two of them are trash ads promoting video games. This is new since v50. What is happening and can I fix it?

Valgt løsning

You can check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure nothing is appended after the path to the Firefox program.


You can check for problems with the sessionstore.js file in the profile folder that stores session data. When sessionstore.js is deleted you lose pinned tabs and open tabs and you will have to recreate them, so if necessary make a note or bookmark them.

You can use this button to go to the current Firefox profile folder:

Læs dette svar i sammenhæng 👍 2

Alle svar (3)

more options

Hi weybrew, if this happens every time you launch a new window, too, for example using Ctrl+n, please check your home page setting to make sure extra tabs weren't added: How to set the home page.

If this only happens when you use your desktop shortcut or pinned taskbar icon, it might be hijacked. I'll describe how to check that in a moment.

Considering your very long list of extensions, you might also check those to see whether any might be behind this new behavior.

Investigate Your Shortcut

The Firefox icon can be set up to launch specific pages at startup (or more specifically, when you use the icon). To check whether that is set:

First, open the shortcut as follows:

  • Desktop shortcut: right-click the icon, choose Properties
  • Pinned taskbar icon: right-click the icon, right-click Mozilla Firefox, choose Properties

Windows normally will select the Shortcut tab. If not, go ahead and click the Shortcut tab.

You'll see the Target highlighted. On 64-bit Windows, that usually is no more and no less than the following:

"C:\Program Files (x86)\Mozilla Firefox\firefox.exe"

If anything follows after that, try clearing it out.

After OK'ing the Properties dialog, you can test right away to confirm that Firefox now launches only your home page. Either:

  • double-click desktop shortcut
  • right-click pinned taskbar icon, click Mozilla Firefox

Success?

Investigate Extensions

You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then cast a critical eye over the list on the right side. All extensions are optional. If in doubt, disable.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Any improvement?

more options

Valgt løsning

You can check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure nothing is appended after the path to the Firefox program.


You can check for problems with the sessionstore.js file in the profile folder that stores session data. When sessionstore.js is deleted you lose pinned tabs and open tabs and you will have to recreate them, so if necessary make a note or bookmark them.

You can use this button to go to the current Firefox profile folder:

more options

Thanks for your reply, cor-el. For some reason today's startup was uneventful... maybe FF just had a bad day. i'll keep your notes on hand for any occurrence.