Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Spinny circle when changing tabs

more options

Firefox has updated again and true to form it has got worse :-(

Now whenever I switch between tabs (all of which have already loaded) I get a white tab with a spinny circle in the middle for a few seconds before the page appears. This did not used to happen, it used to switch instantly and only happend after the most recent update. Is there a setting I can change to turn this off?

Whilst I'm on a similar subject a recent change changed the address bar "awesomebar" so that when I start typing an address I got "View" or "Search" as the first entry on the list rather than the auto-complete entries. This is useless to me and I can't see the benefit. So I searched and there was a setting to turn it off. So I turned it off. This too had stopped working and I am back to getting these useless "View" and "Search" options. How can I turn this off again as well? The setting I found before (unifiedcomplete) is still turned off, but it seems not to work any more?

Firefox has updated again and true to form it has got worse :-( Now whenever I switch between tabs (all of which have already loaded) I get a white tab with a spinny circle in the middle for a few seconds before the page appears. This did not used to happen, it used to switch instantly and only happend after the most recent update. Is there a setting I can change to turn this off? Whilst I'm on a similar subject a recent change changed the address bar "awesomebar" so that when I start typing an address I got "View" or "Search" as the first entry on the list rather than the auto-complete entries. This is useless to me and I can't see the benefit. So I searched and there was a setting to turn it off. So I turned it off. This too had stopped working and I am back to getting these useless "View" and "Search" options. How can I turn this off again as well? The setting I found before (unifiedcomplete) is still turned off, but it seems not to work any more?

Alle svar (5)

more options

Security Issue: Update your Flash Player Note: Windows users should download the active_x for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the active_x.

Flash Player Version: 23.0.0. 205 Flash Player (Linux) Version 11.2. 202.643

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download.

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download.


See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

more options

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?

more options

One of the headline changes in Firefox 48-49 is e10s, which separates the browser interface process from the page content process. The performance impact of this can vary a lot between systems, and the developers are aware of some users having spinners and have been seeking input on the problem. Here's the thread on that over on Reddit:

https://www.reddit.com/r/firefox/comments/51t9bi/please_help_me_destroy_the_tab_switch_spinner_on/

Thank you for your input. And then, to disable e10s for now:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste autos and pause while the list is filtered

(3) Double-click the browser.tabs.remote.autostart.2 preference to switch the value from true to false

Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart

At your next Firefox startup, it should run in the traditional way.

more options

jscher2000 thank you this has fixed the problem for me, Firefox is now performing as expected when I switch the tabs, no more spinning circles.

Will this setting keep working though or will it "mysteriously" stop working after a few updates (as with the setting to tun off the "View/Search" options on the address bar)?

more options

The goal is to get e10s working smoothly for everyone ASAP and get rid of opt-outs, but it really depends on testing how soon that happens.