Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox won't close to uninstall and reinstall

  • 1 svar
  • 1 har dette problem
  • 4 visninger
  • Seneste svar af jscher2000

more options

I get very frequent messages saying the "long running script has stopped.....". I have to use the task manager and force the browser to close. I searched and have tried all of the suggestions listed by Firefox, up to reinstalling the browser. I am unable to uninstall it. When I try, I get a box saying that Firefox needs to close. Do I want to force it to close? It is always closed when I do this but I get this message anyway. Then it says it wouldn't close and asks if I want to try it again. No matter how many times I try I get a message saying it won't close. I have this same problem when I run my AVG program. It says it has found 62 problems but I can't fix them because Firefox won't close. Any suggestions would be appreciated.

Alle svar (1)

more options

If all else fails, shut down and restart Windows. Firefox should not be running at startup.

When you get the unresponsive script warning, what addresses are usually listed? For example:

  • addresses starting with the name of the site usually are features/functions of the page
  • addresses from other sites often (but not always) are advertising networks - using an ad blocking extension can help address issues with slow or dysfunctional ad network scripts
  • addresses starting with chrome:// usually are part of Firefox or of an extension you installed - the Skype extension sometimes causes this problem, for example

We have a general support article addressing potential solutions to this issue: Warning Unresponsive script - What it means and how to fix it. It sounds like you saw that one.

Another common cause of unresponsive script errors on Windows 7 is the protected mode feature of the Flash player plugin. That feature has security benefits, but seems to have serious compatibility issues on some systems. You can disable it using the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. On the right side, find "Shockwave Flash" and click the More link. Then uncheck the box for "Enable Adobe Flash protected mode" and try that for a day to see whether it helps.