X
Tryk her for at gå til webstedets mobilversion.

Supportforum

Denne tråd blev lukket og arkiveret. Stil et nyt spørgsmål, hvis du har brug for hjælp.

Where is "Don't open tabs until selected" in version 47.0b7?

Skrevet

I had selected "Don't open tabs until selected" but all of a sudden they are all opening on startup. The "Don't open tabs until selected" option is not there anymore when I go to Options. What can I do? This is urgent because I have multiple tabs open and they're all going strong at the same time and some of them are YouTube videos!

I had selected "Don't open tabs until selected" but all of a sudden they are all opening on startup. The "Don't open tabs until selected" option is not there anymore when I go to Options. What can I do? This is urgent because I have multiple tabs open and they're all going strong at the same time and some of them are YouTube videos!

Yderligere systemdetaljer

Installerede plugins

  • Shockwave Flash 21.0 r0
  • 5.1.41212.0

Program

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:47.0) Gecko/20100101 Firefox/47.0

Yderligere information

Luk
FredMcD
  • Top 10 Contributor
4229 løsninger 59016 svar

Type about:preferences#general<enter> in the address bar. Look under Tabs.

Type '''about:preferences#general'''<enter> in the address bar. Look under Tabs.

Spørgsmålsstiller

That gives me the same thing as going to Tools\Options and it is still not there.

That gives me the same thing as going to Tools\Options and it is still not there.
FredMcD
  • Top 10 Contributor
4229 løsninger 59016 svar

I've called the big guys to help you. Good luck.

I've called the big guys to help you. Good luck.

Spørgsmålsstiller

Thanks so much.

Thanks so much.
philipp
  • Top 25 Contributor
  • Moderator
5291 løsninger 23378 svar

Nyttigt svar

hi, the checkbox is hidden in firefox 47 since once disabled it causes negative effects with the new multi-process architecture that is introduced in firefox (bug 1257554). however though hidden, "don't open tabs until selected" is the default behaviour still...

hi, the checkbox is hidden in firefox 47 since once disabled it causes negative effects with the new multi-process architecture that is introduced in firefox (bug 1257554). however though hidden, "don't open tabs until selected" is the default behaviour still...

Spørgsmålsstiller

You mean the default is "Don't open till selected?" If that's so, then mine is NOT working. Is there some way I can check on this? Thanks.

You mean the default is "Don't open till selected?" If that's so, then mine is NOT working. Is there some way I can check on this? Thanks.
philipp
  • Top 25 Contributor
  • Moderator
5291 løsninger 23378 svar

Nyttigt svar

you can enter about:config into the firefox address bar (confirm the info message in case it shows up), search for the preference named browser.sessionstore.restore_on_demand and confirm that it is set to true.

you can enter '''about:config''' into the firefox address bar (confirm the info message in case it shows up), search for the preference named '''browser.sessionstore.restore_on_demand ''' and confirm that it is set to '''true'''.

Spørgsmålsstiller

That is set to True, as is

services.sync.prefs.sync.browser.sessionstore.restore_on_demand;true

but I don't understand what the Session Restore has to do with Don't Open Until Selected.

That is set to True, as is services.sync.prefs.sync.browser.sessionstore.restore_on_demand;true but I don't understand what the Session Restore has to do with Don't Open Until Selected.
FredMcD
  • Top 10 Contributor
4229 løsninger 59016 svar

Load Tab on select {web link} Stops background tabs from loading until you select them.

'''[https://addons.mozilla.org/en-US/firefox/addon/load-tab-on-select/ Load Tab on select]''' {web link} Stops background tabs from loading until you select them.
cor-el
  • Top 10 Contributor
  • Moderator
17421 løsninger 157408 svar

Can you attach a screenshot of the Options/Preferences page?

  • use a compressed image type like PNG or JPG to save the screenshot
  • make sure that you do not exceed the maximum size of 1 MB

Does it help if you disable multi-process tabs?

Can you attach a screenshot of the Options/Preferences page? *https://en.wikipedia.org/wiki/Screenshot *https://support.mozilla.org/kb/how-do-i-create-screenshot-my-problem *use a compressed image type like PNG or JPG to save the screenshot *make sure that you do not exceed the maximum size of 1 MB Does it help if you disable multi-process tabs?

Spørgsmålsstiller

The screenshot is attached. I can't find anything on multi-process tabs and am not familiar with the term.

The screenshot is attached. I can't find anything on multi-process tabs and am not familiar with the term.
FredMcD
  • Top 10 Contributor
4229 løsninger 59016 svar

You have Tab Mix Plus. Did you check its options?

You have Tab Mix Plus. Did you check its options?

Spørgsmålsstiller

I've checked its options multiple times and can find nothing to do with this area. I did download the add-on you referenced above, so I'll see what that does.

I've checked its options multiple times and can find nothing to do with this area. I did download the add-on you referenced above, so I'll see what that does.

Spørgsmålsstiller

Even though the browser.tabs.loadInBackground is set to True, the add-on is not stopping the loading of all of the tabs; it might as well not be there. I just checked the Tab Mix Plus options again and there is nothing there. I'm going to change the 'tabs.loadinBackground' back to False and reboot again.

Even though the browser.tabs.loadInBackground is set to True, the add-on is not stopping the loading of all of the tabs; it might as well not be there. I just checked the Tab Mix Plus options again and there is nothing there. I'm going to change the 'tabs.loadinBackground' back to False and reboot again.

Spørgsmålsstiller

I changed the 'browser.tabs.loadInBackground' back to True because changing it to False made no difference.

I still have all tabs loading, even with the add-on. Thanks

I changed the 'browser.tabs.loadInBackground' back to True because changing it to False made no difference. I still have all tabs loading, even with the add-on. Thanks
cor-el
  • Top 10 Contributor
  • Moderator
17421 løsninger 157408 svar

Did you try to disable TMP temporarily to see if that has effect?

You can also try to ask advice at the TMP forum to see if this is a known issue.

Tab Mix Plus forum:

Did you try to disable TMP temporarily to see if that has effect? You can also try to ask advice at the TMP forum to see if this is a known issue. Tab Mix Plus forum: *http://tmp.garyr.net/forum/viewforum.php?f=3

Spørgsmålsstiller

I tried disabling TMP but it had no effect. I have posted a question on their forum about it. I let you know if I hear something.

I tried disabling TMP but it had no effect. I have posted a question on their forum about it. I let you know if I hear something.

Spørgsmålsstiller

There only suggestion so far is to see how it is if I disable TMP; it had no effect.

There only suggestion so far is to see how it is if I disable TMP; it had no effect.

Spørgsmålsstiller

Their suggestion now is to disable add-ons until I find the one that is conflicting with 'Don't Open Until Select.' Since I have not added any tabs in about 6 months, that's not a factor.

So what's next?

Their suggestion now is to disable add-ons until I find the one that is conflicting with 'Don't Open Until Select.' Since I have not added any tabs in about 6 months, that's not a factor. So what's next?

Spørgsmålsstiller

I have since removed Testpilot (from Mozilla) and that has had no impact either.

Any suggestions are greatly appreciated.

I have since removed Testpilot (from Mozilla) and that has had no impact either. Any suggestions are greatly appreciated.