Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Autofill for more than one saved username/password no longer works (46.0.1).

  • 15 svar
  • 2 har dette problem
  • 1185 visninger
  • Seneste svar af stwtorpedo

more options

Autofill by typing the first character of a username when more than one username/password combination is remembered no longer works. Do not know if it is related to upgrade to 46.0.1 or not. It worked just fine up until about 2 weeks ago (beginning of May 2016). With only one username/password remembered, it works every time.

Valgt løsning

I stumbled upon the following while researching the problem a bit more today. If you right click in the username field, a drop-down opens containing, among other things, Fill Login with a sub-menu containing the two remembered sets of login info and View Saved Logins. Here you can select the desired username that will then be autofilled. This is about as close to a solution as I have seen so far. Believe it or not, I have recently noticed that the former drop-down appearance when typing the first character of the desired username does still actually happen, but very infrequently.

Læs dette svar i sammenhæng 👍 0

Alle svar (15)

more options

Are you talking about autofill or the Password Manager?

https://support.mozilla.org/en-US/kb/update-firefox-latest-version 46.0.1

more options

Thanks to FredMcD for the response. My answer to your question regarding autofill versus Password Manager is "I don't know". All I know are the symptoms as stated in my original query: if you have more than one username/password remembered, typing the first character of one of the usernames will not cause the entire username to be "autofilled" any longer. It has functioned perfectly for years up until about two weeks ago. If you have only one username/password remembered, it continues to work great by "autofilling" the entire username when the first character is typed. My Firefox indicates that it is up to date.

more options

First, let's check the Password Manager. Type about:preferences#security<enter> in the address bar.

Under Logins, Turn on Remember Logins To check the passwords you have listed, press Saved Logins.

more options

Hi Fred. Thanks for your continued interest. I checked the Security Option as you suggested. Yes, Remember Logins is set. My wife's and my username/passwords have both been remembered and are in Saved Logins for our ISP's email system. I have noted this many times in researching this problem. Have also removed both username/password login infos from Saved Logins and started fresh. With only one login info for the email system remembered in Saved Logins, the autofill works fine. With both login infos remembered, autofill when typing the first character of the username no longer works. The technicians at my ISP insist that it is not their bug.

more options

What happens when you "click" (or double-click) in the Username field when going to login to your email?

A drop-down of choices for the saved Usernames should appear and when you click on the one you want to use, both the Username and the Password should get auto-completed. That's how the Firefox Password Manager has always worked for me.

more options

Hi edmeister. Thanks for the reply. The cursor is usually in the username field, and single or doubling clicking in the field does nothing (I tried it at your suggestion). The way it has always worked for me in the past is to type the first character of the username desired (one of two remembered by Firefox), and the username and password are auto-completed from the one entry drop-down that is displayed. I have tried this on both our desktop computers, and with more than one set of login info remembered, it will no longer auto-complete. Had a tech at our ISP try it yesterday. Same results. When only one set of login info is remembered, it auto-completes perfectly.

more options

Multifox {web link} Multifox is an extension that allows Firefox to connect to websites using different user names. Simultaneously!

more options

There will never be an autofill when you have multiple names and passwords stored. You should be able to select one from the drop-down list that open if you start typing the name. If that list doesn't open then try to open the drop-down list with the cursor Down key.

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: "3-bar" menu button or Tools > Add-ons > Appearance
  • Do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

You can try to temporarily move the focus out of the input field by clicking elsewhere and click again in the name input field. You can also try to press the Tab key when a valid user name is typed to go to the password field to see if that makes Firefox fill the password.

Ændret af cor-el den

more options

Hi Fred,

You are correct. Maybe I have not been relating the issue quite right. For years, a drop-down would open after typing the first character of the desired username in the username field. However, it would only contain one username, that beginning with the character I had typed (not a list of the two remembered choices). Then when that username is clicked, it is auto-completed into the username field along with the associated password in the password field. For some reason, this ceased to function about two weeks ago. The username and password automatically appear in their fields of the email home page if only one username and password set remembered. I have changed nothing in Firefox in the way of settings or options or add-ons or extensions.

more options

Fred, Also, I assume the cursor down key you mentioned is the down arrow key. Nothing occurred when tried.

more options

Make sure that you do not run Firefox in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History).

  • Tools > Options > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use Private Browsing mode"

Are those pages using autocomplete="off" if you check that via the right-click context menu in the Inspector?

You can right-click and select "Inspect Element" to open the Inspector ("3-bar" menu button or Tools > Web Developer) with this element selected.

more options

Valgt løsning

I stumbled upon the following while researching the problem a bit more today. If you right click in the username field, a drop-down opens containing, among other things, Fill Login with a sub-menu containing the two remembered sets of login info and View Saved Logins. Here you can select the desired username that will then be autofilled. This is about as close to a solution as I have seen so far. Believe it or not, I have recently noticed that the former drop-down appearance when typing the first character of the desired username does still actually happen, but very infrequently.

more options

It's possible an add-on is causing the problem.

more options

Finally got a chance to try moving the focus outside the username input field by clicking elsewhere then clicking back in the username box. Then typing the first character of the username desired drops down that username only. Clicking on it autofills the username and the associated password just like it used to. Don't understand why yet but, it seems to work every time. Thanks so much for your help.