Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I make bookmarks automatically open in a new tab instead of in the current tab?

  • 22 svar
  • 1 har dette problem
  • 14414 visninger
  • Seneste svar af moz2u

more options

Currently all my bookmarks, especially those in the Bookmarks Toolbar always open in the current tab I'm looking at, thereby changing my current tab to a new one. I want to keep my current tab and simply click on a bookmark in the toolbar and have it open in a new tab, just like it does as a default setting in my other browser Maxthon. This crappy browser instead forces me to first click on a new tab and THEN choose my bookmark. I don't like clicking twice for a bookmark, I want to do it in ONE click, not two. So, once again, how do I make bookmarks automatically open in a new tab instead of in the current tab?

Valgt løsning

Hi, this add-on works for me: Open Bookmarks in New Tab.

There are other add-ons that open links/bookmarks in a new tab, such as -

Open Link in New Tab.

DblClicker.

Right Links.

If your question is resolved by this or another answer, please take a minute to let us know. Thank you.

Læs dette svar i sammenhæng 👍 2

Alle svar (20)

more options

Valgt løsning

Hi, this add-on works for me: Open Bookmarks in New Tab.

There are other add-ons that open links/bookmarks in a new tab, such as -

Open Link in New Tab.

DblClicker.

Right Links.

If your question is resolved by this or another answer, please take a minute to let us know. Thank you.

more options

Thanks for that. I guess I didn't intuitively think that such an option would require an add-on. I guess I expected it to be a standard option in the tabs settings. In my Maxthon browser it is the standard setting.

Ændret af Blackadam den

more options

Note that you can middle-click a bookmark like any link with the mouse scroll wheel to open the link in a new tab.

more options

It just makes you wonder how on earth this could have possibly occurred. Do these designers not use their own browser with bookmarks? Its ridiculous the way it is now. Could there be something in the software that is preventing this from being implemented? If so, tell us! At least we know you're aware, realize its silly, and are working to rectify the situation.

Partial solution: Use the Control key while clicking the link and it will open in a new tab. It works the same if you're are navigating by the keyboard. Just hold the Control key down when your item in highlighted and you hit the Enter key.

C'mon Mozilla. Please fix this glitch. Or at least warn the user. Many, many people will lose their place when this Bookmarks program hijacks their present URL to launch them unaware to the next. Nobody does this. Because its really illogical. Illogical is a very polite way of putting it. Its just plain stupid.

more options

Well the "Open Link in New Tab" was installed. Didn't seem to do anything. Maybe I have to restart Firefox. Will try.

more options

Ever since I updated to firefox 47 the right click /open in new tab or window is not available ,will this be fixed??

more options

tfinniii said

Ever since I updated to firefox 47 the right click /open in new tab or window is not available ,will this be fixed??


Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

more options

went to safe mode and could not find my bookmarks. reloaded page normally and we have a miraculous recovery, no way safe mode would would work any different then normal mode . I hate it when the first thing someone says is to use safe mode as if the person with problem has any idea what to do!

more options

tfinniii said

... I hate it when the first thing someone says is to use safe mode as if the person with problem has any idea what to do!

I hate it when people requesting support don't read the hyperlinked support articles.

See this - Firefox Safe Mode

And this - Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

My guess is an extension that lost some compatibility in Firefox 47.0.

more options

I read the support articles even if they are the same ones that are given for many different problems.

Ændret af tfinniii den

more options

I have seen some others who are having problem with right click and the open in new tab,window are greyed out, as after some use mine started doing this again. One person said this started after reloading and working ok 'till they went to customize page.

more options

tfinniii said

I have seen some others who are having problem with right click and the open in new tab,window are greyed out, as after some use mine started doing this again. One person said this started after reloading and working ok 'till they went to customize page.

Yes, after you use Customize in Firefox 29+, the right-click context menu becomes mostly disabled on the Bookmarks menu on the classic menu bar in the current window. This effect (bug) is per window, so you can launch a new window as a workaround, either using the menu / Ctrl+n or if you have more than one tab open, you can right-click the current tab and choose Move to New Window (or click and drag the tab downwards to tear it off the tab bar to a new window).

Ændret af jscher2000 den

more options

Mine worked fine until I downloaded FF 47, as it had worked ok before that.

more options

Thanks. That did the trick. Pity it isn't standard.

more options

One has to wonder what kind of mind would implement such an illogical decision as this. And, even more bewildering, why it wasn't corrected. Sounds like its been going on for years. Like a car maker that forgets to include the brake pedal. Then continues to offer the same product with the same deficiency for years afterwards. I see this all the time in technology: A total and complete lack of common sense, a lack of understanding of real world function. Web design, phone systems and most software is abundant in total senseless design. What planet do these people live on one wonders?

more options

moz2u said

One has to wonder what kind of mind would implement such an illogical decision as this. And, even more bewildering, why it wasn't corrected. Sounds like its been going on for years. ... What planet do these people live on one wonders?

What planet are you from?

Easily 'fixed' via an extension. The way it has always worked with Firefox is that when you're looking for a feature that Firefox doesn't have, you look for an add-on that "adds" that feature to Firefox. Similar for Firefox features that you 'think' are wrong or bassackwards; install an add-on to 'straighten it out'.

more options

Extensions are nice until the latest FF update makes them defunk Then you have to search and find another extension and hope that works and isn't blitzed by the next update. I thought the right click WAS part of FF normal set-up , that is being greyed out now ?!?

more options

Hi tfinniii, where is right-click grayed? I mentioned the bug I know about (Customize). Is there a new one? What are the steps to reproduce it?

more options

There is an answer to all of these problems. Do not use Firefox as a place to store your bookmarks. It has many deficiencies as does EVERY browser's bookmarks system. The answer is to use a separate, stand alone bookmark program that interfaces with all the browsers we all use. Because no browser does everything best. So you use whichever is best suited for the task at hand. And all your bookmarks should integrate with whichever browser that is.

So has anyone found a bookmark program that interfaces with at least Firefox and Chrome?

I'm almost at the point where I'd consider using a text based system. Each URL is in a RTF, DOC or TXT file. Not sure if either is preferable. These files can be grouped in folders or subfolders just like browsers use. To store you just copy and paste the text from your browser's Address Bar to the file. To go to a link you copy and paste the link from the text file to whichever browser you are using at that moment. Not as slick but simple and effective. To set up it would be a royal pain if you have thousands of bookmarks like I do, but after that it might work very efficiently.

more options

jscher2000 said

Hi tfinniii, where is right-click grayed? I mentioned the bug I know about (Customize). Is there a new one? What are the steps to reproduce it?

No ,I was just commenting on FF screwing up.

  1. 1
  2. 2