Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

context hover popup menus: wrong colors in FF46

  • 13 svar
  • 161 har dette problem
  • 3376 visninger
  • Seneste svar af isufosjefoi

more options

Just installed FF46 on a Kubuntu system this morning. All my context/popup/hover menus have changed to Black text (on original dark background).

How can I change text color to White as it was up to FF46??

I have tried to take a snapshot but it is impossible since I need the mouse to select and the hover menus dissapear as soon as I move the mouse. Catch 22. (edit: found a way to get screenshot)

Vedhæftede skærmbilleder

Ændret af Golem den

Valgt løsning

Not a Fix: but at least an acceptable workaround.

From my Kubuntu settings, I changed the color of the Tooltip Background, to a blue that does NOT interfere with the OS and lets Firefox display Hover/Context Menus in a reasonable way.

Firefox, I still wish you would change YOUR settings to display the appropriate Text color. Thanks.

Læs dette svar i sammenhæng 👍 14

Alle svar (13)

more options

Does no one know of an about:config change that can be applied to change Text Color in all the Popup/Context menus

I have found a few entries but do not want to touch anything until I am sure. When I did change some of them, nothing happened.

No luck searching Google since all items found date from 2009 to 2012 and talk about Chrome folder and CSS files that are nowhere to be found on FF 46 or Add-Ons that do not work in latest FF.

This was not a problem in FF 45.0.2, so it's a new change. What is the change and how can it be returned to the original value???

Thanks all.

more options

Are you using a High Contrast setting in the Linux OS or is this a full theme?

  • Edit > Preferences > Content : Fonts & Colors > Colors : "Override the colors specified by the page with my selections above"
more options

cor-el said

Are you using a High Contrast setting in the Linux OS or is this a full theme?
  • Edit > Preferences > Content : Fonts & Colors > Colors : "Override the colors specified by the page with my selections above"

Thanks for the input.

I am using Out Of The Box color theme that came with Kubuntu 14.04 LTS (whatever it is) and have never changed anything. I tried all the different color change settings inside Firefox and even tried changing to different Themes/Colors in Kubuntu. The entire system displays Hover/Context menus in the appropriate colors but ONLY Firefox 46 started using Black Text instead of white.

I tried starting Firefox in safe mode, no change. Rebooted my VmWare Kubuntu, no change either.

I can't post a Bug Report because I am not a member. If someone here is, please escalate this new bug.

Hoping there is a config entry that applies to Text in Hover menus.

more options

Additional tests I have performed today.

This morning I burned an ISO of Kubuntu 14.04 to a DVD and booted it on a different computer.

The only thing I did was to run the older version of Firefox (39) that came with the ISO. Context/Help/Hover menus and were White (ish) text on Black (dark) background.

From this version 39, I downloaded Firefox 46 from Mozilla source as a tar file, extracted it to Download folder, ran Firefox from Command Line and the BUG is fully apparent. Context/Help/Hover menus and were BLACK text on Black background.

So it is not something I did wrong on my main install of Kubuntu. It is not something Kubuntu has changed or done when THEY updated Firefox from the repository. It is a little BUG with Firefox 46.

Can this be solved?

Anyone???

more options

Will look into GTK (???), though I am not a super user when it comes to changing Base Linux code. I visited the page and it says Firefox would NOT run if...missing bunch of code. Since it runs, I guess I have what is needed.

I will continue to investigate

Ændret af Golem den

more options

Firefox 46 uses GTK 3.4 on Linux, so you could check the GTK settings.

more options

Yes you may have essentially been using a different GTK theme before when using Firefox 45 and older like say a GTK2 Theme.

Firefox 46.0 from mozilla.org does not work with GTK 2 Themes as it needs at least GTK 3.4+ and GTK 3.4+ Themes to theme it now. So whatever GTK 3 Theme you have in use is causing the issue likely.

According to distrowatch.com the old Kubuntu 14.04 comes with GTK 3.10.8 on a new install. However since it is a KDE desktop the GTK themes may not be a priority by default.

At least you are able to run Firefox 46.0 as Ubuntu (and flavors) distros users are getting Firefox crashes with 46.0 when using the Oxygen GTK theme.

Ændret af James den

more options

James

I have no clue what any of this means, but I will look into Theme changes. Thanks for the information.

As I said, I use Linux in a VmWare, run the original installs and leave it at that. I never change anything, no colors, no themes, no fonts, no nothing because when I do, all heck breaks loose and I can't use the distro anymore. Case and point, with my trying to change settings in this Distro for this problem, I somehow screwed up the Fonts and I can't get them back to what they were because I have no clue how I caused the problem.

I will try changing themes since going to Kubuntu 16.04 is not in the cards for now. My basic testings resulted in a very bad experience as 16.04 does not seem as stable and does not look as good as 14.04

Once again, thanks for the input.

P. S. I am using the out of the box Kubuntu and yes, it's running the Oxygen theme (at least I know that). Do you have any suggestion for a theme that would work?

more options

Well I cannot really say what GTK 3 Theme options that Ubuntu can have as I do not use a Ubuntu flavor let alone will never a KDE or a LTS one.

If I want a new GTK Theme I go to places like http://gnome-look.org/index.php?xcontentmode=167


The Oxygen theme crashes I mentioned was more of a issue for those still using the old 12.04 LTS (and not 14.0.4 LTS and newer) and users who updated the GTK from the old 2.24.x to 3.4+ and had the version of Oxygen-GTK3 it has in use.

Ændret af James den

more options

Ok All

I give up. Unless someone comes up with an About:config tweak, I will have to live with this horrible mess. Incredible that you can change the launch codes for the Missile Defense system of the White House with About:config, but not text color.

This is not the place to bore you with Linux problems, but Ubuntu/Kubuntu 16 (though Firefox works perfectly there) is just too much of a pain in the back part to use. Trying to find another distro that installs and works like I need.

Thanks to all who tried.

Ændret af Golem den

more options

Valgt løsning

Not a Fix: but at least an acceptable workaround.

From my Kubuntu settings, I changed the color of the Tooltip Background, to a blue that does NOT interfere with the OS and lets Firefox display Hover/Context Menus in a reasonable way.

Firefox, I still wish you would change YOUR settings to display the appropriate Text color. Thanks.

more options

kubuntu / edubuntu 14.04.5 LTS

I couldn't quite figure out Golem's answer .... I did System Settings > Colors and changed Scheme to "Oxygen Cold" and now the tooltips have a cool white-blue gradient background.

more options

Hi, I have been having the same problem for a while now. I was able to track down the problem to the Kubuntu package gtk3-engines-oxygen. If you choose a GTK theme, that does not depend on the gtk3-oxygen engine, then the problem vanishes. There were a couple of other subtle annoyance that were caused by that engine: In my case, the context menus were invisible (only the shadow around them was drawn) and I could not click on the bookmarks in the file chooser dialog and sometimes the cursor behaved as though I was holding down the mouse button in the file chooser dialog. All of this was solved by changing to a different GTK3 theme. I chose one that is reasonably similar to the Oxygen theme. These are the detailed steps:

1. Download another GTK3 theme. I used the Gnome Cupertino theme (also to be found on gnome-look.org): https://dl.opendesktop.org/api/files/download/id/1461782792/147061-Gnome-Cupertino-2.1.5.tar.gz 2. From the tar.gz file, extract the directory Gnome-Cupertino/gtk-3.0. 3. Make a backup of the original gtk-3.0 theme, in case you need to go back: sudo mv /usr/share/themes/oxygen-gtk/gtk-3.0 /usr/share/themes/oxygen-gtk/gtk-3.0~ 4. Move the Cupertino theme to the above directory: sudo mv Gnome-Cupertino/gtk-3.0 /usr/share/themes/oxygen-gtk/ 5. Restart Firefox.