Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Don't start automatic download when showing the download dialog.

  • 3 svar
  • 6 har dette problem
  • 10 visninger
  • Seneste svar af cor-el

more options

Firefox starts to download a file immediately the download dialog shows up. At most times, I don't want to save but this automatic download means wasted data when I don't actually save the file. Can I get an option to tell the download dialog not to start downloading till I browse to wherever I want to save the file and click on save?

Firefox starts to download a file immediately the download dialog shows up. At most times, I don't want to save but this automatic download means wasted data when I don't actually save the file. Can I get an option to tell the download dialog not to start downloading till I browse to wherever I want to save the file and click on save?

Alle svar (3)

more options

Hello brainites, go from the 3-bar menu on your right-up > Options > General > in Downloads area check the "Always ask me where to save files" > close the tab > exit firefox and restart it. Probably you are ok now :-)

General panel, Downloads

thank you

Ændret af ideato den

more options

Hello ideato, Thanks for the reply. But my Firefox is already set to ask for where to download the file. Perhaps my question wasn't clear enough. Because I have already set it to ask where I am supposed to download, the dialog(not operating system's the save dialog) appears. I mean that dialog where you will select either you want to open or save the file. The issue is as soon as that dialog shows up, Firefox starts downloading the file in the background. So before I chose to open or save from that Firefox dialog which will then bring up the Operating Systems save dialog, either part or the entire file has been downloaded. This speeds up the download process. I lost 2Gig data because I downloaded a 2Gig initially then realized later that the download link was clicked twice hence another 2Gig gone as Firefox downloaded the file while showing the Firefox's download dialog. I has happened on other occasions although the files weren't that large.

more options

It is not possible to disable automatically starting the download once you click the button. You will have to cancel the download as quickly as possible if you do not want to save the file and abort this action.

Firefox immediately starts downloading the file in the background and saves the file to the temp folder and doesn't wait until you specify the name and the location (destination folder).