Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How can I stop pages starting "data:text/html;" aka URI?

  • 2 svar
  • 1 har dette problem
  • 46 visninger
  • Seneste svar af jscher2000

more options

Inadvertently, I visit a site infected with malware.

Somehow it generates a new window that has "data:text/html,base64,PN..." in the address bar.

The base64 coding is obfuscation of a malicious payload that starts running scripts and opening more pages and trying to wreck ongoing havoc with my system. Thank <deity> for other protections running in my system...

I have NoScript and Adblock Plus installed, but neither catch the initial launch via the URI.

Is there something I can set in about:config that will stop FF from processing the data:/text/html URI?

And how the heck are these windows with data:/text/html in the address bar being launched, as I have FF pop-up blocking active?


PS: It might have been "data:text/html;", semicolon vs comma.

Ændret af HiTechHiTouch den

Alle svar (2)

more options

.....

Ændret af HiTechHiTouch den

more options

I don't know whether there is a setting or trick to stop Firefox from loading data URIs (or non-image data URIs, since the images probably are okay).

Regarding the source:

(1) Have you checked for any unknown extensions? Usually you can disable them on the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then cast a critical eye over the list on the right side.

If you want a second set of eyes on your list, you can copy/paste it from the Troubleshooting Information page. Either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

Scroll down to the Extensions heading and you can select from there to the end of the table, copy (Ctrl+c) and paste (Ctrl+v) into a reply. It's also helpful to compare in case you have a "self-hiding" extension.

(2) I assume you have scanned for malware? If not, try the scanning/cleaning tools listed in our support article: Troubleshoot Firefox issues caused by malware. These on-demand scanners are free and take considerable time to run. If they finish quickly and especially if they require payment, you may have a serious infection. I suggest the specialized forums listed in the article in that case.

(3) In rare cases, infections are launched from an Autoconfig file in Firefox's program folder. To eliminate that, you can use this approach:

Clean Reinstall

We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed.

(A) Download a fresh installer for Firefox 44.0.2 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.)

(B) Exit out of Firefox (if applicable).

(C) Rename the program folder as follows:

(32-bit Firefox on 64-bit Windows)

C:\Program Files (x86)\Mozilla Firefox

to

C:\Program Files (x86)\OldFirefox

(Other systems)

C:\Program Files\Mozilla Firefox

to

C:\Program Files\OldFirefox

(D) Run the installer you downloaded in step (A). It should automatically connect to your existing settings.

Any improvement?

Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders, but for obvious reasons, don't just copy everything over:

  • \OldFirefox\Plugins
  • \OldFirefox\browser\plugins