Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox doesnt show embeded youtube videos on websites

  • 2 svar
  • 13 har dette problem
  • 5233 visninger
  • Seneste svar af jeyaganesh

more options

Firefox 45.0b3 doesnt show embedded youtube videos on websites. But it shows videos on Youtube website with no problem. It says 'Connection is not secure' for sites like Gizmodo and Slashfilm where embedded youtubes are not showing; But I can see Vimeo videos on those sites.

Embedded youtube videos are playing on Google Chrome and Safari.

Please give me some solution to fix this problem. Thanks in advance, Jay

Valgt løsning

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)?

Firefox 42+ has a Tracking Protection feature that is enabled by default in Private Browsing mode. When you are in private browsing mode then Firefox can show a shield icon at the left end of the location/address bar that some content is affected.

You can disable this feature in "Options/Preferences > Privacy" or via the about:privatebrowsing page that get when you open a New Private Window.

  • Options/Preferences > Privacy: "Use Tracking Protection in Private Windows"

If you use extensions (3-bar Menu button/Tools > Add-ons > Extensions) that can interfere with loading content (e.g. Adblock Plus, NoScript, Flash Block, Ghostery) then make sure that such extensions do not interfere with loading content. There is security software that can interfere with loading content, so check that as well.

Læs dette svar i sammenhæng 👍 3

Alle svar (2)

more options

Valgt løsning

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)?

Firefox 42+ has a Tracking Protection feature that is enabled by default in Private Browsing mode. When you are in private browsing mode then Firefox can show a shield icon at the left end of the location/address bar that some content is affected.

You can disable this feature in "Options/Preferences > Privacy" or via the about:privatebrowsing page that get when you open a New Private Window.

  • Options/Preferences > Privacy: "Use Tracking Protection in Private Windows"

If you use extensions (3-bar Menu button/Tools > Add-ons > Extensions) that can interfere with loading content (e.g. Adblock Plus, NoScript, Flash Block, Ghostery) then make sure that such extensions do not interfere with loading content. There is security software that can interfere with loading content, so check that as well.

more options

Hi Cor-el,

Thank you so much for your reply :)

After disabling "Use Tracking Protection in Private Windows", embedded Youtube video started working once, then stopped showing up again.

Then I disabled "youtube.com/embed/*" in custom filter of Adblock Plus. I dont remember whether I blocked the embedded youtube videos myself. Now all embedded youtube videos are working.

I also enabled "Use Tracking Protection in Private Windows" again.

Thanks again :-) Jay