Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Javascript causing crashes

  • 14 svar
  • 1 har dette problem
  • 1302 visninger
  • Seneste svar af maveet

more options

I've been troubleshooting for issues of Firefox hanging. It is primarily with one location, full of media content: http://www.theguardian.com/au

First, I closed some windows with many tabs, which didn't help. I followed instructions for increasing speed by changing settings for pipelining, which did not seem to help. I started to, but did not, change places settings. Also looked at suggestions re shockwave, but do not think I followed any.

Then I downloaded YesScript. This has solved the loading/hanging problem. But it has also made viewing comments in their normal presentation impossible. Even when I turn YS off, the comments do not load in a useful way.

Since it now appears that my primary problem is due to javascript, is there any other way I can rectify the problem? Thanks.

Ændret af maveet den

Valgt løsning

I'm closing this question. Problem seems solved. Minor slow-downs continue, but nothing like the hanging problems of earlier. If I get annoyed enough, I'll go through the extensions at a later date. Thanks for your help.

Læs dette svar i sammenhæng 👍 0

Alle svar (14)

more options

Disregard. Edited above to include what was added here.

Ændret af maveet den

more options

Make sure your Java (Not JavaScript) is up to date Verify Java and Find Out-of-Date Versions {web link}

Version 8 Update 66 Release date November 16, 2015 http://java.com/en/download/manual.jsp

https://java.com/en/download/help/ Java Help Center


Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. Is the problem still there?

more options

Thank you Fred. This appears to have solved the problem. I remember getting rid of java some time ago, thought I'd only downloaded it for a particular task, and didn't need it. ha. Very happy to have these pages loading without a glitch. :-)

more options

Unfortunately, I'm again having problems, hanging while loading. Any idea what I should try next? thanks

more options

Have you checked the Java Help Center?

more options

You can check for problems with preferences.

Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases.


Start Firefox in Safe Mode to check if one of the extensions (Firefox menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox menu button/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

FredMcD said

Have you checked the Java Help Center?

Thanks. I just went there, looked at my plug-ins, and Java was set on 'Ask to Activate'. I changed it to always activate, will see if this does the trick.

cor-el [[#answer-831908] Thank you. if the above does not work, I'll follow your suggestions.

Ændret af maveet den

more options
  • I went to Java Help, and saw that my Java applet wasn't activated. I activated it, but this did not help.
  • I Disabled Add-ons. But this did not seem to show me anything.
  • I looked at my add-ons, and it looks like it would take forever to try turning each one off and checking for the problem. I chose the one I thought might be the most likely: Privacy Badger. But this has not changed anything, sitll hanging, I'm having to force-quit.
What else I've done:
  • Delete Duplicate Session Restore files
  • Turn off Hardware Acceleration

Can you advise which of the 2 procedures I'm listing below is the next best step? I haven't wanted to go deleting things until I'd done other possibilities. Is the 2nd one, cor-el's suggestion, going to reset all my style and extension preferences? so I have to load everything back in again?


In the Firefox profile folder, find and rename the files places.sqlite to places.sqlite.old and places.sqlite-journal to places.sqlite-journal.old (if it exists).

Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases

I'm not finding these prefs, neither in my Finder (OSX), nor in about:config. In about:config I get the 2 lines I'm attaching as file. In Finder, I get a text doc, 2nd attachment.

ADD: I can't upload the Grab files. :-(

I must be missing something, probably something obvious. thanks for helping.

more options

This afternoon I installed places maintenance extension. It said no problems. But still, when I look in about:config, there is no places.sqlite.

more options
  • If you have many extensions then first enable half of the extensions to test which half has the problem.
  • Continue to divide the bad half that still has the issue until you find which one is causing it.

places.sqlite and places.sqlite-shm and places.sqlite-wal are file in the Firefox profile folder and not prefs stored in prefs.js.

The point with (temporarily) renaming/moving or deleting files in the profile folder is to check for issues caused by specific data stored in this file. The prefs.js file stores setting that you make in Options/Preferences among other data.

more options

In the Firefox profile folder, find and rename the files places.sqlite to places.sqlite.old and places.sqlite-journal to places.sqlite-journal.old (if it exists).

OK, found places.sqlite in pref folder, renamed .old. No other places. files.

No user js; no numbered prefs-##.js files;

rename (or delete) the prefs.js file I added .old.

That's enough for tonight, I'll be re-starting and see how it goees tomorrow.

Is it possible this is caused by too many tabs? I've read numerous references to hundreds of tabs, so I'm certainly not the only one. The bulk of my tabs are not loaded.

Thanks cor-el.

more options

So far, in my first attempts at AM news, this seems to have helped considerably, I was worried I'd lose all my settings, bookmark bar, but happily that's all intact. I'll leave this question open for the next day or so, see how it goes. Thanks.

more options

My problem seems almost fixed. I'm not needing to use YesScript for Guardian anymore, but am still having occasional slow-downs, hanging. Any suggestion of what I should do next? Go through all the extensions? Thanks for your help.

Ændret af maveet den

more options

Valgt løsning

I'm closing this question. Problem seems solved. Minor slow-downs continue, but nothing like the hanging problems of earlier. If I get annoyed enough, I'll go through the extensions at a later date. Thanks for your help.