Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox keeps being signed out of google services whenever a session is closed

  • 4 svar
  • 5 har dette problem
  • 3622 visninger
  • Seneste svar af DarkOverord

more options

Or more specifically, when I start up a new session, I'm always brought to the "enter your password to continue" screen (Screenshot attached in case you're not sure what page I mean)

Now Firefox remembers my password so it's not exactly hard to just click "Sign In" but it's more a convenience thing, and bewilderment that my FF install on another of my PC's isn't having the same issue. I thought it may be an issue with the GMail notifier I was using (https://addons.mozilla.org/en-GB/firefox/addon/fastest-notifier-for-gmail/) so I disabled that and restarted FF. No success.

I've attempted to clear my cookies for google three times, one just deleting the google.com cookies, second deleting them all internally via FF and the last time removing cookies.sqlite file in case that was corrupt or similar. However all three of these attempts after signing in to Google and restarting Firefox bring me back to the login screen on my next browsing session.

This is exclusive to Google however, other websites I use only log me out when the relevant cookie expires so I'm not sure what Google's cookies are doing differently to other sites to cause this.

Hopefully one of you guys has a good idea of what's going on and are not as stumped as I am!

Vedhæftede skærmbilleder

Ændret af DarkOverord den

Valgt løsning

Do you have an allow exception for cookies from Google?

Also make sure that the remember me check box on the log in page doesn't have a tick.

Læs dette svar i sammenhæng 👍 1

Alle svar (4)

more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox menu button/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

This issue can be caused by corrupted cookies or cookies that are blocked.

If clearing cookies didn't help then it is possible that the cookies.sqlite file in the profile folder that stores the cookies got corrupted.

  • Rename (or delete) cookies.sqlite (cookies.sqlite.old) and if present delete cookies.sqlite-shm and cookies.sqlite-wal in the Firefox profile folder in case cookies.sqlite got corrupted.

You can use this button to go to the current Firefox profile folder:

more options

No luck in Safe Mode (including closing out of safe mode and reopening in safe mode to be sure), still asking to sign in. The cookies issue suggestion is already covered in my initial post (Though I called the sqlite file a folder for some reason). Sorry!

Ændret af DarkOverord den

more options

Valgt løsning

Do you have an allow exception for cookies from Google?

Also make sure that the remember me check box on the log in page doesn't have a tick.

more options

I have no exceptions... The second suggestion however, worked.

I have no words for how bewildered I am that a "Stay signed in?"/"Remember me?" tickbox working the opposite as intended. Thanks!