X
Tryk her for at gå til webstedets mobilversion.

Supportforum

How to stop links from opening new tabs in Firefox

Skrevet

When I used to use Firefox, and I would click on a link, it would open in the same page/tab. Now for some reason, new links are always opening in a tab, which is annoying and time consuming. How do I stop links from opening in a new tab? I used to have to select right-click for this, but now somehow it's automatic.

thanks.

When I used to use Firefox, and I would click on a link, it would open in the same page/tab. Now for some reason, new links are always opening in a tab, which is annoying and time consuming. How do I stop links from opening in a new tab? I used to have to select right-click for this, but now somehow it's automatic. thanks.

Yderligere systemdetaljer

Installerede plugins

  • Adobe PDF Plug-In For Firefox and Netscape 10.1.0
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • Nitro PDF Plug-in for Firefox and Chrome
  • 4.0.50401.0

Program

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0

Yderligere information

Luk
FredMcD
  • Top 10 Contributor
4347 løsninger 61127 svar

Some links are programmed to open in new tabs / windows. The only real way to override this is to right click the link.

Some links are programmed to open in new tabs / windows. The only real way to override this is to right click the link.

Spørgsmålsstiller

Let me give you an example: I go to log into my email, I click on the link to bring up the page, which now opens in a new tab (it didn't use to do this). I enter my log in information and then the webmail opens in a third tab.

Before all this would just open in the same page.

Let me give you an example: I go to log into my email, I click on the link to bring up the page, which now opens in a new tab (it didn't use to do this). I enter my log in information and then the webmail opens in a third tab. Before all this would just open in the same page.
FredMcD
  • Top 10 Contributor
4347 løsninger 61127 svar

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.

Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies<br> '''''Warning ! ! '' This will log you out of sites you're logged in to.''' Type '''about:preferences'''<Enter> in the address bar. * '''Cookies;''' Select '''Privacy.''' Under '''History,''' select Firefox will '''Use Custom Settings.''' Press the button on the right side called '''Show Cookies.''' Use the search bar to look for the site. Note; There may be more than one entry. Remove '''All''' of them. * '''Cache;''' Select '''Advanced > Network.''' Across from '''Cached Web Content,''' Press '''Clear Now.''' If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} While you are in safe mode; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites. Are there any problems? Then restart.
the-edmeister
  • Top 25 Contributor
  • Moderator
5425 løsninger 40503 svar

If a webpage is coded for "_new" or "_blank" which is 'code' for opening a new window, Firefox is going to open a new window or a new tab (if you have Open new windows in a new tab instead selected in Options). That is the limit of 'control' that you have in Firefox, unless your webmail service provider has its' own options or preferences in the software they use. Sometimes a preference like that is 'bundled' with the selector for text only or rich text (HTML) for email display.

If you tell us which webmail service (Gmail, Xfinity, Yahoo, etc) you are using, a support contributor might be familiar with that service provider and be able to advise you if that preference exists and where to find it in the webmail UI.

Or ask them for support.

If a webpage is coded for "_new" or "_blank" which is 'code' for opening a new window, Firefox is going to open a new window or a new tab (if you have '''Open new windows in a new tab instead''' selected in Options). That is the limit of 'control' that you have in Firefox, unless your webmail service provider has its' own options or preferences in the software they use. Sometimes a preference like that is 'bundled' with the selector for text only or rich text (HTML) for email display. If you tell us which webmail service (Gmail, Xfinity, Yahoo, etc) you are using, a support contributor might be familiar with that service provider and be able to advise you if that preference exists and where to find it in the webmail UI. Or ask them for support.
cor-el
  • Top 10 Contributor
  • Moderator
17779 løsninger 160821 svar

See:

For links opened via JavaScript you can look at this pref:

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

See: *http://kb.mozillazine.org/browser.link.open_newwindow *1: current tab; 2:new window; 3:new tab; For links opened via JavaScript you can look at this pref: *http://kb.mozillazine.org/browser.link.open_newwindow.restriction You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config

Spørgsmålsstiller

Thank you co-el, I carefully tried the steps 1 at a time but the annoying browser behavior continued. I do not know why. I did not have this before.

I think my post of my original problem has been clear in that I am noticing a change of brower behavior and not trying to insist that every tab opens in the original window. This is unrelated to my email service provider (as some suggested) as I do not encounter this behavior using work computers - for any of my email accounts - in the way that the current firefox browser as  been behaving.

I simply uninstalled Firefox and installed U-light. I have a simple fast browser that does not insist on opening tab after tab after tab during the log in process.

Thank you co-el, I carefully tried the steps 1 at a time but the annoying browser behavior continued. I do not know why. I did not have this before. I think my post of my original problem has been clear in that I am noticing a change of brower behavior and not trying to insist that every tab opens in the original window. This is unrelated to my email service provider (as some suggested) as I do not encounter this behavior using work computers - for any of my email accounts - in the way that the current firefox browser as been behaving. I simply uninstalled Firefox and installed U-light. I have a simple fast browser that does not insist on opening tab after tab after tab during the log in process.
cor-el
  • Top 10 Contributor
  • Moderator
17779 løsninger 160821 svar

Start Firefox in Safe Mode to check if one of the extensions (Firefox menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox menu button/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) to see if that has effect.

Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox menu button/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes ----- Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) to see if that has effect. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/ *http://www.7tutorials.com/4-ways-boot-safe-mode-windows-10